Bug 651832 - JBossas5: auto discovery of JBossAS5 fails after uninventory.
JBossas5: auto discovery of JBossAS5 fails after uninventory.
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
Unspecified Unspecified
low Severity medium (vote)
: ---
: ---
Assigned To: Lukas Krejci
Corey Welton
:
Depends On:
Blocks: jon241-bugs
  Show dependency treegraph
 
Reported: 2010-11-10 07:10 EST by Sudhir D
Modified: 2011-05-23 21:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:07:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sudhir D 2010-11-10 07:10:10 EST
Description of problem:
The auto discovery of jbossas5 server failed after I uninventory, it never auto discovered the jbossAS5 server.

Version-Release number of selected component (if applicable):
rhq-server-3.0.1-SNAPSHOT build# 8469bdd

How reproducible:
Always

Steps to Reproduce:
1. Install rhq-server and rhq-agent where JBossAS5 server is running. Ensure that jboss-as-5 plugin is present.
2. Import the auto discovered JBossAS5 server.
3. Uninventory the JBossAS5 server.
4. Restart both rhq server and agent and JBossAS5 server.
  
Actual results:
JBossAS5 server is not auto discovered.

Expected results:
JBossAS5 server should be auto discovered.

Additional info:
I can see that the pid of the JBossAS5 server picked up in log but it just does not show up in the auto discovery queue.
Comment 1 Lukas Krejci 2010-11-18 14:38:30 EST
I could not reproduce this with the latest RHQ build.

Could you please try once more and if you are still experiencing this, could you provide as much detail about the RHQ server and agent installs as well as the AS5 server as possible?
Comment 2 Charles Crouch 2010-12-13 18:34:59 EST
Pushing to ON_QA to retest
Comment 3 Rajan Timaniya 2010-12-14 05:24:09 EST
Tested on JON 2.4.1 build #41 (build number: 10963:e46b3e2)

I couldn't reproduce this with JON-241 build #41.

I found NoSuchMethodException in agent.log during bug verification and filed separate bug for it (bug #662978).
Comment 4 Corey Welton 2011-05-23 21:07:49 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.