Bug 65213 - wireless no longer working: orinoco driver problems since upgrade to RH 7.3
wireless no longer working: orinoco driver problems since upgrade to RH 7.3
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-20 09:02 EDT by Telsa Gwynne
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 13:22:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2002-05-20 09:02:06 EDT
Description of Problem: wireless networking no longer works since upgrading
to RH 7.3 on a Sony Vaio PCG-SR1K with a Compaq WL100 pcmcia card in it.
It worked on RH 7.2.

Light on card blinks as though reception is poor.
"eth0: Tx timeout! Resetting card" is scrolling continuously on the console
and filling up dmesg.
All attempts even to ping other boxes fail.

Rebooting to grab dmesg output before the continuous "Tx timeout" messages
fill it up, I see this in dmesg.

hermes.c: 16 Jan 2002 David Gibson <hermes@gibson.dropbear.id.au>
orinoco.c 0.09b (David Gibson <hermes@gibson.dropbear.id.au> and others)
orinoco_cs.c 0.09b (David Gibson <hermes@gibson.dropbear.id.au> and others)
eth0: Station identity [it got this right]
eth0: Looks like an Intersil firmware version of 0.06
eth0: Intersil firmware earlier than v0.08 - several functions not supported
eth0: Ad-hoc demo mode supported
eth0: MAC address [it got this right]
eth0: Station name [it got this right]
eth0: ready
eth0: error -5 reading info frame. Frame dropped.
eth0: Tx error, status 4 (FID=00AC)
NETDEV WATCHDOG: eth0: transmit timed out.

The last three lines cycle again and again. 

Let me know what else you need. The difficulty is that I have lost my
ethernet pcmcia card, there is no floppy drive, and burning a CD with an
update seems a bit stupid. I shall borrow an ethernet card, and any really
long logfiles may have to wait until after I have done that: currently I 
can't just paste it :)
Comment 1 Arjan van de Ven 2002-05-21 05:49:26 EDT
Thankfully we also ship the 7.2 driver, with the orinoco_old_cs name.
to use it, you need to edit /etc/pcmcia/config file around line 966
(eg where your card is) and replace

bind "orinoco_cs"

with

bind "orinoco_old_cs"

Comment 2 Warren Togami 2002-05-22 06:47:13 EDT
arjanv, where can I find other documented cases where the new orinoco_cs is
broken (necessitating the shipping of the old driver)?
Comment 3 Kevin R. Page 2002-07-17 13:22:28 EDT
This may be a dup or related to bug #65097. Anyway, upgrading my kernel to
kernel-2.4.18-5 fixed the reset errors for me.

Note You need to log in before you can comment on or make changes to this bug.