Bug 652318 - udev complains many times "ressize 4096 too short" in a boot sequence
udev complains many times "ressize 4096 too short" in a boot sequence
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 649530 657805 700666 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-11 11:10 EST by Martin Poole
Modified: 2011-05-06 08:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: udev-161-6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 488554
Environment:
Last Closed: 2010-11-16 18:14:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2010-11-11 11:10:35 EST
+++ This bug was initially created as a clone of Bug #488554 +++

Description of problem:

The following show up while booting:

Starting udev: udevd-event[964]: ressize 4096 too short

udevd-event[1245]: ressize 4096 too short



----
Comment 1 Martin Poole 2010-11-11 11:12:08 EST
Following the debug instructions in the previous version of this bug I was able to log the following.


Nov 11 15:56:13 d10 udevd[547]: seq 3121 forked new worker [3286]
Nov 11 15:56:13 d10 udevd-work[3286]: seq 3121 running
Nov 11 15:56:13 d10 udevd-work[3286]: device 0x15b8840 has devpath '/devices/virtual/block/md0'
Nov 11 15:56:13 d10 udevd-work[3286]: device 0x15b8840 filled with db file data
Nov 11 15:56:13 d10 udevd-work[3286]: removing watch on '/dev/md0'
Nov 11 15:56:13 d10 udevd-work[3286]: RUN 'socket:/org/kernel/dm/multipath_event' /lib/udev/rules.d/40-multipath.rules:4
Nov 11 15:56:13 d10 udevd-work[3286]: LINK 'block/9:0' /lib/udev/rules.d/50-udev-default.rules:3
Nov 11 15:56:13 d10 udevd-work[3286]: GROUP 6 /lib/udev/rules.d/50-udev-default.rules:72
Nov 11 15:56:13 d10 udevd-work[3286]: IMPORT '/sbin/mdadm --detail --export /dev/md0' /lib/udev/rules.d/64-md-raid.rules:26
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/mdadm --detail --export /dev/md0' started
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/mdadm' (stdout) 'MD_LEVEL=raid10'
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/mdadm' (stdout) 'MD_DEVICES=4'
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/mdadm' (stdout) 'MD_METADATA=1.1'
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/mdadm' (stdout) 'MD_UUID=8cb0a7e8:82fa1a5f:7903f6fb:72f798ee'
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/mdadm' (stdout) 'MD_NAME=localhost.localdomain:0'
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/mdadm --detail --export /dev/md0' returned with exitcode 0
Nov 11 15:56:13 d10 udevd-work[3286]: LINK 'disk/by-id/md-name-localhost.localdomain:0' /lib/udev/rules.d/64-md-raid.rules:27
Nov 11 15:56:13 d10 udevd-work[3286]: LINK 'disk/by-id/md-uuid-8cb0a7e8:82fa1a5f:7903f6fb:72f798ee' /lib/udev/rules.d/64-md-raid.rules:
28
Nov 11 15:56:13 d10 udevd-work[3286]: IMPORT '/sbin/blkid -o udev -p /dev/md0' /lib/udev/rules.d/64-md-raid.rules:35
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/blkid -o udev -p /dev/md0' started
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/blkid' (stdout) 'ID_FS_UUID=UVr9E1-GugM-t09W-BkdJ-WFHn-4Ntz-NqDD4d'
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/blkid' (stdout) 'ID_FS_UUID_ENC=UVr9E1-GugM-t09W-BkdJ-WFHn-4Ntz-NqDD4d'
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/blkid' (stdout) 'ID_FS_VERSION=LVM2\x20001'
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/blkid' (stdout) 'ID_FS_TYPE=LVM2_member'
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/blkid' (stdout) 'ID_FS_USAGE=raid'
Nov 11 15:56:13 d10 udevd-work[3286]: '/sbin/blkid -o udev -p /dev/md0' returned with exitcode 0
Nov 11 15:56:13 d10 udevd-work[3286]: IMPORT 'udisks-lvm-pv-export UVr9E1-GugM-t09W-BkdJ-WFHn-4Ntz-NqDD4d' /lib/udev/rules.d/80-udisks.
rules:66
Nov 11 15:56:13 d10 udevd-work[3286]: 'udisks-lvm-pv-export UVr9E1-GugM-t09W-BkdJ-WFHn-4Ntz-NqDD4d' started
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_VG_UUID=vVNiEH-hB95-GbLk-kmYO-y4he-fl4L
-6KFpBp'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_VG_NAME=D10'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_VG_SIZE=3000571527168'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_VG_FREE_SIZE=1112094539776'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_VG_EXTENT_SIZE=33554432'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_VG_EXTENT_COUNT=89424'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_VG_SEQNUM=133'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_VG_PV_LIST=uuid=UVr9E1-GugM-t09W-BkdJ-W
FHn-4Ntz-NqDD4d;size=3000571527168;allocated_size=1888476987392 '
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_VG_LV_LIST=name=SWAP;uuid=IBjrks-5CVV-w
7ZP-61fK-xSFC-21Hd-gKkEDr;size=4194304000;;active=1 name=D10_ROOT;uuid=Mxecuc-JPvc-2nUf-PMpD-GDYZ-wEao-ciFTbD;size=20971520000;;active=
1 name=d10rootcopy;uuid=zBB8SM-5j2Q-uRTr-y11Z-hDcK-GLlb-muWXvb;size=20971520000;;active=1 name=SAT53.BACKUP;uuid=tjdHxk-WNFx-8V56-bz4x-
LG4z-taWl-sCDdOe;size=343597383680;;active=1 name=test2;uuid=rqOqNu-l2Vt-xoL3-p8Bs-j0wW-ODiP-x5TQOV;size=8388608000;;active=1 name=RHEL
5-64;uuid=0Vx5Sm-hWWf-j3j3-mt5X-Ac0E-mIsi-eceqG8;size=137438953472;;active=1 name=RHEL4-GUI;uuid=tFGYcf-3KjR-Zw6r-vP1Q-jADf-huhC-B9R8Gm
;size=17179869184;;active=1 name=RHEL4-BUILD;uuid=lhnj1W-wlwC-t5Re-id08-jjPT-U4Y3-8GhBOL;size=17179869184;;active=1 name=aa-ca;uuid=P9C
BBN-SQfE-1F7r-LB6m-X4DB-UcWk-Mjp9ES;size=17179869184;;active=1 name=aa-ds;uuid=9CW3VF-r5i7-rhAR-qwzP-M5QL-2wkj-fLJS7H;size=17179869184;
;active=1 name=RHEL5-32;uuid=gul8eK-thBp-FCCv-nHtn-XtpH-OyEJ-74h1jT;size=17179869184;;active=1 name=DS81;uuid=lf2u4w-U2P7-Dmkv-2UGm-3N1
E-eQUN-MJUk2W;size=17179'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) '869184;;active=1 name=DS71;uuid=pHcSWd-Zrvp-SYdE-9nSQ-
ve9w-MJny-3LPrpn;size=17179869184;;active=1 name=XP1;uuid=gLPRP0-EVcv-ozFj-yrVn-3Gwg-zPO0-nEJBOo;size=17179869184;;active=1 name=Proxy6
4;uuid=akYKvC-KnRq-JJPZ-8zQa-4wTA-3TcQ-hwd1Pp;size=17179869184;;active=1 name=IT302493;uuid=C1cqy0-e033-RVGR-oBLZ-L1SF-7sBO-8OhrsT;size
=17179869184;;active=1 name=ldapload;uuid=Gxgjms-DJO4-1Fn5-2eV9-3WCs-7YQ9-3Ngopr;size=17179869184;;active=1 name=CA;uuid=3Xh18M-IzzU-qf
JW-4Mc3-cvqJ-v6SR-mC1Q3o;size=17179869184;;active=1 name=CA.OLD;uuid=tTeDmd-ev1L-GdnX-5MXw-gcRN-BZr6-GXtTd8;size=17179869184;;active=1 
name=proxy5;uuid=MtAxEM-IF1e-VUSg-M7BB-cOO8-3fWz-JnSasq;size=17179869184;;active=1 name=V6A;uuid=Dfzhwy-GUY1-eYvj-0KOi-3j28-ECjk-ca6nN1
;size=17179869184;;active=1 name=V6B;uuid=iwdjl2-neYu-r8wK-h2EL-8a2B-w3WK-sADS7c;size=17179869184;;active=1 name=Sat53-64;uuid=3Wu316-O
acJ-66Z4-jZfG-YBhr-D1Ed-J0c2Qa;size=17179869184;;active=1 name=IT379878C;uuid=DO8H0c-xn3j-aPfr-K0kU-eGgG-3LnP-l1M7Tg;size=2147483648;;a
ctive=1 name=IT379878D;u'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'uid=4AcdIT-Nx7G-w2SK-uNO8-moLZ-uIvT-qlpYtY;size=214748
3648;;active=1 name=demo-ca;uuid=u9F00T-JTKq-2ntz-i6JY-lVE4-X9Su-0UnUhK;size=21474836480;;active=1 name=demo-client;uuid=q52Y9e-m4c4-YH
xy-4eaF-FNdQ-smM6-vu5fMW;size=21474836480;;active=1 name=demo-admin;uuid=aThlrF-6DYU-0PJp-ExY4-MRj5-rlQ1-2vCHUt;size=21474836480;;activ
e=1 name=ca2;uuid=8gLsO9-Zf9W-mJhn-w0es-HZFv-qWIm-AAC4Yf;size=17179869184;;active=1 name=ra2;uuid=UgGRSi-nLCc-8qU0-nO52-sW05-Lnpu-DJvXc
p;size=17179869184;;active=1 name=IT681913;uuid=V2rSzy-Ygbv-J0pn-sDU3-FWvM-vPBu-lUBrJQ;size=17179869184;;active=1 name=IT747873;uuid=2m
lk0R-P6Lp-yR3F-BcQ9-8Bno-TRp9-qrHzGL;size=17179869184;;active=1 name=IDMD-DS;uuid=7UXHRB-NKZe-yXgR-NyCm-5Hr5-VAPz-v6vffx;size=171798691
84;;active=1 name=osad1;uuid=fS1K0y-gJQg-zRun-OEt3-JW91-Qvds-ylG6fI;size=17179869184;;active=1 name=IT929033;uuid=2difnh-qgY2-SjvR-g9w5
-mTzQ-Dh0L-fiwula;size=17179869184;;active=1 name=f12loadtest;uuid=nvG1eo-ERmZ-HEVT-kuw1-8xRT-IvIq-NJe5E7;size=34359738368;;active=1 na
me=f13loadtest;uuid=xMl2'
Nov 11 15:56:17 d10 udevd-work[3286]: ressize 4096 too short
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'Fh-JcTV-vkUh-h57U-r9PH-ndfm-43Ykno;size=34359738368;;a
ctive=1 name=IT1004293;uuid=U8OgyR-AOLL-K0QF-VJbk-P97G-wUXW-wYOdf2;size=34359738368;;active=1 name=IT369102;uuid=1NDvtN-bKL3-aBe9-t8Ho-
vtJ0-d4y5-EEefz7;size=17179869184;;active=1 name=IT1052143;uuid=a2IAUn-Z75k-9kgq-sJLR-uINQ-qbfE-0A2ri2;size=17179869184;;active=1 name=
CSR;uuid=Sylvn2-Rf20-wVBN-mnLT-7Ek1-z3E8-6Si0sD;size=34359738368;;active=1 name=RHEL3-BUILD;uuid=EHx3fK-JGOe-sd76-octA-Y3hG-63n7-5ADkmp
;size=17179869184;;active=1 name=IT1092683;uuid=0c6Cc4-5bhX-F3wu-j1EX-QlbB-SpKx-q0dZz0;size=17179869184;;active=1 name=IT1126263;uuid=T
zRYTW-oiVb-H0uO-vrHy-JzFg-0YsV-vxlhJL;size=17179869184;;active=1 name=RHEL6-B2-32;uuid=ZqbggT-RpmM-7Lzj-tn3e-5ttn-mCe7-6c4EiX;size=1717
9869184;;active=1 name=RHEL4-U8-64;uuid=kk3N9w-RXNH-JBmK-cT4l-wPuJ-GNVM-PY0ErL;size=17179869184;;active=1 name=IT1199163;uuid=v06c7e-mT
Uz-ward-DMA2-Bx3F-FO4A-uHeeuf;size=17179869184;;active=1 name=IT1250323;uuid=NFydgW-jDci-fjGg-f1FD-mxkV-EjIw-3lY50X;size=17179869184;;a
ctive=1 name=IT374495;uu'
Nov 11 15:56:17 d10 udevd-work[3286]: ressize 4096 too short
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'id=ervyHS-PmuN-UXo2-DOeD-gNNi-2e6O-cVFGqu;size=3435973
8368;;active=1 name=IT1309893;uuid=929pPM-2n0A-EOya-stri-0Zrd-Nppp-63IIt3;size=17179869184;;active=1 name=IT1309893B;uuid=qojN3U-HNGS-q
OjJ-4q8X-zjuf-mwlR-4wV8Em;size=17179869184;;active=1 name=bigds;uuid=EyXb5A-07ce-DYQC-RrPW-xh6o-DVF1-i8vX3Y;size=34359738368;;active=1 
name=bigds-save;uuid=KLYHZD-B9bn-bIsW-pTkH-tVs7-OnDo-2Fv7Tx;size=34359738368;;active=1 name=ds82;uuid=pcSrEi-3LvE-M090-Sn5g-Y3GR-bC3g-u
3pcam;size=17179869184;;active=1 name=ISOS;uuid=pX9Sh0-oVeE-eWnE-MK2V-tVzQ-Blie-ZoxYHR;size=64424509440;;active=1 name=SAT53;uuid=YBxGX
c-xpvf-VTgG-RgMS-EDm0-HtGu-65nOHT;size=343597383680;;active=1 name=ds-client;uuid=1LQCh9-MrZy-4Q18-3dys-Y02z-mcb4-e4HeaP;size=858993459
2;;active=1 name=f14;uuid=SOVXr7-b9fU-L0ba-YpiJ-r0Wv-RwZ7-Dodu8V;size=8589934592;;active=1 '
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_UUID=UVr9E1-GugM-t09W-BkdJ-WFHn-4Ntz-Nq
DD4d'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-lvm-pv-export' (stdout) 'UDISKS_LVM2_PV_NUM_MDA=1'
Nov 11 15:56:17 d10 udevd-work[3286]: 'udisks-lvm-pv-export UVr9E1-GugM-t09W-BkdJ-WFHn-4Ntz-NqDD4d' returned with exitcode 0
Nov 11 15:56:17 d10 udevd-work[3286]: IMPORT 'udisks-part-id /dev/md0' /lib/udev/rules.d/80-udisks.rules:85
Nov 11 15:56:17 d10 udevd-work[3286]: 'udisks-part-id /dev/md0' started
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'libudev: udev_device_new_from_syspath: device 0x1fea270 has 
devpath '/devices/virtual/block/md0''
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'libudev: udev_device_read_db: device 0x1fea270 filled with d
b file data'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'using device_file=/dev/md0 syspath=/sys/devices/virtual/bloc
k/md0, offset=0 ao=0 and number=0 for /dev/md0'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'Entering MS-DOS parser (offset=0, size=3000597741568)'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) ''
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'No MSDOS_MAGIC found'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) ''
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'Exiting MS-DOS parser'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) ''
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'Entering Apple parser'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) ''
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'No MAC_MAGIC found'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) ''
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'Leaving Apple parser'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) ''
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'No known partition table found'
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) ''
Nov 11 15:56:17 d10 udevd-work[3286]: '/lib/udev/udisks-part-id' (stderr) 'No partition table found on /dev/md0: No such file or direct
ory'
Nov 11 15:56:17 d10 udevd-work[3286]: 'udisks-part-id /dev/md0' returned with exitcode 0
Nov 11 15:56:17 d10 udevd-work[3286]: RUN 'socket:@/org/freedesktop/hal/udev_event' /etc/udev/rules.d/90-hal.rules:2
Nov 11 15:56:17 d10 udevd-work[3286]: no node name set, will use kernel supplied name 'md0'
Nov 11 15:56:17 d10 udevd-work[3286]: created db file for '/devices/virtual/block/md0' in '/dev/.udev/db/block:md0'
Nov 11 15:56:17 d10 udevd-work[3286]: creating device node '/dev/md0', devnum=9:0, mode=0660, uid=0, gid=6
Nov 11 15:56:17 d10 udevd-work[3286]: preserve file '/dev/md0', because it has correct dev_t
Nov 11 15:56:17 d10 udevd-work[3286]: preserve permissions /dev/md0, 060660, uid=0, gid=6
Nov 11 15:56:17 d10 udevd-work[3286]: preserve already existing symlink '/dev/block/9:0' to '../md0'
Nov 11 15:56:17 d10 udevd-work[3286]: found 'b9:0' claiming '/dev/.udev/links/disk\x2fby-id\x2fmd-name-localhost.localdomain:0'
Nov 11 15:56:17 d10 udevd-work[3286]: creating link '/dev/disk/by-id/md-name-localhost.localdomain:0' to '/dev/md0'
Nov 11 15:56:17 d10 udevd-work[3286]: preserve already existing symlink '/dev/disk/by-id/md-name-localhost.localdomain:0' to '../../md0
'
Nov 11 15:56:17 d10 udevd-work[3286]: found 'b9:0' claiming '/dev/.udev/links/disk\x2fby-id\x2fmd-uuid-8cb0a7e8:82fa1a5f:7903f6fb:72f79
8ee'
Nov 11 15:56:17 d10 udevd-work[3286]: creating link '/dev/disk/by-id/md-uuid-8cb0a7e8:82fa1a5f:7903f6fb:72f798ee' to '/dev/md0'
Nov 11 15:56:17 d10 udevd-work[3286]: preserve already existing symlink '/dev/disk/by-id/md-uuid-8cb0a7e8:82fa1a5f:7903f6fb:72f798ee' t
o '../../md0'
Nov 11 15:56:17 d10 udevd-work[3286]: passed -1 bytes to socket monitor 0x15b8840
Nov 11 15:56:17 d10 udevd-work[3286]: passed 622 bytes to socket monitor 0x155e140
Nov 11 15:56:17 d10 udevd-work[3286]: adding watch on '/dev/md0'
Nov 11 15:56:17 d10 udevd-work[3286]: created db file for '/devices/virtual/block/md0' in '/dev/.udev/db/block:md0'
Nov 11 15:56:17 d10 udevd-work[3286]: passed -1 bytes to netlink monitor 0x15b86c0
Nov 11 15:56:17 d10 udevd-work[3286]: seq 3121 processed with 0
Nov 11 15:56:20 d10 udevd[547]: worker [3286] exit
Nov 11 15:56:20 d10 udevd[547]: worker [3286] cleaned up
Comment 2 Martin Poole 2010-11-11 11:13:26 EST

# rpm -q udev
udev-161-4.fc14.x86_64


# rpm -q kernel
kernel-2.6.35.6-48.fc14.x86_64
Comment 3 Harald Hoyer 2010-11-11 12:36:09 EST
$ rpm -qf /lib/udev/udisks-lvm-pv-export
udisks-...
Comment 4 Harald Hoyer 2010-11-11 12:37:43 EST
seems like the output of /lib/udev/udisks-lvm-pv-export is more than 4096 bytes.
Comment 5 Martin Poole 2010-11-11 13:24:44 EST
# rpm -qf /lib/udev/udisks-lvm-pv-export
udisks-1.0.1-4.fc14.x86_64
Comment 6 David Zeuthen 2010-11-11 13:33:39 EST
(In reply to comment #4)
> seems like the output of /lib/udev/udisks-lvm-pv-export is more than 4096
> bytes.

Need to bump this limit in udev (again [1]); unfortunately we really need all that information if we want to support LVM2 in any meaningful way... so reassigning back to udev.

    David

[1] : I'm also puzzled that the limit is 4KiB - I thought I changed that into 16KiB a while ago, see

 http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=e32d5237ea045045c621edba7341631abd602d74

Maybe there's another 4096 limit in udev? I don't know.
Comment 7 Harald Hoyer 2010-11-11 13:58:24 EST
udev-rules.c:

static int import_program_into_properties(struct udev_device *dev, const char *program)
...
        char result[4096];
...
        if (util_run_program(udev, program, envp, result, sizeof(result), &reslen, NULL, false) != 0)
...
Comment 8 Fedora Update System 2010-11-12 09:33:19 EST
udev-161-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/udev-161-5.fc14
Comment 10 Harald Hoyer 2010-11-12 09:59:41 EST
udev-161-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/udev-161-6.fc14
Comment 11 David Zeuthen 2010-11-12 15:28:21 EST
Harald: thanks for the prompt bugfix!
Comment 12 Fedora Update System 2010-11-13 17:00:33 EST
udev-161-6.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/udev-161-6.fc14
Comment 13 Fedora Update System 2010-11-16 18:14:27 EST
udev-161-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Harald Hoyer 2010-12-01 08:34:55 EST
*** Bug 649530 has been marked as a duplicate of this bug. ***
Comment 15 David Lehman 2010-12-01 19:00:38 EST
*** Bug 657805 has been marked as a duplicate of this bug. ***
Comment 16 Brian Lane 2011-05-03 17:00:18 EDT
*** Bug 700666 has been marked as a duplicate of this bug. ***
Comment 17 Robert Story 2011-05-04 08:14:06 EDT
so what's the trick to get this fix when installing? The F14 dvd/netboot.iso won't recognize my existing LVs, so I can't upgrade/install....
Comment 18 Harald Hoyer 2011-05-04 08:18:51 EDT
(In reply to comment #17)
> so what's the trick to get this fix when installing? The F14 dvd/netboot.iso
> won't recognize my existing LVs, so I can't upgrade/install....

you would have to go with F15
Comment 19 Frank Crawford 2011-05-04 08:52:24 EDT
(In reply to comment #17)
> so what's the trick to get this fix when installing? The F14 dvd/netboot.iso
> won't recognize my existing LVs, so I can't upgrade/install....

If you really need to get it fixed, you will need to hack the boot initrd.img to install a fixed version of udevd (see my commented in bug 657805).

However this is not a recommended practice, and easiest is to go with F15 as mentioned above.
Comment 20 Robert Story 2011-05-05 08:59:28 EDT
I see that a net install tries to grab /fedora/14/i386/images/updates.img... any way to stuff an updated udev into that?
Comment 21 Frank Crawford 2011-05-06 08:35:43 EDT
I don't think there is a supported method to do this, but it isn't that hard to extract the files in the image, replace udevd with an updated one and then create a new image file.  The udevd binary does not need to match any kernel version so any recent udevd should do.  Of course all this assumes that it pulls from a local repository, not one you don't have any control over.

Is there a later Fedora respin that includes a later udevd?

Note You need to log in before you can comment on or make changes to this bug.