Bug 652513 - need some exception to have LANG=en_US in grub.conf for CIJK
need some exception to have LANG=en_US in grub.conf for CIJK
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: F15Target
  Show dependency treegraph
 
Reported: 2010-11-12 00:14 EST by Akira TAGOH
Modified: 2011-03-31 01:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-31 01:33:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-11-12 00:14:37 EST
Description of problem:
Putting CIJK locale to the kernel parameters doesn't make any sense since VT isn't capable to display any CIJK characters. as we have a sort of hacks to prevent enabling CIJK locale on VT in /etc/profile.d/lang.sh, new-kernel-pkg should have similar hack.

Version-Release number of selected component (if applicable):
grubby-7.0.16-1.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1.put LANG=ja_JP.UTF-8 as the kernel parameter in grub.conf
2.boot
3.try login on VT
  
Actual results:
the broken localized strings on the password prompt appears.

Expected results:
should be readable.

Additional info:
This issue is raised on rawhide only since upstart doesn't have a look at LANG to spawn any processes but systemd does.
Comment 1 Akira TAGOH 2011-01-07 06:52:26 EST
any progress on this issue?
Comment 2 A S Alam 2011-01-07 09:53:36 EST
do you think any link with bug #663900?
Comment 3 Akira TAGOH 2011-01-10 20:30:28 EST
*** Bug 663900 has been marked as a duplicate of this bug. ***
Comment 4 Akira TAGOH 2011-02-03 02:06:55 EST
Any progress or updates for this issue? this issue makes the console unusable for CIJK users.
Comment 5 Akira TAGOH 2011-03-31 01:33:15 EDT
the issue seems fixed in systemd and we don't need anything in grubby now. so closing this.

Note You need to log in before you can comment on or make changes to this bug.