Bug 652518 - [abrt] yum-utils-1.1.28-1.fc13: grabber.py:1078:__getattr__:AttributeError: filenameself
[abrt] yum-utils-1.1.28-1.fc13: grabber.py:1078:__getattr__:AttributeError: f...
Status: CLOSED DUPLICATE of bug 622521
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
13
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:48bcb774
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-12 00:40 EST by Tim Shumakov
Modified: 2014-01-21 18:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-12 11:29:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.72 KB, text/plain)
2010-11-12 00:40 EST, Tim Shumakov
no flags Details

  None (edit)
Description Tim Shumakov 2010-11-12 00:40:06 EST
abrt version: 1.1.13
architecture: x86_64
cmdline: /usr/bin/python -tt /usr/bin/reposync -a i686 -c rhel-beta.repo -r rhel-beta-optional
component: yum-utils
executable: /usr/bin/reposync
kernel: 2.6.34.7-61.fc13.x86_64
package: yum-utils-1.1.28-1.fc13
reason: grabber.py:1078:__getattr__:AttributeError: filenameself
release: Fedora release 13 (Goddard)
time: 1289540239
uid: 500

backtrace
-----
grabber.py:1078:__getattr__:AttributeError: filenameself

Traceback (most recent call last):
  File "/usr/bin/reposync", line 349, in <module>
    main()
  File "/usr/bin/reposync", line 322, in main
    path = repo.getPackage(pkg)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 836, in getPackage
    size=package.size,
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 808, in _getFile
    size=size
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 408, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 394, in _mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 982, in urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 886, in _retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 968, in retryfunc
    fo = PyCurlFileObject(url, filename, opts)
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 1063, in __init__
    self._do_open()
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 1351, in _do_open
    self._do_grab()
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 1497, in _do_grab
    % (self.filenameself.url, e))
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 1078, in __getattr__
    raise AttributeError, name
AttributeError: filenameself

Local variables in innermost frame:
self: <closed file '/pub/rhel/tmp/rhel-beta-optional/Packages/fontforge-20090622-2.1.el6.i686.rpm', mode 'wb' at 0x1ee7580>
name: 'filenameself'
Comment 1 Tim Shumakov 2010-11-12 00:40:09 EST
Created attachment 459915 [details]
File: backtrace
Comment 2 James Antill 2010-11-12 11:29:21 EST

*** This bug has been marked as a duplicate of bug 622521 ***

Note You need to log in before you can comment on or make changes to this bug.