Bug 652646 - After using Manually Add - Script to a JBossAS5 resource, the child resource cannot be deleted.
After using Manually Add - Script to a JBossAS5 resource, the child resource ...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.0.0
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: jon30-bugs
  Show dependency treegraph
 
Reported: 2010-11-12 07:53 EST by Lukas Krejci
Modified: 2011-05-23 21:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 568917
Environment:
Last Closed: 2011-05-23 21:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lukas Krejci 2010-11-12 07:53:14 EST
This is a clone of bug 568917 to track its resolution in RHQ 4.

Description of problem:
After using Manually Add - Script to a JBossAS5 resource, the child resource cannot be deleted.

Steps to Reproduce:
1. From within an inventoried JBossAS5 server...
2. Goto INVENTORY / OVERVIEW
3. Manually Add -Script
     create a dummy.sh script on the patform of the JBossAS5 server and enter the Path to it.
4. Now that the script has been successfully added as a child resource....
5. Try to DELETE it...
  
Actual results:
  There is no checkbox next to child resources of type "Script".
  Moreover, because you cannot uninventory a service, there is no way to
  get rid of the inventoried child resource script service.

Expected results:
Comment 1 Lukas Krejci 2010-11-12 07:54:49 EST
commit 9ce5c9a040539d5155698ccef6a8dc19bdb37829
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Fri Nov 12 13:19:25 2010 +0100

    BZ 568917 - Enable creation of as5 scripts by uploading them to the server's bin. Also added support to delete arbitrary script.
    Only scripts with the supported file extensions can be successfully deployed so that they are auto-discovered later and thus appear in the inventory after their uploading.
Comment 2 Lukas Krejci 2010-11-18 08:34:00 EST
This needed more work so the commit that implements this feature in full is:

commit 27f80c3dedd8d7c1bb3a8725682aa51e4285d3a3
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Thu Nov 18 14:21:43 2010 +0100

    BZ 568917 - Implementing ContentFacet on ScriptComponent so that the support for uploading a new script is complete.
Comment 3 Sunil Kondkar 2010-11-26 08:28:05 EST
Verified on rhq-server-4.0.0-SNAPSHOT build#725.

Manually added a script with resource tree right click option. 
There is an 'IUninventory' button at "Jbossas resource->Resources->Scripts->Inventory->Members" screen. User is able to select and uninventory the script 

There is a delete button at "Jbossas resource->Inventory->Child Resources" screen. User is able to select and delete the manually added script.
Comment 4 Corey Welton 2011-05-23 21:15:08 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:15:18 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:15:21 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 7 Corey Welton 2011-05-23 21:15:22 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.