Bug 652695 - [abrt] openoffice.org-writer-1:3.3.0-13.3.fc14: raise: Process /usr/lib/openoffice.org3/program/swriter.bin was killed by signal 6 (SIGABRT)
[abrt] openoffice.org-writer-1:3.3.0-13.3.fc14: raise: Process /usr/lib/openo...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
14
i686 Unspecified
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:cb122aec53c56434cc9f7c6b345...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-12 10:08 EST by H.-P. Sorge
Modified: 2011-01-19 16:02 EST (History)
2 users (show)

See Also:
Fixed In Version: openoffice.org-3.3.0-19.2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-19 16:02:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (82.91 KB, text/plain)
2010-11-12 10:08 EST, H.-P. Sorge
no flags Details
stack of the crash (2.69 KB, text/plain)
2010-11-20 14:59 EST, David Tardon
no flags Details
a fix for something that sounds similiar from michael (1.56 KB, patch)
2010-11-25 11:38 EST, Caolan McNamara
no flags Details | Diff

  None (edit)
Description H.-P. Sorge 2010-11-12 10:08:34 EST
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/swriter.bin -writer
comment: I tried to verify bug # 652472
component: openoffice.org
crash_function: raise
executable: /usr/lib/openoffice.org3/program/swriter.bin
kernel: 2.6.35.6-48.fc14.i686
package: openoffice.org-writer-1:3.3.0-13.3.fc14
rating: 4
reason: Process /usr/lib/openoffice.org3/program/swriter.bin was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1289573733
uid: 500

How to reproduce
-----
1. Quickstarter is not visible:  Tools->Options->OpenOffice.org->Memory [checked] Enable systray Quickstarter 
2. Tools->Options->OpenOffice.org->Memory, uncheck Enable systray Quickstarter
3. close writer
4. start writer
5. Tools->Options->OpenOffice.org->Memory, [check] Enable systray Quickstarter -> OK  => quick starter gets displayed
6. close writer
7. exit quick starter => crash
Comment 1 H.-P. Sorge 2010-11-12 10:08:36 EST
Created attachment 460065 [details]
File: backtrace
Comment 2 Caolan McNamara 2010-11-20 09:07:12 EST
caolanm->dtardon: I know we have a rash of quickstarter problems at the moment. But can you reproduce this exact one with the described sequence ?

Those exact steps seem to work ok for me.
Comment 3 David Tardon 2010-11-20 14:59:53 EST
Created attachment 461758 [details]
stack of the crash

dtardon->caolanm: Yes, I see it, on rawhide with local build of openoffice.org-3.3.0-14.1. I think something is trying to call into libqstart_gtk after it's been unloaded.
Comment 4 Caolan McNamara 2010-11-22 08:43:55 EST
And its not affected by your other fix. i.e. still crashes with that in place ?
Comment 5 David Tardon 2010-11-23 04:25:49 EST
dtardon->caolanm: Yup, that fixes it, only I forgot to handle the situation where the quickstarter is exited by user. Will commit updated patch.

*** This bug has been marked as a duplicate of bug 650170 ***
Comment 6 Caolan McNamara 2010-11-25 11:38:54 EST
Created attachment 462937 [details]
a fix for something that sounds similiar from michael

caolanm->dtardon: Does this patch fix it ?
Comment 7 David Tardon 2010-11-25 14:17:14 EST
dtardon->caolanm: Looks like it should fix both this and bug 650170 (if the changes to shutdowniconunx.cxx remain in place), but I'm not entirely sure what happens in the case when there is quickstarter and a window. Will try it tomorrow.
Comment 8 David Tardon 2010-11-26 04:40:25 EST
So evidently it still crashes on _some_ runs and Michael's patch fixes it.
Comment 9 Caolan McNamara 2010-11-26 05:28:39 EST
Lets add that into the mix as well
Comment 10 Fedora Update System 2011-01-09 08:59:55 EST
openoffice.org-3.3.0-19.1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-19.1.fc14
Comment 11 Fedora Update System 2011-01-09 16:01:09 EST
openoffice.org-3.3.0-19.1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-19.1.fc14
Comment 12 Fedora Update System 2011-01-12 13:54:48 EST
openoffice.org-3.3.0-19.2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-19.2.fc14
Comment 13 Fedora Update System 2011-01-19 16:01:35 EST
openoffice.org-3.3.0-19.2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.