Bug 650170 - [abrt] quickstarter keeps oo.o alive after end of session
Summary: [abrt] quickstarter keeps oo.o alive after end of session
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:80efc7e7cf4420eab1663f1e894...
: 650580 651072 651494 651979 652118 652776 652794 652866 654026 654945 655007 655019 655033 655036 655186 655259 655366 656275 656276 656961 657106 657129 657145 657508 657590 659943 660639 661170 663237 666002 667469 668630 668933 669568 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-05 13:16 UTC by eblix08
Modified: 2011-01-14 10:58 UTC (History)
55 users (show)

Fixed In Version: openoffice.org-3.3.0-17.2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-02 19:07:40 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (3.55 KB, text/plain)
2010-11-05 13:16 UTC, eblix08
no flags Details
something like this, maybe (1.14 KB, patch)
2010-11-06 11:31 UTC, David Tardon
no flags Details | Diff
this works, but it's a bit elaborate (3.72 KB, patch)
2010-11-09 14:05 UTC, David Tardon
no flags Details | Diff
stack of the crash (14.49 KB, text/plain)
2010-12-07 08:34 UTC, David Tardon
no flags Details

Description eblix08 2010-11-05 13:16:27 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/soffice.bin -quickstart -nologo -nodefault
component: openoffice.org
executable: /usr/lib64/openoffice.org3/program/soffice.bin
kernel: 2.6.35.6-45.fc14.x86_64
package: openoffice.org-brand-1:3.3.0-9.3.fc14
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/soffice.bin was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1288386874
uid: 500

comment
-----
The stacktrace is sparse.  If you supply me with instructions I can install additional debug info or run OpenOffice in debug mode in order to try to offer more assistance.

Thanks.

How to reproduce
-----
1. Didn't realize the crash but found the alert in the ABRT.
2.
3.

Comment 1 eblix08 2010-11-05 13:16:28 UTC
Created attachment 458073 [details]
File: backtrace

Comment 2 David Tardon 2010-11-05 13:31:51 UTC
well, if you don't have any clue how it happened, there is not much we can do

Comment 3 eblix08 2010-11-05 13:48:01 UTC
I have seven identical errors in the ABRT for this issue.  About one or two a day are being generated.  My assumption is that this is being caused by the OpenOffice Quickstarter in the system tray during shutdown.  This would hide the error generation from me unless I looked for it.

Back to my original question, is there any additional debug packages I can install to generate a better stack trace?  Or can I start OpenOffice and the OpenOffice Quickstart in a type of debug mode in order to better track down this issue?  I've started Firefox in debug mode before in order to try to assist the developers.

This is definitely a repeatable issue.  Is there anything I can do to help the developers find and fix the issue?

Thanks.

Comment 4 David Tardon 2010-11-05 15:16:46 UTC
Okay, in that case you need openoffice.org-debuginfo-3.3.0-9.3.fc14 .

debuginfo-install openoffice.org

should install it. Then install abrt-cli, run

abrt-cli -lf

, find UUID of the crash and run

abrt-cli -i <UUID> -b

. That should generate the stack trace again.

Comment 5 eblix08 2010-11-05 17:52:37 UTC
"debuginfo-install openoffice.org" did not install any additional debug info.

I then ran "debuginfo-install openoffice.org-brand openoffice.org-calc openoffice.org-calc-core openoffice.org-core openoffice.org-impress openoffice.org-impress-core openoffice.org-langpack-en openoffice.org-opensymbol-fonts openoffice.org-presenter-screen openoffice.org-ure openoffice.org-writer openoffice.org-writer-core"

Which installed 20 additional debug packages.
   ORBit2-debuginfo-2.14.19.1.fc14.x86_64
   curl-debuginfo-7.21.0.5.fc14.x86_64
   db4-debuginfo-4.8.30.2.fc14.x86_64
   gstreamer-debuginfo-0.10.30.1.fc14.x86_64
   gstreamer-plugins-base-debuginfo-0.10.30.2.fc14.x86_64
   hyphen-debuginfo-2.5.2.fc14.x86_64
   icu-debuginfo-4.4.1.3.fc14.x86_64
   libXinerama-debuginfo-1.1.2.fc13.x86_64
   libXrandr-debuginfo-1.3.0.5.fc13.x86_64
   libtextcat-debuginfo-2.2.11.fc13.x86_64
   libwpd-debuginfo-0.8.14.5.fc14.x86_64
   libxslt-debuginfo-1.1.26.3.fc14.x86_64
   lpsolve-debuginfo-5.5.0.15.3.fc13.x86_64
   mythes-debuginfo-1.2.1.1.fc14.x86_64
   neon-debuginfo-0.29.3.1.fc14.x86_64
   nss-debuginfo-3.12.8.2.fc14.x86_64
   openoffice.org-debuginfo-1:3.3.0.9.3.fc14.x86_64
   openssl-debuginfo-1.0.0a.2.fc14.x86_64
   redland-debuginfo-1.0.12.1.fc14.x86_64
   silgraphite-debuginfo-2.3.1.3.fc14.x86_64

Running "abrt-cli -i 7a985dcccec2b6dc44e9b8b07868f6d6d066333f -b" provided no additional debugging information.  In addition I attempted to generate debugging information for a duplicate bug that I have not submitted yet without success.

According to the original comment this was caused by "soffice.bin -quickstart" and I believe the signal 6 (SIGABRT) is being caused by a standard shutdown.  If you can not reproduce this and unless there is something else you would like me to try I guess we'll leave this ticket closed.

Thanks for your help,
Eric

Comment 6 David Tardon 2010-11-06 10:00:11 UTC
dtardon->eblix08:
> According to the original comment this was caused by "soffice.bin -quickstart"
> and I believe the signal 6 (SIGABRT) is being caused by a standard shutdown. 

Thanks! That's what we needed to know.

dtardon->caolanm: It seems that the XIOErrors we keep getting are caused by quickstarter trying to outlive the session. Just enable quickstarter and log out and observe the crash...

Comment 7 David Tardon 2010-11-06 11:31:26 UTC
Created attachment 458312 [details]
something like this, maybe

Comment 8 Caolan McNamara 2010-11-06 11:55:55 UTC
Looks very plausible. Presumably in the scenario where there actually is another toplevel window open this doesn't do anything horrible ?

Comment 9 David Tardon 2010-11-07 12:44:41 UTC
*** Bug 650580 has been marked as a duplicate of this bug. ***

Comment 10 David Tardon 2010-11-07 19:30:16 UTC
dtardon->caolanm: Yeah, now it crashes when there is a toplevel window.

Comment 11 James Heather 2010-11-07 22:29:25 UTC
Package: openoffice.org-brand-1:3.3.0-9.3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


Comment
-----
I wasn't aware this crash had happened. Pretty sure I wasn't using OpenOffice at the time.

Comment 12 Theophanis Kontogiannis 2010-11-08 11:41:23 UTC
Package: openoffice.org-brand-1:3.3.0-9.3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


Comment
-----
no idea how to reproduce

Comment 13 Caolan McNamara 2010-11-08 19:57:49 UTC
*** Bug 651072 has been marked as a duplicate of this bug. ***

Comment 14 David Tardon 2010-11-09 14:05:26 UTC
Created attachment 459110 [details]
this works, but it's a bit elaborate

The problem with the previous approach was that framework::Desktop::terminate() was called recursively when a frame was opened: SessionManagerClient::ShutDownHdl() called terminate(), which called impl_sendNotifyTerminationEvent(), which caused destroying of the quickstarter and another call of terminate(), because all frames were already closed at this point. This patch avoids the recursive terminate() call. I'm not sure that's what we want (it might have consequences I haven't seen), but it's recorded here as a possible approach :)

Comment 15 Caolan McNamara 2010-11-09 17:17:55 UTC
*** Bug 651494 has been marked as a duplicate of this bug. ***

Comment 16 David Tardon 2010-11-10 18:23:21 UTC
*** Bug 651979 has been marked as a duplicate of this bug. ***

Comment 17 David Tardon 2010-11-11 07:40:07 UTC
*** Bug 652118 has been marked as a duplicate of this bug. ***

Comment 18 chris.hobson 2010-11-11 18:02:15 UTC
Package: openoffice.org-brand-1:3.3.0-13.3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Opening Open Office, with a large number of previously opened documents and spreadsheets
2. Couldn't seem to open it at all, couldn't find any of the usual splash screen about recovering documents
3. Open Office reported as crashed

Comment 19 cnangel 2010-11-12 11:23:47 UTC
Package: openoffice.org-brand-1:3.3.0-13.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.i do nothing when open the openoffice
2.
3.

Comment 20 David Tardon 2010-11-12 19:15:17 UTC
*** Bug 652776 has been marked as a duplicate of this bug. ***

Comment 21 David Tardon 2010-11-13 06:26:18 UTC
*** Bug 652794 has been marked as a duplicate of this bug. ***

Comment 22 David Tardon 2010-11-13 06:31:08 UTC
*** Bug 652866 has been marked as a duplicate of this bug. ***

Comment 23 BartS 2010-11-13 07:23:59 UTC
Package: openoffice.org-brand-1:3.3.0-13.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


Comment
-----
random crash

Comment 24 Eric Liger 2010-11-13 09:38:01 UTC
Package: openoffice.org-brand-1:3.3.0-13.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Mise  jour du systme
2.During the first update of the system
3.

Comment 25 Eric Liger 2010-11-13 09:39:19 UTC
Package: openoffice.org-brand-1:3.3.0-13.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. During the first update of the system
2.
3.

Comment 26 Lofton Alley 2010-11-14 12:32:05 UTC
Package: openoffice.org-brand-1:3.3.0-13.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.on a restart
2.
3.

Comment 27 Lofton Alley 2010-11-16 14:03:29 UTC
Package: openoffice.org-brand-1:3.3.0-13.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.restart
2.
3.

Comment 28 Igor Katalnikov 2010-11-16 18:32:04 UTC
Package: openoffice.org-brand-1:3.3.0-13.3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Unknown
2.
3.

Comment 29 Moises Padilla 2010-11-17 11:53:02 UTC
Package: openoffice.org-brand-1:3.3.0-9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


Comment
-----
No idea what crashed, just see it on my list off issues to report.

Comment 30 David M. 2010-11-19 06:07:25 UTC
Package: openoffice.org-brand-1:3.3.0-14.1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Not sure
2.
3.


Comment
-----
Mysterious crash uppon Gnome Startup.

Comment 31 David Tardon 2010-11-19 06:22:23 UTC
*** Bug 654945 has been marked as a duplicate of this bug. ***

Comment 32 Caolan McNamara 2010-11-19 11:37:16 UTC
*** Bug 655019 has been marked as a duplicate of this bug. ***

Comment 33 Caolan McNamara 2010-11-19 11:38:37 UTC
*** Bug 655007 has been marked as a duplicate of this bug. ***

Comment 34 David Tardon 2010-11-19 14:21:19 UTC
*** Bug 655033 has been marked as a duplicate of this bug. ***

Comment 35 David Tardon 2010-11-19 14:22:11 UTC
*** Bug 655036 has been marked as a duplicate of this bug. ***

Comment 36 David Tardon 2010-11-20 06:10:49 UTC
*** Bug 655186 has been marked as a duplicate of this bug. ***

Comment 37 David Tardon 2010-11-20 06:11:38 UTC
*** Bug 655259 has been marked as a duplicate of this bug. ***

Comment 38 Caolan McNamara 2010-11-20 17:01:29 UTC
caolanm->dtardon: IMO the patch looks good, can you take care of adding it into upstream LibreOffice. Maybe find someone to review it for backport to 3.3.

Will be in 3.3.0-16.1

Comment 39 David Tardon 2010-11-20 18:28:23 UTC
*** Bug 655366 has been marked as a duplicate of this bug. ***

Comment 40 Paul Ward 2010-11-20 23:19:13 UTC
Package: openoffice.org-brand-1:3.3.0-14.1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Crash occurred on startup.

Comment 41 Eric Liger 2010-11-21 09:59:12 UTC
Package: openoffice.org-brand-1:3.3.0-13.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.ouverture d un fichier .csv
2.
3.

Comment 42 David M. 2010-11-21 19:04:22 UTC
Package: openoffice.org-brand-1:3.3.0-14.1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.  Log out of Gnome.
2.  In terminal type "halt"
3.  Computer shuts down normally
4.  Start computer with init 3
5.  type "startx"
6.  crash appears in abrt after gnome start.

Comment
-----
loging out of gnome / shutting down computer crashes package.

Comment 43 mariolinux 2010-11-21 21:56:48 UTC
Package: openoffice.org-brand-1:3.3.0-14.1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I don't know
2.
3.

Comment 44 Slawek Gawlowski 2010-11-22 05:59:08 UTC
Package: openoffice.org-brand-1:3.3.0-14.1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
running presentation

Comment 45 David Tardon 2010-11-23 09:25:49 UTC
*** Bug 652695 has been marked as a duplicate of this bug. ***

Comment 46 David Tardon 2010-11-23 12:05:14 UTC
*** Bug 656275 has been marked as a duplicate of this bug. ***

Comment 47 David Tardon 2010-11-23 12:06:57 UTC
*** Bug 656276 has been marked as a duplicate of this bug. ***

Comment 48 Caolan McNamara 2010-11-24 15:40:39 UTC
*** Bug 656961 has been marked as a duplicate of this bug. ***

Comment 49 zbechir 2010-11-24 16:20:57 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.??
2.
3.

Comment 50 Horst H. von Brand 2010-11-24 22:42:49 UTC
*** Bug 654026 has been marked as a duplicate of this bug. ***

Comment 51 David Tardon 2010-11-25 05:13:09 UTC
*** Bug 657106 has been marked as a duplicate of this bug. ***

Comment 52 David Tardon 2010-11-25 05:14:20 UTC
*** Bug 657129 has been marked as a duplicate of this bug. ***

Comment 53 David Tardon 2010-11-25 05:16:32 UTC
*** Bug 657145 has been marked as a duplicate of this bug. ***

Comment 54 Caolan McNamara 2010-11-26 10:17:30 UTC
*** Bug 657508 has been marked as a duplicate of this bug. ***

Comment 55 Misha Shnurapet 2010-11-26 17:13:33 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. no idea
2.
3.

Comment 56 David Tardon 2010-11-26 17:29:48 UTC
*** Bug 657590 has been marked as a duplicate of this bug. ***

Comment 57 Alexandre A. Borba 2010-11-26 22:47:48 UTC
Package: broffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.no idea
2.
3.

Comment 58 David M. 2010-11-27 18:16:45 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Log out of Gnome Desktop
2.Type "halt" from user account
3.Crash seems to happen while computer is shutting down


Comment
-----
Failure might have something to do with me not closing the applet before logging out of gnome.

Comment 59 Bob 2010-11-28 11:51:41 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Apparently occurred around time system was shutdown.
2.
3.

Comment 60 Bob 2010-11-28 11:53:28 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.May have happened at system shutdown.
2.
3.

Comment 61 Mark Lees 2010-11-28 12:25:18 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I've no idea what I was doing when it crashed
2.
3.

Comment 62 Yann Droneaud 2010-11-28 12:51:24 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Don't know what happened. ABRT was only reporting the failure.

Comment 63 Jeffrey S Austin 2010-11-28 23:17:14 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
logging in.

Comment 64 Fedora Update System 2010-11-29 11:47:57 UTC
openoffice.org-3.3.0-17.2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-17.2.fc14

Comment 65 zbechir 2010-11-29 13:17:13 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.I don't know!
2.
3.


Comment
-----
I don't know!

Comment 66 matthias.guentert 2010-11-29 19:38:40 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Linphone was crashing when this bug somehow additionaly occured...

Comment 67 Fedora Update System 2010-11-29 21:35:19 UTC
openoffice.org-3.3.0-17.2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-17.2.fc14

Comment 68 Truls Gulbrandsen 2010-12-01 13:10:56 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.The crash happened during start-up and no interaction from user.
2.
3.

Comment 69 Tad 2010-12-01 14:00:14 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
n

Comment 70 Tad 2010-12-01 14:47:36 UTC
Package: openoffice.org-brand-1:3.3.0-14.1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
n

Comment 71 dobs 2010-12-01 23:36:03 UTC
Package: openoffice.org-brand-1:3.3.0-15.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I don't know

Comment 72 Fedora Update System 2010-12-02 19:07:17 UTC
openoffice.org-3.3.0-17.2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 73 David Tardon 2010-12-04 11:01:58 UTC
*** Bug 659943 has been marked as a duplicate of this bug. ***

Comment 74 David Tardon 2010-12-07 08:34:33 UTC
Created attachment 465186 [details]
stack of the crash

Comment 75 David Tardon 2010-12-07 13:01:30 UTC
*** Bug 660639 has been marked as a duplicate of this bug. ***

Comment 76 David Tardon 2010-12-08 06:02:25 UTC
*** Bug 661170 has been marked as a duplicate of this bug. ***

Comment 77 Yann Droneaud 2010-12-08 20:15:51 UTC
(In reply to comment #72)
> openoffice.org-3.3.0-17.2.fc14 has been pushed to the Fedora 14 stable
> repository.  If problems still persist, please make note of it in this bug
> report.

It seems it's not really fixed: see bug #660639 which was closed as a duplicate: it was reported against openoffice.org-3.3.0-17.2.fc14.

(In reply to comment #75)
> *** Bug 660639 has been marked as a duplicate of this bug. ***

This bug could probably reopened.

Comment 78 Caolan McNamara 2010-12-08 20:49:13 UTC
Well, it might still be broken, or bug 660639 could be a crash of the *old* quickstarter which was running while the upgrade to the *new* version occurred and therefore the old one was still running on exit. Tricky area. Might be a few more enhancements to quickstarter shutdown coming down the stream, but basically turn off the quickstarter unless you like it and you won't be hassled.

Comment 79 David Tardon 2010-12-15 05:21:03 UTC
*** Bug 663237 has been marked as a duplicate of this bug. ***

Comment 80 David Tardon 2010-12-29 07:08:00 UTC
*** Bug 666002 has been marked as a duplicate of this bug. ***

Comment 81 David Tardon 2011-01-05 17:20:40 UTC
*** Bug 667469 has been marked as a duplicate of this bug. ***

Comment 82 David Tardon 2011-01-11 05:31:03 UTC
*** Bug 668630 has been marked as a duplicate of this bug. ***

Comment 83 David Tardon 2011-01-12 07:39:14 UTC
*** Bug 668933 has been marked as a duplicate of this bug. ***

Comment 84 David Tardon 2011-01-14 05:33:11 UTC
*** Bug 669568 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.