Bug 65284 - Bigmem kernel sees only 4.75 of 5GB on a slimmerlot
Bigmem kernel sees only 4.75 of 5GB on a slimmerlot
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 62123 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-21 09:57 EDT by Clay Cooper
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-22 06:33:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (51.48 KB, text/plain)
2002-05-21 09:59 EDT, Clay Cooper
no flags Details

  None (edit)
Description Clay Cooper 2002-05-21 09:57:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
On a slimmerlot with A02 Bios, 5GB ram, and 7.3 (2.4.18-3bigmem) installed. 
/Proc/meminfo reports only 4.75GB.  Machine bios reports 5.120GB.

Attaching /var/log/messages 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install 7.3 on a slimmerlot w/ 5GB ram
2.Note /proc/meminfo memory amount
3.
	

Actual Results:  4.75 of 5GB shown

Expected Results:  5 of 5GB shown

Additional info:
Comment 1 Clay Cooper 2002-05-21 09:59:37 EDT
Created attachment 58095 [details]
/var/log/messages
Comment 2 Arjan van de Ven 2002-05-21 11:37:17 EDT
If you count the memory in the "usable" regions in the e820 table it adds up
to about 4669 Mb. I think you should ask your bios folks how this table says 5Gb
since it clearly doesn't.....
Comment 3 Matt Domsch 2002-07-09 15:08:03 EDT
This is working as designed.  The chipset cannot remap physical RAM out of 
address space reserved for PCI devices into any other address space.  This 
means that PCI devices like PERC3 cards, which request 128MB of address space, 
get it, and the system "loses" 128MB of RAM.  This is a property of all 
existing ServerWorks chipsets.  Other platforms which use Intel chipsets may 
not have this limitation.
Comment 4 John A. Hull 2002-07-23 18:38:48 EDT
*** Bug 62123 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.