Bug 652939 - tar segfaults while doing listed-incremental archive of root partition
Summary: tar segfaults while doing listed-incremental archive of root partition
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tar   
(Show other bugs)
Version: 14
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 653433
TreeView+ depends on / blocked
 
Reported: 2010-11-13 16:37 UTC by Kevin Street
Modified: 2011-03-26 21:22 UTC (History)
3 users (show)

Fixed In Version: tar-1.23-8.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 653433 (view as bug list)
Environment:
Last Closed: 2010-11-26 01:08:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Street 2010-11-13 16:37:51 UTC
Description of problem:
When creating an archive using the --listed-incremental option to tar, tar will segfault (return code 139). This only happens when archiving the root partition (/) and only on the second and subsequent invocations. (The first invocation creates the list file, the second should read the list file and archive only the delta changes).


Version-Release number of selected component (if applicable):
tar-1.23-6.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. tar --create --one-file-system --listed-incremental=root.list --file=root.full.tar /
2. tar --create --one-file-system --listed-incremental=root.list --file=root.delta.tar /
3. echo $?
  
Actual results:
segfault errcode 139

Expected results:
delta archive into root.delta.tar

Additional info:

There is a patch for this floating around upstream.  See:
http://www.mail-archive.com/bug-tar@gnu.org/msg02632.html

Comment 1 Fedora Update System 2010-11-15 14:27:17 UTC
tar-1.23-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/tar-1.23-7.fc14

Comment 2 Fedora Update System 2010-11-15 22:21:40 UTC
tar-1.23-7.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tar'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/tar-1.23-7.fc14

Comment 3 Kevin Street 2010-11-16 00:52:20 UTC
tar 1.23-7 works for me

Comment 4 Fedora Update System 2010-11-26 01:08:05 UTC
tar-1.23-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Alain Spineux 2011-03-23 10:00:59 UTC
My test case is a little bit different and segfault on last fedora 14.
It is working fine on F11 and centos5.

I tried tar-1.26 and it works too, no segfault.

# rm -f /tmp/backup-inc.tgz /tmp/snapshot.snar ; find  /bin -not -type s -print | tar  cvTf  -  /tmp/backup-inc.tgz  --no-recursion  -z  --listed-incremental=/tmp/snapshot.snar
tar: /bin: Directory is new

# rpm -qi
rpm: no arguments given for query
[root@box172 tmp]# rpm -qi tar
Name        : tar                          Relocations: (not relocatable)
Version     : 1.23                              Vendor: Fedora Project
Release     : 7.fc14                        Build Date: Mon 15 Nov 2010

Comment 6 Fedora Update System 2011-03-23 14:50:47 UTC
tar-1.23-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/tar-1.23-8.fc14

Comment 7 Alain Spineux 2011-03-23 15:37:40 UTC
tar-1.23-8.fc14 works as expected
Thanks

Comment 8 Fedora Update System 2011-03-26 21:22:46 UTC
tar-1.23-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.