Bug 653433 - tar segfaults while doing listed-incremental archive of root partition
Summary: tar segfaults while doing listed-incremental archive of root partition
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tar
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Pavel Raiskup
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
Keywords:
Depends On: 652939
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-15 12:57 UTC by Ondrej Vasik
Modified: 2018-11-27 19:31 UTC (History)
6 users (show)

(edit)
Clone Of: 652939
(edit)
Last Closed: 2012-06-20 13:49:09 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0849 normal SHIPPED_LIVE tar bug fix and enhancement update 2012-06-19 20:48:42 UTC

Description Ondrej Vasik 2010-11-15 12:57:08 UTC
+++ This bug was initially created as a clone of Bug #652939 +++

Description of problem:
When creating an archive using the --listed-incremental option to tar, tar will segfault (return code 139). This only happens when archiving the root partition (/) and only on the second and subsequent invocations. (The first invocation creates the list file, the second should read the list file and archive only the delta changes).


Version-Release number of selected component (if applicable):
tar-1.23-6.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. tar --create --one-file-system --listed-incremental=root.list --file=root.full.tar /
2. tar --create --one-file-system --listed-incremental=root.list --file=root.delta.tar /
3. echo $?
  
Actual results:
segfault errcode 139

Expected results:
delta archive into root.delta.tar

Additional info:

There is a patch for this floating around upstream.  See:
http://www.mail-archive.com/bug-tar@gnu.org/msg02632.html

Comment 2 RHEL Product and Program Management 2011-01-07 15:31:36 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Alain Spineux 2011-03-23 02:48:57 UTC
identical problem on fedora 14 running this command line

# rm -f /tmp/backup-inc.tgz /tmp/snapshot.snar ; find  /bin -not -type s -print | tar  cvTf  -  /tmp/backup-inc.tgz  --no-recursion  -z  --listed-incremental=/tmp/snapshot.snar

no probleme on fedora 11 and centos 5

Identical problem on debian 
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=575298
Looks to be solved on tar-1.25


Tried on tar-1.26. It works.

Comment 4 Ondrej Vasik 2011-03-23 06:50:20 UTC
Yep, I know the problem exists on Fedora 14, it was not serious enough for me to do an update for tar there. I'll check if there are more such "smaller" things and maybe do an update, f15 should be ok anyway, as there is already upstream version with fix.

Comment 5 Ondrej Vasik 2011-03-23 09:21:13 UTC
Ignore my previous comment, I realized that I fixed the problem in F14 already - see https://admin.fedoraproject.org/updates/tar-1.23-7.fc14 . So just make sure you have fully updated f14 and everything should be ok ... If not, feel free to report f14 bugzilla, this one is tracking RHEL-6 status.

Comment 6 Alain Spineux 2011-03-23 09:50:33 UTC
(In reply to comment #5)
> Ignore my previous comment, I realized that I fixed the problem in F14 already
> - see https://admin.fedoraproject.org/updates/tar-1.23-7.fc14 . So just make
> sure you have fully updated f14 and everything should be ok ... If not, feel
> free to report f14 bugzilla, this one is tracking RHEL-6 status.

My test case (see below) is not fixed on my up2date F14 :-(.
I have no RHEL-6 for testing. could you make a try ?
I will open a bug for F14.
thanks for your time.
Regards

[root@box172 tmp]# rpm -qi
rpm: no arguments given for query
[root@box172 tmp]# rpm -qi tar
Name        : tar                          Relocations: (not relocatable)
Version     : 1.23                              Vendor: Fedora Project
Release     : 7.fc14                        Build Date: Mon 15 Nov 2010 

<snip>

[root@box172 tmp]# rm -f /tmp/backup-inc.tgz /tmp/snapshot.snar ; find  /bin -not -type s -print | tar  cvTf  -  /tmp/backup-inc.tgz  --no-recursion  -z  --listed-incremental=/tmp/snapshot.snar
tar: /bin: Directory is new
Segmentation fault

Comment 7 Ondrej Vasik 2011-03-23 12:02:49 UTC
Yep, your test fails on RHEL-6, so the f-14 fix has to be extended, thanks for another test, I'll check the f14 binary and make tar update after fix.

Comment 10 Ondrej Vasik 2011-03-23 14:29:56 UTC
This one commit fixes your part of crash - but is completely separate from the previous one - http://git.savannah.gnu.org/gitweb/?p=tar.git;a=commit;h=40dea1ae7fc892a54eae2efd30ddd8559c697525

Comment 12 RHEL Product and Program Management 2011-07-05 23:43:43 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 20 errata-xmlrpc 2012-06-20 13:49:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0849.html


Note You need to log in before you can comment on or make changes to this bug.