Bug 65294 - Missing dependencies for cpanflute2
Missing dependencies for cpanflute2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 67352 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-21 13:04 EDT by Markku Kolkka
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-21 13:04:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markku Kolkka 2002-05-21 13:04:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
The cpanflute2 script used to build RPMs out of CPAN Perl modules requires Archive::Tar perl module which isn't specified as a dependency of the rpm-build package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install rpm-build
2. Try to run cpanflute2

 

Actual Results:  Can't locate Archive/Tar.pm in @INC (@INC contains: /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.6.1/i386-linux /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendor_perl .) at /usr/lib/rpm/cpanflute2 line 7.
BEGIN failed--compilation aborted at /usr/lib/rpm/cpanflute2 line 7.


Additional info:

Archive::Tar is provided by perl-Archive-Tar package.
Comment 1 Jeff Johnson 2002-06-05 13:18:17 EDT
cpanflute2 has been removed from the rpm-build
package. Install Chip Turner's CPAN package instead.
Comment 2 Warren Togami 2002-06-23 06:42:29 EDT
*** Bug 67352 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.