Bug 652994 - SELinux is preventing /usr/bin/perl "create" access .
Summary: SELinux is preventing /usr/bin/perl "create" access .
Keywords:
Status: CLOSED DUPLICATE of bug 652965
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:caa28e30547...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 02:39 UTC by srh
Modified: 2010-11-15 13:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-15 10:16:56 UTC
Type: ---


Attachments (Terms of Use)

Description srh 2010-11-14 02:39:15 UTC
Summary:

SELinux is preventing /usr/bin/perl "create" access .

Detailed Description:

SELinux denied access requested by ddclient. It is not expected that this access
is required by ddclient and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:ddclient_t:s0
Target Context                system_u:system_r:ddclient_t:s0
Target Objects                None [ netlink_route_socket ]
Source                        ddclient
Source Path                   /usr/bin/perl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           perl-5.12.2-136.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.7-10.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35.6-48.fc14.x86_64 #1 SMP Fri
                              Oct 22 15:36:08 UTC 2010 x86_64 x86_64
Alert Count                   12
First Seen                    Sun 14 Nov 2010 15:20:23 NZDT
Last Seen                     Sun 14 Nov 2010 15:35:31 NZDT
Local ID                      78e58444-006c-450b-8f1a-f388062640e9
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1289702131.115:39006): avc:  denied  { create } for  pid=1588 comm="ddclient" scontext=system_u:system_r:ddclient_t:s0 tcontext=system_u:system_r:ddclient_t:s0 tclass=netlink_route_socket

node=(removed) type=SYSCALL msg=audit(1289702131.115:39006): arch=c000003e syscall=41 success=no exit=-13 a0=10 a1=3 a2=0 a3=0 items=0 ppid=1 pid=1588 auid=4294967295 uid=489 gid=481 euid=489 suid=489 fsuid=489 egid=481 sgid=481 fsgid=481 tty=(none) ses=4294967295 comm="ddclient" exe="/usr/bin/perl" subj=system_u:system_r:ddclient_t:s0 key=(null)



Hash String generated from  catchall,ddclient,ddclient_t,ddclient_t,netlink_route_socket,create
audit2allow suggests:

#============= ddclient_t ==============
allow ddclient_t self:netlink_route_socket create;

Comment 1 Miroslav Grepl 2010-11-15 10:16:56 UTC

*** This bug has been marked as a duplicate of bug 652965 ***


Note You need to log in before you can comment on or make changes to this bug.