Bug 653005 - video/audio broken after hibernation
video/audio broken after hibernation
Status: CLOSED DUPLICATE of bug 643367
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-13 22:21 EST by Paolo Bonzini
Modified: 2010-11-17 05:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-16 19:57:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2010-11-13 22:21:47 EST
Description of problem:
After hibernation, neither video nor audio works.

Version-Release number of selected component (if applicable):
udev-161-4.fc14.x86_64
kernel-2.6.35.6-48.fc14.x86_64

How reproducible:
2 out of 2

Steps to Reproduce:
1. Install gstreamer-properties
2. Hibernate and resume
3. Run gstreamer-properties from console
4. Start webcam test
 
Actual results:
Console shows:

gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': Could not open device '/dev/video0' for reading and writing. [v4l2_calls.c(502): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src1: system error: Permission denied]

Expected results:
Webcam works

Additional info:
After doing "sudo chmod o+rw /dev/video0", the webcam works.

Audio is likewise broken and fixed by "sudo chmod -R o+rw /dev/snd/".
Comment 1 Harald Hoyer 2010-11-15 06:10:51 EST
chmod is not the way it works... console user access is granted with ACLs.

What is:

# getfacl /dev/video0

before and after hibernation
Comment 2 Paolo Bonzini 2010-11-15 10:10:34 EST
before hibernation
==================

yakj:~ pbonzini$ getfacl /dev/video0
getfacl: Removing leading '/' from absolute path names
# file: dev/video0
# owner: root
# group: video
user::rw-
user:pbonzini:rw-
group::rw-
mask::rw-
other::---

after hibernation
=================

yakj:~ pbonzini$ getfacl /dev/video0
getfacl: Removing leading '/' from absolute path names
# file: dev/video0
# owner: root
# group: video
user::rw-
group::rw-
mask::rw-
other::---

As expected, the ACL is not restored (the chmod experiment was just to make sure that the problem involved permissions).  A workaround is to switch to another console and back.

I guess the bug is more likely to be in ConsoleKit, changing component.
Comment 3 Lennart Poettering 2010-11-16 19:57:33 EST

*** This bug has been marked as a duplicate of bug 650955 ***
Comment 4 Harald Hoyer 2010-11-17 05:57:05 EST

*** This bug has been marked as a duplicate of bug 643367 ***

Note You need to log in before you can comment on or make changes to this bug.