Bug 653016 - PulseAudio Manager lacks the necessary configuration interface to enable built in micropohones
Summary: PulseAudio Manager lacks the necessary configuration interface to enable buil...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 14
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 05:18 UTC by Paul Lambert
Modified: 2010-11-25 03:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-22 01:39:55 UTC
Type: ---


Attachments (Terms of Use)
How to use PulseAudio for built in microphones. (450.35 KB, application/pdf)
2010-11-14 05:18 UTC, Paul Lambert
no flags Details
G-V-C dialog box (31.54 KB, image/png)
2010-11-25 03:30 UTC, Paul Lambert
no flags Details
Sound Preferences Hardware tab screen capture (43.64 KB, image/png)
2010-11-25 03:46 UTC, Paul Lambert
no flags Details

Description Paul Lambert 2010-11-14 05:18:25 UTC
Created attachment 460310 [details]
How to use PulseAudio for built in microphones.

Description of problem:  Thousands of laptop Linux users have endured countless hours of research, testing and reboots to get their built in microphones to work with audio capture applications such as Skype, Audacity, etc.  This is unnecessary and would be eliminated if the PulseAudio Manager allowed direct access to low level driver "properties."


Version-Release number of selected component (if applicable):
kernel-2.6.34.7-56.fc13.x86_64

paman-0.9.4-4.fc12.x86_64

pulseaudio-0.9.21-6.fc13.x86_64
alsa-plugins-pulseaudio-1.0.22-1.fc13.x86_64
pulseaudio-module-x11-0.9.21-6.fc13.x86_64
alsa-plugins-pulseaudio-1.0.22-1.fc13.i686
pulseaudio-utils-0.9.21-6.fc13.x86_64
pulseaudio-gdm-hooks-0.9.21-6.fc13.x86_64
pulseaudio-libs-0.9.21-6.fc13.i686
pulseaudio-module-gconf-0.9.21-6.fc13.x86_64
pulseaudio-libs-glib2-0.9.21-6.fc13.i686
pulseaudio-module-bluetooth-0.9.21-6.fc13.x86_64
pulseaudio-libs-0.9.21-6.fc13.x86_64
pulseaudio-libs-glib2-0.9.21-6.fc13.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. Determine what sound hardware the laptop has
2. Create a "conf" file for ALSA to read on startup
3.  Reboot laptop and launch audio capture application
  
Actual results:
With composite devices such as camera/mic used on laptops it is necessary to link the device to the driver.  This can be done using a alsa-boot.conf file or a sound.conf file

Expected results:
The PulseAudio Manager should allow either a drop down menu with the driver "properties" selectable or a text input line that allows additional driver command line configuration data.

Additional info:
See attached "guide" that goes through a step by step analysis of how to correctly use PulseAudio with a built in microphone.

Comment 1 Michael Wiktowy 2010-11-15 03:30:12 UTC
Related bugs:
Bug 590115
Bug 542924
Bug 620189
Bug 629003
Bug 520216

Both of my systems can't capture properly but one of them is Ubuntu.
Fedora system is:
lspci |grep -i audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
04:00.1 Audio device: ATI Technologies Inc HD48x0 audio

Comment 2 Michael Wiktowy 2010-11-15 03:31:33 UTC
Sorry ... Bug 629003 should be Bug 628003 in above list.

Comment 3 Michael Wiktowy 2010-11-15 03:57:38 UTC
Creating
/etc/modprobe.d/alsa-base.conf

with *only* the following line:

options snd-hda-intel position_fix=1 enable=yes

fixes the long standing capture issue with Skype/Audacity/etc. for me.

Comment 4 Lennart Poettering 2010-11-22 01:39:55 UTC
Paul, such an interface is available in the gnome-volume-control too.

Michael, file a kernel bug to make sure that your driver is fixed.

Comment 5 Paul Lambert 2010-11-22 19:59:18 UTC
I don't believe you understood the bug that I am reporting.  The gnome-volume-control is just another mixer.  The bug I am reporting is that there is no sound from built-in microphones for almost all laptops.  To get these microphones to work correctly requires adding a "sound.conf" or "basic-alsa.conf" file to associate the proper device to the audio input driver.  

This should be a selectable "property" that is readily accessible through the  sound manager interface.  There should be no need to open a terminal window, open a file and then enter the required information.  If you open the attached document I demonstrate how to drill down into the sound manager and display the underlying hardware where this "association" could be made without the need of editing a file.  It might be necessary for the dialog configuration box to create this "conf" file but causal users should not need to.

Comment 6 Lennart Poettering 2010-11-25 01:40:46 UTC
g-v-c has a drop-down to select the input source. Have you played around with that?

Comment 7 Paul Lambert 2010-11-25 03:29:24 UTC
Lennart,

I have found this link that shows the gnome-volume-control panel.  
http://fedoraproject.org/wiki/Features/VolumeControl

This example shows the HDA_INTEL device that is selectable as an input device.  However, when I open the sound control from the system preferences I only see Internal Audio Analog Stereo and when this alone is selected there is no sound output.  I have attached this dailog box screen shot.  So the reason it was necessary for me to install the PulseAudio Manager and go down the path I did was the fact that the g-v-c manager does not provide me the proper choices.

Comment 8 Paul Lambert 2010-11-25 03:30:25 UTC
Created attachment 462799 [details]
G-V-C dialog box

Comment 9 Paul Lambert 2010-11-25 03:46:37 UTC
Created attachment 462800 [details]
Sound Preferences Hardware tab screen capture


Note You need to log in before you can comment on or make changes to this bug.