Bug 653038 - dell laptop very hot
Summary: dell laptop very hot
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 07:31 UTC by Maarten
Modified: 2013-01-10 06:20 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-31 16:44:01 UTC
Type: ---


Attachments (Terms of Use)

Description Maarten 2010-11-14 07:31:12 UTC
Description of problem:
Updated Dell XPS-M1300 from F12 to F14 (using preupgrade, frequently updated since), since then the laptop runs very hot (easily 80C when busy, about 60-70 when idle). The problem is not related to dust, because when running a previous kernel (2.6.32.23-170.fc12.i686.PAE) or WinXP things are cool.

Version-Release number of selected component (if applicable):
No idea which component causes this.

How reproducible:
Always when running F14 using the default kernel

Comment 1 Maarten 2010-11-14 08:56:15 UTC
Hint: for some time now, a vertical band on the display shows distorted pixel colors (they also show rapidly changing "noise"). Could it be that some part of the graphics is going/melting?

Comment 2 Jesse Keating 2010-11-15 21:22:01 UTC
Stab in the dark...

Comment 3 Maarten 2010-11-16 12:47:01 UTC
The pixels are most distorted when temperature becomes higher (i.e. F14 working), and remain calmer when on WinXP or F12.

Comment 4 Maarten 2010-11-17 10:30:26 UTC
It seems more XPS F14 users have the same problems:

http://fedoraforum.org/forum/showthread.php?t=248403
https://bugzilla.redhat.com/show_bug.cgi?id=614691

Comment 5 Maarten 2010-11-17 15:34:33 UTC
Found a workaround:

Inspired by comment 5 of bug 614691 ( https://bugzilla.redhat.com/show_bug.cgi?id=614691 ) I actually installed i8kutils. 

Running i8kmon manually after logging in starts the fans and keeps my laptop cool.

Comment 6 Maarten 2010-11-21 10:32:28 UTC
i8kutils comes with problems as well, fan staying on at full throttle all time, reporting a (false) temperature of 127 C. 

Using /etc/grub.conf I now boot into 2.6.32.23-170.fc12.i686.PAE by default. Will try how my dell reacts to any new kernels as they come out.

Comment 7 Maarten 2010-12-30 22:34:20 UTC
2.6.35.10-74.fc14.i686.PAE works fine, temperatures at c. 50 C idle, I can live with that.

Comment 8 Josh Boyer 2011-08-31 16:44:01 UTC
closing per comment #7


Note You need to log in before you can comment on or make changes to this bug.