Bug 653151 - Brightness controls don't work on Thinkpad T410
Brightness controls don't work on Thinkpad T410
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
i686 Linux
low Severity high
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-14 12:47 EST by Istvan Cebrian
Modified: 2013-01-10 02:32 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-31 13:05:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smoltSendProfile -p (7.96 KB, text/plain)
2010-11-14 12:47 EST, Istvan Cebrian
no flags Details

  None (edit)
Description Istvan Cebrian 2010-11-14 12:47:45 EST
Created attachment 460390 [details]
smoltSendProfile -p

Description of problem:
Am running a fully updated version of Fedora 14 x86 (2.6.35.6-48.fc14.i686.PAE) on my Lenovo Thinkpad T410. Brightness controls either via keyboard or software don't work at all. Brightness is only dimmed when laptop is removed from AC power. When I plug it back in brightness is not restored and remains at a very low setting. Other FN+Key combinations work just fine.

The only way in which I can set brightness levels is by editing the file /sys/class/backlight/acpi_video0/brightness manually, so to set values I:

# echo 2 > /sys/class/backlight/acpi_video0/brightness (OR)
# echo 15 > /sys/class/backlight/acpi_video0/brightness 

I have tried using nvidia proprietary drivers but the problem is still present. In other distributions such as Linux Mint 10 problem was also present, however, it seemed that when I switched over to a console (using CTRL+ALT+F1) I could set the brightness there. In F12 when I switch over to a console and attempt setting the brightness I get a "^@" outputted and nothing happens.

Additional info:
# lspci -v
01:00.0 VGA compatible controller: nVidia Corporation GT218 [NVS 3100M] (rev a2) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 2142
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at cc000000 (32-bit, non-prefetchable) [size=16M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Memory at ce000000 (64-bit, prefetchable) [size=32M]
	I/O ports at 2000 [size=128]
	[virtual] Expansion ROM at cd000000 [disabled] [size=512K]
	Capabilities: [60] Power Management version 3
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [b4] Vendor Specific Information: Len=14 <?>
	Capabilities: [100] Virtual Channel
	Capabilities: [128] Power Budgeting <?>
	Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
	Kernel driver in use: nouveau
	Kernel modules: nouveau, nvidiafb

# ll -R /sys/class/backlight/
/sys/class/backlight/:
total 0
lrwxrwxrwx 1 root root 0 Nov 14 16:40 acpi_video0 -> ../../devices/virtual/backlight/acpi_video0
lrwxrwxrwx 1 root root 0 Nov 14 16:40 nv_backlight -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/nv_backlight

# grub entry
title Fedora (2.6.35.6-48.fc14.i686.PAE)
	root (hd0,0)
	kernel /vmlinuz-2.6.35.6-48.fc14.i686.PAE ro root=/dev/mapper/vg_iclaptop-lv_root rd_LVM_LV=vg_iclaptop/lv_root rd_LVM_LV=vg_iclaptop/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=pt-latin1 rhgb quiet
	initrd /initramfs-2.6.35.6-48.fc14.i686.PAE.img

# smoltSendProfile -p
(attached)

Possibly related bugs: 519105 & 588590
Comment 1 Istvan Cebrian 2010-11-15 15:22:53 EST
When I say F12 I meant F14.
Comment 2 Rolf Linder 2010-12-09 08:37:52 EST
Same issue here.

It worked on F13, starting in F14 it stopped. You are unable to control brightness (video card Nvidia NVS 3100M in a Lenovo T410i).

this also includes, you are not able to use any auto-dim funcitons, since it will not restore to the original brightness once it has dimmed.

As reported on the thinkpadwiki-page it seems, that is issue is not known on the lenovo T41X systems with intel graphics (seems related to the nvidia systems)
Comment 3 Kyle McMartin 2010-12-09 11:22:48 EST
Can you test the rawhide kernel, or the kernel from
http://repos.fedorapeople.org/repos/kyle/kernel/fedora-kernel.repo to see if it's fixed upstream in a newer release?

If so, we can then look at backporting it.

Thanks!
 Kyle
Comment 4 Istvan Cebrian 2010-12-11 12:10:31 EST
Hi Kyle,

So i've added repo http://repos.fedorapeople.org/repos/kyle/kernel/fedora-15/i386/ and upgrade to kernel 2.6.37-0.rc5.git2.1.fc15.i686.PAE and brightness controls are working once again.

What can I do now?

Btw last kernel I was using was 2.6.35.9-64.fc14.i686.PAE and brightness controls with this one still weren't working.

Regards,
Istvan
Comment 5 Kyle McMartin 2010-12-17 10:36:54 EST
OK, good. I'll try to backport a fix for this next week, although, if its fixed in 2.6.36.2, we might get it 'for free' if I update F14...

http://koji.fedoraproject.org/koji/buildinfo?buildID=208434

regards, Kyle
Comment 6 Sean Carlos 2010-12-22 14:16:12 EST
I have the same problem - brightness control function keys stopped working with the 2.6.35 series kernels, e.g.

kernel-2.6.35.9-64.fc14.x86_64.rpm

(you can still change brightness in gnome power control tool or using 
/sys/class/backlight/acpi_video0/brightness as noted above)

They do work in a kernel taken from the above noted repo:

2.6.37-0.rc5.git2.1.fc15.x86_64

and they work if I go back to a F13 kernel, e.g. 

kernel-2.6.34.7-63.fc13.x86_64.rpm

Laptop is a Sony Vaio FW series
VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650
Comment 7 Kyle McMartin 2010-12-22 16:31:30 EST
OK, thanks for testing. 2.6.37 will very quickly (I hope) make it to F-14/13, since it's seen quite a lot of positive testing (few 'unexpected' regressions as well)

In the meantime, any chance I could convince you to try:
http://koji.fedoraproject.org/koji/buildinfo?buildID=208434

Which is the last build of 2.6.36 I did in rawhide, so I can narrow down the changes and hopefully backport your fix to 2.6.35?
Comment 8 Sean Carlos 2010-12-22 17:14:34 EST
2.6.36.2-12.rc1.fc15.x86_64 solves this problem in my case of a Sony Vaio - brightness up/down keys (Fn + F5 / F + F6) work like a charm.  Thanks, would love to see this in F14.
Comment 9 Istvan Cebrian 2010-12-23 18:36:28 EST
Updated to 2.6.35.10-72.fc14.i686.PAE problem however persists.
Comment 10 Josh Boyer 2011-08-31 13:05:30 EDT
At this point we're going to encourage people with this issue to update to fedora 15.  This won't be fixed for f14.

Note You need to log in before you can comment on or make changes to this bug.