Bug 653283 - BSOD occured when do live migration during guest installation
BSOD occured when do live migration during guest installation
Status: CLOSED DUPLICATE of bug 578751
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
: Triaged
: 653284 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2010-11-15 03:12 EST by Mike Cao
Modified: 2013-01-10 22:32 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-17 08:51:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screendump when migration from host A to host B (197.68 KB, image/png)
2010-11-15 03:22 EST, Mike Cao
no flags Details

  None (edit)
Description Mike Cao 2010-11-15 03:12:44 EST
Description of problem:


Version-Release number of selected component (if applicable):
# uname -r 
2.6.18-230.el5
# rpm -q kvm
kvm-83-207.el5


How reproducible:
3/3

Steps to Reproduce:
1.start VM in src host 
CLI:/usr/libexec/qemu-kvm -no-hpet -no-kvm-pit-reinjection -usbdevice tablet -rtc-td-hack -startdate now -name win08R2 -smp 4 -m 8G -boot dc -net nic,vlan=0,macaddr=12:23:32:12:13:18,model=virtio -net tap,vlan=0,script=/etc/qemu-ifup -drive file=/dev/mike/install08,media=disk,if=virtio,cache=none,boot=on,format=raw,werror=stop -cpu qemu64 -M rhel5.6.0 -notify all -balloon virtio -monitor stdio -uuid 4e8567a1-4f9a-40aa-89d4-6278dd6c26d5 -cdrom /mnt/win08-R2.iso -fda /mnt/virtio-drivers-1.0.0-45801.vfd -spice port=5910,disable-ticketing,ic=on,host=0 -qxl 1
2.start listening port in dst host
3.ping-pong migrate while the installation of windows 08 R2 guest is in progress.
  
Actual results:
first time migration from host A to host B,the screen displays "setup.exe-NO disk".
click  "Try Again" in the guest ,guest continue installation.
then migration from host B to host A ,BSOD occurred.

Expected results:
installation should be completed successfully.

Additional info:
Comment 1 Mike Cao 2010-11-15 03:17:33 EST
*** Bug 653284 has been marked as a duplicate of this bug. ***
Comment 2 Mike Cao 2010-11-15 03:22:24 EST
Created attachment 460496 [details]
screendump when migration from host A to host B


btw ,hard to capture BSOD screen dump
Comment 4 Juan Quintela 2010-11-30 21:34:10 EST
what type of disk is that?
iSCSI/Fiber channel?

file=/dev/mike/install08,media=disk,if=virtio,cache=none,boot=on,format=raw,werror=stop

?

We have a problem with flushing the read cache for this, there is the start of a patch, but I haven't finished it.
Comment 5 Mike Cao 2010-11-30 21:38:23 EST
(In reply to comment #4)
> what type of disk is that?
> iSCSI/Fiber channel?
> 
> file=/dev/mike/install08,media=disk,if=virtio,cache=none,boot=on,format=raw,werror=stop
> 
> ?

iscsi.

> 
> We have a problem with flushing the read cache for this, there is the start of
> a patch, but I haven't finished it.
Comment 8 Juan Quintela 2011-01-17 08:51:45 EST

*** This bug has been marked as a duplicate of bug 578751 ***

Note You need to log in before you can comment on or make changes to this bug.