Bug 653344 - Periodic error message: Unknown format at
Periodic error message: Unknown format at
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-nls (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Sean Flanigan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-15 04:50 EST by Christoph Höger
Modified: 2011-01-04 15:59 EST (History)
9 users (show)

See Also:
Fixed In Version: eclipse-nls-3.6.0.v20100814043401-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 692358 (view as bug list)
Environment:
Last Closed: 2011-01-04 15:59:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christoph Höger 2010-11-15 04:50:05 EST
Description of problem:
Periodically my eclipse shows me an error about a malformatted message. This is a german locale. Not sure what plugin causes this.

Version-Release number of selected component (if applicable):
[choeger@elrond page-runtime]$ rpm -qa | grep eclipse
tomcat5-jasper-eclipse-5.5.27-7.4.fc12.noarch
eclipse-mylyn-java-3.4.0-4.fc14.noarch
eclipse-gef-3.6.0-1.fc14.noarch
eclipse-nls-de-3.5.0.v20090620043401-2.fc12.noarch
eclipse-dtp-1.8.0-1.fc14.noarch
eclipse-jgit-0.9.3-1.fc14.noarch
eclipse-nls-3.5.0.v20090620043401-2.fc12.noarch
eclipse-oprofile-0.6.1-1.fc14.x86_64
eclipse-pydev-1.6.1-1.fc14.x86_64
eclipse-birt-2.5.2-1.fc14.noarch
eclipse-subclipse-1.6.12-1.fc14.noarch
eclipse-rpm-editor-0.6.0-1.fc14.x86_64
eclipse-jdt-3.6.1-2.fc14.x86_64
eclipse-linuxprofilingframework-0.6.1-1.fc14.x86_64
eclipse-collabnet-merge-2.0.0-1.fc13.noarch
eclipse-cdt-7.0.1-2.fc14.x86_64
eclipse-valgrind-0.6.1-1.fc14.x86_64
eclipse-platform-3.6.1-2.fc14.x86_64
eclipse-emf-2.6.0-2.fc14.noarch
eclipse-mylyn-3.4.0-4.fc14.noarch
eclipse-rcp-3.6.1-2.fc14.x86_64
eclipse-changelog-2.6.7-5.fc14.x86_64
eclipse-pde-3.6.1-2.fc14.x86_64
eclipse-svnkit-1.3.3-5.fc14.noarch
eclipse-callgraph-0.6.1-1.fc14.x86_64
eclipse-egit-0.9.3-1.fc14.noarch
icu4j-eclipse-4.2.1-1.fc14.x86_64
eclipse-swt-3.6.1-2.fc14.x86_64
eclipse-rse-3.2-1.fc14.noarch


How reproducible:
always

Steps to Reproduce:
1. Start eclipse
2. Save some java file
  
Actual results:
error message pops up

Additional info:
Stack trace from log:

java.lang.IllegalArgumentException: unknown format type at 
	at com.ibm.icu.text.MessageFormat.makeFormat(MessageFormat.java:2069)
	at com.ibm.icu.text.MessageFormat.applyPattern(MessageFormat.java:571)
	at com.ibm.icu.text.MessageFormat.<init>(MessageFormat.java:420)
	at com.ibm.icu.text.MessageFormat.format(MessageFormat.java:1109)
	at org.eclipse.ui.internal.views.markers.ExtendedMarkersView.getStatusMessage(ExtendedMarkersView.java:890)
	at org.eclipse.ui.internal.views.markers.ExtendedMarkersView.updateTitle(ExtendedMarkersView.java:1395)
	at org.eclipse.ui.internal.views.markers.UIUpdateJob.runInUIThread(UIUpdateJob.java:117)
	at org.eclipse.ui.progress.UIJob$1.run(UIJob.java:95)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3515)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3164)
	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1383)
Comment 1 greubel 2010-11-21 06:43:14 EST
Workaround: Remove the nls package for eclipse. In my case this was

Nov 21 12:39:20 Erased: eclipse-nls-de

Then the problem seems to be gone.
Comment 2 Alexander Kurtakov 2010-11-22 02:49:21 EST
So this is a problem with eclipse-nls. Changing component.
Comment 3 Christoph Höger 2010-11-23 17:04:05 EST
Yeah, seems to be a bad formatted translation string. I hoped someone with a little more spare time then me currently could figure out what string that was from the backtrace and fix it. Maybe I could do it next week if noone steps in.
Comment 4 greubel 2010-11-24 01:30:54 EST
If it helps: it occurs any time, when some entry in the error log appear (or maybe also disappear - not tested). For example, if you compile a C Makefile project which has some warnings (unused variables, etc.)
Comment 5 Sean Flanigan 2010-11-29 00:06:25 EST
I haven't had a chance to reproduce the problem yet, but does anyone want to try the updated lang packs to see if they fix the problem?

http://koji.fedoraproject.org/koji/taskinfo?taskID=2631446

You'll need to grab the base rpm:
 eclipse-nls-3.6.0.v20100814043401-1.fc15.noarch.rpm 
plus the 'de' rpm:
 eclipse-nls-de-3.6.0.v20100814043401-1.fc15.noarch.rpm
Comment 7 Fedora Update System 2010-12-09 20:08:13 EST
eclipse-nls-3.6.0.v20100814043401-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/eclipse-nls-3.6.0.v20100814043401-2.fc14
Comment 8 Fedora Update System 2010-12-10 15:25:50 EST
eclipse-nls-3.6.0.v20100814043401-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eclipse-nls'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/eclipse-nls-3.6.0.v20100814043401-2.fc14
Comment 9 greubel 2010-12-28 07:37:29 EST
Installed using the recommended command, started eclipse, rebuild a project which contains warnings (CDT).

eclipse-nls-de-3.6.0.v20100814043401-2.fc14.noarch solves the problem for me.

Thank you.
Comment 10 Fedora Update System 2011-01-04 15:59:46 EST
eclipse-nls-3.6.0.v20100814043401-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.