Bug 653419 - [abrt] gnome-color-manager-2.91.2-1.fc15: cmsSetEncodedICCversion: Process /usr/bin/gcm-apply was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnome-color-manager-2.91.2-1.fc15: cmsSetEncodedICCversion: Process /u...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-color-manager
Version: rawhide
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:78f7c26580b2a6118a0445a88a8...
: 653707 654788 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-15 11:48 UTC by Tim Waugh
Modified: 2018-04-11 08:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-26 10:12:22 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (12.90 KB, text/plain)
2010-11-15 11:48 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2010-11-15 11:48:39 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: gcm-apply --login
comment: Happened while logging in.
component: gnome-color-manager
crash_function: cmsSetEncodedICCversion
executable: /usr/bin/gcm-apply
kernel: 2.6.36-1.fc15.x86_64
package: gnome-color-manager-2.91.2-1.fc15
rating: 4
reason: Process /usr/bin/gcm-apply was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1289820629
uid: 500

Comment 1 Tim Waugh 2010-11-15 11:48:42 UTC
Created attachment 460527 [details]
File: backtrace

Comment 2 Richard Hughes 2010-11-15 16:28:59 UTC
Hmm, cmsCreateRGBProfile must have failed. What is the output of "gcm-apply --verbose" please. Thanks.

Comment 3 Tim Waugh 2010-11-15 16:59:02 UTC
[tim@localhost ~]$ gcm-apply --verbose
16:57:43        Verbose debugging enabled (on console 1)
16:57:43        loading: 1
16:57:43        adding devices of type XRandR
16:57:43        loading: /usr/share/hwdata/pnp.ids
16:57:43        asking to add xrandr_default
16:57:43        loading: 0
16:57:43        auto-profile edid does not exist, creating as /home/tim/.local/share/icc/edid-(null).icc
Segmentation fault (core dumped)

This is a KVM virtual host.

Comment 4 Richard Hughes 2010-11-15 17:27:01 UTC
Great, thanks:

commit 45e9ed64837914878ce96dc7d31d332874f6e698
Author: Richard Hughes <richard@hughsie.com>
Date:   Mon Nov 15 17:26:46 2010 +0000

    Do not create auto-profiles for XRandR devices without EDID data

Comment 5 Richard Hughes 2010-11-16 09:06:54 UTC
*** Bug 653707 has been marked as a duplicate of this bug. ***

Comment 6 Jens Petersen 2010-11-18 02:32:10 UTC
Package: gnome-color-manager-2.91.2-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. login to Fedora rawhide and crash!

Comment 7 Richard Hughes 2011-04-26 10:13:02 UTC
*** Bug 654788 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.