Bug 65379 - internal compiler error building jikes1.15-1 by gcc-3.1-1
Summary: internal compiler error building jikes1.15-1 by gcc-3.1-1
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc3   
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2002-05-22 21:12 UTC by Sergey V. Udaltsov
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version: 3.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 18:10:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The temporary file (848.03 KB, text/plain)
2002-05-23 08:17 UTC, Sergey V. Udaltsov
no flags Details

Description Sergey V. Udaltsov 2002-05-22 21:12:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i686; U;) Gecko/20020519

Description of problem:
Internal compiler error building double.cc

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Build jikes from src.rpm. (first, it is necessarry to comment out NAN in
double.h - because it is defined in gcc's standard headers)
	

Additional info:

Comment 1 Jakub Jelinek 2002-05-22 22:10:28 UTC
Can you please write here the g++ options used to reproduce it, rerun it
with -save-temps in addition to that and attach here double.ii?
Thanks.

Comment 2 Sergey V. Udaltsov 2002-05-23 08:16:29 UTC
The command line is:

i686-redhat-linux-g++ -DHAVE_CONFIG_H -I. -I. -I.     -O2 -march=i686 -c -o
double.o `test -f double.cpp || echo './'`double.cpp

Comment 3 Sergey V. Udaltsov 2002-05-23 08:17:47 UTC
Created attachment 58267 [details]
The temporary file

Comment 4 Jakub Jelinek 2002-05-23 09:53:34 UTC
The primary problem is that g++ 3.x defines _GNU_SOURCE unconditionally for C++,
so e.g. <bits/nan.h> gets included, which colides with Jikes' NAN enum.
Either Jikes should #undef NAN after including all headers, or choose another
name for NAN in the enum.

But of course, compiler shouldn't segfault. Looking into it.


Note You need to log in before you can comment on or make changes to this bug.