Bug 654302 - nag mail triggers on wrong states
Summary: nag mail triggers on wrong states
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: scheduler
Version: 0.5
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ---
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard:
: 654224 654303 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-17 14:26 UTC by Matt Brodeur
Modified: 2019-05-22 13:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-24 14:06:08 UTC


Attachments (Terms of Use)

Description Matt Brodeur 2010-11-17 14:26:36 UTC
I'll file one bug instead of the seven I was tempted to.

The new beaker nag mail triggers on system states I was assured wouldn't be nagged about.  Examples:

[Beaker Reminder]: System musashi.usersys.redhat.com 
This is my personal laptop.  Owner: mbrodeur, User: mbrodeur, not shared, SECRET, Automated (just fixed that part)


[Beaker Reminder]: System intel-s6e62-03.lab.bos.redhat.com 
Broken system that we're still working on.  Owner: mbrodeur, User: mbrodeur, Shared, Broken


[Beaker Reminder]: System rhts-nfs-02.rhts.eng.bos.redhat.com 
Eng-ops server.  Owner: mbrodeur, User: mbrodeur, not shared, Automated?! (fixed)


[Beaker Reminder]: System db01.db.eng.bos.redhat.com
[Beaker Reminder]: System db02.db.eng.bos.redhat.com
Eng-ops server.  Owner: mbrodeur, User: mbrodeur, not shared, SECRET, Automated/Broken


[Beaker Reminder]: System alpo.boston.devel.redhat.com 
[Beaker Reminder]: System innova.boston.devel.redhat.com
Eng-ops servers.  Owner: mbrodeur, User: mbrodeur, not shared, SECRET, Automated (fixed)


So, at least two problems.  The nag mail shouldn't hit for systems where the user is also the owner.   It probably also shouldn't go to non-shared systems.  There's also the issue of systems previously marked broken becoming Automated, but that's a separate problem.

Comment 1 Dan Callaghan 2010-11-17 22:53:02 UTC
*** Bug 654303 has been marked as a duplicate of this bug. ***

Comment 2 Raymond Mancy 2010-11-18 01:09:05 UTC
A the moment the only filtering that happens is based on whether or not the system was reserved via the web UI, and the amount of time it's been taken for. From what I can tell that's the way it's always been.

We can easily change that to exclude 

1) Shared systems
2) user == owner

Comment 3 Raymond Mancy 2010-11-18 01:10:01 UTC
(In reply to comment #2)
> A the moment the only filtering that happens is based on whether or not the
> system was reserved via the web UI, and the amount of time it's been taken for.
> From what I can tell that's the way it's always been.
> 
> We can easily change that to exclude 
> 
> 1) Shared systems

I mean non shared systems of course

> 2) user == owner

Comment 5 Dan Callaghan 2010-11-18 05:49:48 UTC
*** Bug 654224 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.