Bug 65435 - VariCAD crashes on kde2-compat libraries
VariCAD crashes on kde2-compat libraries
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kde2-compat (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-23 20:05 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-28 12:21:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
message from kde crash with VariCad (417 bytes, text/plain)
2002-07-12 17:07 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-05-23 20:05:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; CDonDemand; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
VariCAD 8.2.0.1-1 ran under 7.2 without problems. I upgraded to 7.3 and it no
longer runs . I corrected the permissions of the kde2-compat libraries per the
bug report and VariCAD instructions and pointed varicad to the kdecompat
libraries. When it is run it give a SIGSEV 11 error under kde with the following
message:
(no debugging symbols found)...[New Thread 1024 (LWP 2204)]
0x420b4769 in wait4 () from /lib/i686/libc.so.6
#0  0x420b4769 in wait4 () from /lib/i686/libc.so.6
#1  0x4213030c in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x405e1f0b in KCrash::defaultCrashHandler ()
   from /usr/lib/kde2-compat/lib/libkdecore.so.3
#3  0x410b4f75 in pthread_sighandler () from /lib/i686/libpthread.so.0
#4  <signal handler called>

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run /usr/bin/varicad
2.
3.
	

Actual Results:  program opens with logo and then crashes.

Expected Results:  Program should have opened and been stable

Additional info:

Was fine under kde 2.2 and RedHat 7.2. Upgrade resulted in the problem and seems
to be related to the kde 2 compatible libraries which appear not to be compatible.
Comment 1 Karsten Hopp 2002-07-12 16:41:21 EDT
Can you please check if this is the same bug as  
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=64668 ?  
Does it work if you fix the permissions with   
find /usr/lib/kde2-compat -type d -exec chmod a+x {} \;
Comment 2 Need Real Name 2002-07-12 17:07:26 EDT
Created attachment 65184 [details]
message from kde crash with VariCad
Comment 3 Need Real Name 2002-07-12 17:09:26 EDT
No this is not the same as bug 64688. The fix does not correct the problem.
Comment 4 Need Real Name 2002-09-28 12:21:05 EDT
Since this isn't closed, I would like guidance as to where to take it next.
VariCAD had me do an strace and they say the results show the problem is not in
VariCAD, but in something external to VariCAD, possibly OpenGL. I have no idea
what to do. I have a Matrox G400 video card and other programs requiring OpenGL
(like AC3D) run fine. Where would be the correct place to post this problem
since it appears to be a one of a kind issue? Right now I am trying to learn
other CAD programs to replace VariCAD, and have tried Octree, Cycas, and ohters,
but none provide me with the ease of VariCAD.  Any suggestions on where to take
this would be appreciated. I cannot find an opengl section on bugzilla under RedHat.
Leon
Comment 5 Ngo Than 2002-11-07 18:42:47 EST
it's a close source. You should download a new version of VariCAD from
http://www.varicad.com/.

There is a VariCAD version for RHL 7.2/7.3/8.0 here. Please get the correct
version, it should work for you.

Note You need to log in before you can comment on or make changes to this bug.