Bug 654373 - [abrt] Zim-0.49-1.fc14: quicknote.py:175:_init_inputs:KeyError: 'newpage'
[abrt] Zim-0.49-1.fc14: quicknote.py:175:_init_inputs:KeyError: 'newpage'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:b0b4d0fe
:
: 668516 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-17 12:56 EST by hugotrip
Modified: 2011-02-24 01:28 EST (History)
4 users (show)

See Also:
Fixed In Version: Zim-0.50-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-24 01:28:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (805 bytes, text/plain)
2010-11-17 12:57 EST, hugotrip
no flags Details

  None (edit)
Description hugotrip 2010-11-17 12:56:57 EST
abrt version: 1.1.13
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/zim
component: Zim
executable: /usr/bin/zim
kernel: 2.6.35.6-48.fc14.x86_64
package: Zim-0.49-1.fc14
reason: quicknote.py:175:_init_inputs:KeyError: 'newpage'
release: Fedora release 14 (Laughlin)
How to reproduce: I right-clicked on the notification area icon to write a quick note and it crashed
time: 1290016508
uid: 500

backtrace
-----
quicknote.py:175:_init_inputs:KeyError: 'newpage'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/plugins/trayicon.py", line 208, in do_quick_note
    dialog = QuickNoteDialog(None, {})
  File "/usr/lib/python2.7/site-packages/zim/plugins/quicknote.py", line 321, in __init__
    self._init_inputs(namespace, basename, text, template_options, table)
  File "/usr/lib/python2.7/site-packages/zim/plugins/quicknote.py", line 175, in _init_inputs
    self.inputs['newpage'].set_active(self.uistate['newpage'])
KeyError: 'newpage'

Local variables in innermost frame:
text: None
basename: None
namespace: None
template_options: {}
table: <gtk.Table object at 0x1f550f0 (GtkTable at 0x206f540)>
self: <QuickNoteDialog object at 0x1f35fa0 (zim+gui+widgets+Dialog at 0x207d050)>
Comment 1 hugotrip 2010-11-17 12:57:02 EST
Created attachment 461120 [details]
File: backtrace
Comment 2 Robin Lee 2010-11-17 14:03:16 EST
Forwarded upstream: https://bugs.launchpad.net/zim/+bug/676641
Comment 3 Renich Bon Ciric 2010-12-26 21:55:34 EST
Package: Zim-0.49-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Try making a quick note
Comment 4 Robin Lee 2011-01-03 20:01:08 EST
Marked 'fix committed' upstream.
Comment 5 Robin Lee 2011-01-10 12:23:20 EST
*** Bug 668516 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2011-02-15 12:28:26 EST
Zim-0.50-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Zim-0.50-1.fc14
Comment 7 Fedora Update System 2011-02-15 16:25:55 EST
Zim-0.50-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Zim'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/Zim-0.50-1.fc14
Comment 8 Fedora Update System 2011-02-24 01:28:09 EST
Zim-0.50-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.