Bug 654426 - Nautilus fails to write to windows share
Summary: Nautilus fails to write to windows share
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba
Version: 6.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Guenther Deschner
QA Contact: Martin Cermak
URL:
Whiteboard:
: 617614 (view as bug list)
Depends On: 598620
Blocks: 654408
TreeView+ depends on / blocked
 
Reported: 2010-11-17 20:26 UTC by Jack Neely
Modified: 2018-11-14 16:22 UTC (History)
20 users (show)

Fixed In Version: samba-3.5.4-73.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 598620
Environment:
Last Closed: 2011-05-19 13:14:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0582 normal SHIPPED_LIVE samba bug fix and enhancement update 2011-05-19 09:37:35 UTC

Description Jack Neely 2010-11-17 20:26:59 UTC
I can duplicate this bug on RHEL 6.  My Windows server I'm connecting to is an EMC Celerra device running code revision 6.0.36.4.

+++ This bug was initially created as a clone of Bug #598620 +++

Description of problem:
Nautilus fails to write to windows share

Version-Release number of selected component (if applicable):
nautilus-2.30.1-3.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a windows share with "Application -> Places -> Connect to server"
2. Open the share's folder on desktop
3. Drop a file to the folder
  
Actual results:
Get the error: Error while copying "somefile.ext".
There was an error copying the file into smb://xx%5Bxxx;name@server/external1/user.
Invalid argument

Expected results:
File is copied to the share

Additional info:
Coping the file from command prompt `cp somefile.txt '~/.gvfs/my share'` is OK.

Also, it isn't good that error message reveals user credentials for a share.

--- Additional comment from nk@r-networks.ru on 2010-06-01 14:12:02 EDT ---

Oops! Forgot to mention. Nautilus reads files from the windows share just fine.

--- Additional comment from tbzatek@redhat.com on 2010-06-02 06:30:38 EDT ---

(In reply to comment #0)
> Additional info:
> Coping the file from command prompt `cp somefile.txt '~/.gvfs/my share'` is OK.
This is weird. Can you try using gvfs-copy? This seems to be like a fault when setting mtime or any additional attributes.

--- Additional comment from nk@r-networks.ru on 2010-06-02 14:50:59 EDT ---

With gvfs-copy I've got the same error as with Nautilus.

But I found out something new. The problem exists with files lengthy than 16KB. If a file has length less than 16KB it is copied OK with Nautilus, if a file is lengthier it is copied no more than 48KB and fire out the error. Coping is fine with cp command. 

And about revealing the password - it is my fault, I mixed domain name and password while creating the bookmark for the share :(

--- Additional comment from tbzatek@redhat.com on 2010-06-03 06:20:00 EDT ---

Interesting, can you please provide version of the libsmbclient package?

Also, can you please grab output of `GVFS_SMB_DEBUG="99" GVFS_DEBUG="1" /usr/libexec/gvfsd -r` and attach it here - it may contain useful information.

--- Additional comment from nk@r-networks.ru on 2010-06-03 08:15:41 EDT ---

Created attachment 419347 [details]
gvfsd debug output

Output from `GVFS_SMB_DEBUG="99" GVFS_DEBUG="1" /usr/libexec/gvfsd -r`

libsmbclient.x86_64 - 3.5.3-61.fc13

--- Additional comment from nk@r-networks.ru on 2010-06-16 14:48:01 EDT ---

The same with gvfs.x86_64 - 1.6.2-1.fc13

--- Additional comment from rostiku@ukr.net on 2010-07-09 03:50:22 EDT ---

The same error in Nautilus.i686 when copy files to Windows 2003 x64.
Copied only 48KB then "Invalid argument".

Versions:
nautilus-2.30.1-3.fc13.i686
libsmbclient-3.5.4-62.fc13.i686

--- Additional comment from tbzatek@redhat.com on 2010-07-19 12:25:30 EDT ---

(In reply to comment #7)
> The same error in Nautilus.i686 when copy files to Windows 2003 x64.
> Copied only 48KB then "Invalid argument".
> 
> Versions:
> nautilus-2.30.1-3.fc13.i686
> libsmbclient-3.5.4-62.fc13.i686    
Can you verify that uploading files via smbclient works and so does "cp somefile.txt '~/.gvfs/my share'" ?

--- Additional comment from wijngaarde@gmail.com on 2010-07-20 04:23:09 EDT ---

- Copying using 'cp' WORKS

- Copying using 'gvfs-copy' FAILS with message "Invalid argument"

- Copying using 'smbclient' WORKS

So the problem seems to be with gvfs-copy

--- Additional comment from tbzatek@redhat.com on 2010-07-21 10:39:32 EDT ---

*** Bug 615332 has been marked as a duplicate of this bug. ***

--- Additional comment from tbzatek@redhat.com on 2010-07-23 08:03:45 EDT ---

Just tested file copy using nautilus and gvfs-copy to clean Windows 2003 Server x64 machine with libsmbclient-3.5.4-62.fc13.x86_64 and everything works as expected. Is there anything specific set on the server? This is difficult to debug, I can't see anything obvious from the daemon log attached.

--- Additional comment from nk@r-networks.ru on 2010-07-23 08:57:28 EDT ---

Windows 2003 EE Server SP2 with default network settings - writes with error. I've got the same result over local connection and over Internet VPN. But now writes no more then 64KB of file. 16KB "magic" length seems preserved.

libsmbclient-3.5.4-62.fc13.x86_64
gvfs-1.6.2-1.fc13.x86_64
nautilus-2.30.1-3.fc13.x86_64

--- Additional comment from nk@r-networks.ru on 2010-07-23 09:14:18 EDT ---

With Samba share on local network write is OK!

--- Additional comment from ricardoalonsos@gmail.com on 2010-07-23 15:24:49 EDT ---

The cp command to .gvfs/my share with big files (>300MB) fails with the same message:
"Invalid argument"

--- Additional comment from nk@r-networks.ru on 2010-07-26 06:24:52 EDT ---

I have no errors with cp command. Tested on a 600MB length file, local network.

--- Additional comment from fjo@kth.se on 2010-09-02 04:10:05 EDT ---

FYI We are seeing the same problems trying to access servers from Fedora 13 since they were upgraded to Windows 2008 R2 this summer.

--- Additional comment from fjo@kth.se on 2010-09-02 04:13:35 EDT ---

I should add some Fedora version information:

gvfs-1.6.2-1.fc13.x86_64
gvfs-smb-1.6.2-1.fc13.x86_64
libsmbclient-3.5.4-63.fc13.x86_64
nautilus-2.30.1-6.fc13.x86_64

--- Additional comment from brianna007@gmail.com on 2010-09-02 10:25:16 EDT ---

(my original details: https://bugzilla.redhat.com/show_bug.cgi?id=615332)

I have a D-Link DNS-321 NAS sitting in my office and found that I get the same error (Error while copying "filename") when using Nautilus to try an copy files to the D-Link (navigated & authenticated against the D-links' "Windows Share" in Nautilus).

If I mount the D-Link manually (or add it to fstab) it works correctly.

--- Additional comment from wijngaarde@gmail.com on 2010-09-22 08:05:50 EDT ---

Is there anything we can do to help resolve this bug? i.e. debug information or anything from the windows server side. I'm not a Windows expert, but if you point me in a direction I can try and maybe to get some information from the windows side.

--- Additional comment from simon_t_scott@ntlworld.com on 2010-10-17 06:17:03 EDT ---

Just wondering if there is an update for this one please?

I have the same issue writing to shares on my Windows 2008 R2 server. Also have found that OpenOffice 3 Writer is unable to save files to the windows share.

Thank you.

--- Additional comment from nk@r-networks.ru on 2010-10-17 11:54:31 EDT ---

As I know there is no update and no activity to found out a solution :(

--- Additional comment from felix.schwarz@oss.schwarz.eu on 2010-10-18 02:48:05 EDT ---

I think the issue is related to SMB signing (or whatever the correct term is). Disabling SMB signing via a group policy on your Windows server and try again to confirm that this is the real issue.

--- Additional comment from tbzatek@redhat.com on 2010-10-18 06:04:19 EDT ---

This is more a samba fault, gvfs code has not been changed for a long time and it's actually so simple that's difficult to influence this.

We need a good reproducer to be able to investigate this issue more and handle it to samba developers if needed. The issue doesn't appear with cleanly installed Windows 2003 Server in default configuration on local network.

There's samba-3.5.6-69.fc13 build available in updates-testing, can you give it a shot please?

--- Additional comment from fjo@kth.se on 2010-10-18 07:56:10 EDT ---

As stated previously, this fault occured this summer, probably after SP2. So a clean install of Windows 2003 server is not sufficient to reproduce. At least SP2 and possibly later patches must be applied.

As long as the debugging is on the client side I can help, it is a bit harder for me to get much support on the server side due to system-boundary issues and lack of resources, but if I can get proper instructions on how to get necessary data I can try to get it from the windows staff.

--- Additional comment from felix.schwarz@oss.schwarz.eu on 2010-10-18 09:23:44 EDT ---

The first thing to know is if SMB signing is enabled. You should be able to find that out also via Wireshark + the right modules.

--- Additional comment from nk@r-networks.ru on 2010-10-18 11:54:30 EDT ---

samba-3.5.6-69.fc13 doesn't change the thing.

Security policies for client and server:
Digitally sign communications (always) - Disabled
Digitally sign communications (if server agrees) - Enabled

No help. So I didn't reboot the Windows Server after I changed the policy.

--- Additional comment from nk@r-networks.ru on 2010-10-18 12:00:06 EDT ---

Security policies were:

Microsoft network client: Digitally sign communications (always) - Not Defined
Microsoft network client: Digitally sign communications (if server agrees) - Not Defined

Microsoft network server: Digitally sign communications (always) - Enabled
Microsoft network server: Digitally sign communications (if server agrees) - Enabled

--- Additional comment from john.kissane@tyndall.ie on 2010-10-20 04:51:00 EDT ---

I've been doing some testing of this as two users have complained that transferring files with Krusader didn't work any more when they moved to Fedora 13. Presumably it's the same underlying issues as with Nautilus?

It works fine with Fedora 12 (ie it can transfer any sized file) but doesn't work on Fedora 13 (or the beta of Fedora 14) where only small files (~ less than 32kb) can be copied.

The Windows servers was the same for all the tests.

If there's anything I can do to help get this solved just let me know.

--- Additional comment from simon_t_scott@ntlworld.com on 2010-10-21 03:19:18 EDT ---

Likewise - I have limited resources and am a complete Linux newbie but happy to help if I can.

--- Additional comment from jclai@internode.on.net on 2010-10-27 23:49:52 EDT ---

I have the same problem with invalid argument, and only to manage of creating small text files. 

Certainly there was a connection and correct authorization between networks. I doubt my windows 2003 SBS settings or the hardware were incorrect because i can make connections using OS (Windows 7) of a different partition on the same computer. Something isn't right about 64bit Fedora 13. 

The Linux version i had was 2.6.33.3-85.fc13.x86_64
smbclient Version 3.5.5-68.fc13
Gnome Nautilus 2.30.1

Hopefully a patch coming out soon, cause isn't very productive!

--- Additional comment from jclai@internode.on.net on 2010-10-27 23:51:33 EDT ---

Another thing, the file size limit to 48kb before it hits error, if copy over the nautilus explorer.

--- Additional comment from fjo@kth.se on 2010-11-02 03:39:15 EDT ---

To add a bit more details: mounting works, i.e, using a command such as the one below and writing to the mount-point works fine.

mount -t cifs -o "user=username,domain=Domain" server:/share /mountpoint

"Mounting" with nautilus does not work and the files get truncated after 48kb. 

Your request of:

"The first thing to know is if SMB signing is enabled. You should be able to
find that out also via Wireshark + the right modules."

Is a little bit too unspecific for me to spend time on it, especially since I very much doubt this is the issue.

Best regards

--- Additional comment from ricardoalonsos@gmail.com on 2010-11-02 10:12:05 EDT ---

In Fedora 14 i couldn't reproduce the problem

gvfs-1.6.4-2.fc14.x86_64
gvfs-smb-1.6.4-2.fc14.x86_64
libsmbclient-3.5.6-69.fc14.x86_64
nautilus-2.32.0-1.fc14.x86_64

It works perfectly with a 350Mb file.

--- Additional comment from john.kissane@tyndall.ie on 2010-11-02 11:19:42 EDT ---

(In reply to comment #33)
> In Fedora 14 i couldn't reproduce the problem
> 
> gvfs-1.6.4-2.fc14.x86_64
> gvfs-smb-1.6.4-2.fc14.x86_64
> libsmbclient-3.5.6-69.fc14.x86_64
> nautilus-2.32.0-1.fc14.x86_64
> 
> It works perfectly with a 350Mb file.

I updated my Fedora 14 VM just now which pulled in the same version of the libsmbclient package as you and I still see the same problem where I cannot copy a file from Fedora to the Windows Server. It stops & leaves a file of size 32kb in the directory. No problem copying in the opposite direction.

--- Additional comment from nk@r-networks.ru on 2010-11-03 08:58:12 EDT ---

Just upgraded to Fedora 14. The problem is still here. :(

--- Additional comment from wijngaarde@gmail.com on 2010-11-05 03:33:28 EDT ---

(In reply to comment #33)
> In Fedora 14 i couldn't reproduce the problem
> 
> gvfs-1.6.4-2.fc14.x86_64
> gvfs-smb-1.6.4-2.fc14.x86_64
> libsmbclient-3.5.6-69.fc14.x86_64
> nautilus-2.32.0-1.fc14.x86_64
> 
> It works perfectly with a 350Mb file.

I just dit a clean install of Fedora 14 32bit, same problem still exists. Did you do a *clean* install? Did you add some additional packages? Only difference between packages listed above is 32 bit vs 64 bit...

--- Additional comment from ricardoalonsos@gmail.com on 2010-11-05 09:03:15 EDT ---

I did an upgrade from Fedora 13 to 14 using yum (both 64 bit). I don't know if there are others packages involved in this operation. I have some extensions like these:

nautilus-2.32.0-1.fc14.x86_64
nautilus-python-0.7.0-2.fc14.x86_64
nautilus-sendto-2.31.7-1.fc14.x86_64
rabbitvcs-nautilus-0.13.3-2.fc14.x86_64
brasero-nautilus-2.32.0-1.fc14.x86_64
nautilus-extensions-2.32.0-1.fc14.x86_64
totem-nautilus-2.32.0-1.fc14.x86_64
evince-nautilus-2.32.0-1.fc14.x86_64

but I can't say if they are involved in the process of gvfs. I did the tests again with 1,5k, 15Mb and 350Mb in both directions (copy to windows share and then copy it again to my machine).

--- Additional comment from john.kissane@tyndall.ie on 2010-11-05 10:29:48 EDT ---

(In reply to comment #37)
> I did an upgrade from Fedora 13 to 14 using yum (both 64 bit). I don't know if
> there are others packages involved in this operation. I have some extensions
> like these:
> 
> nautilus-2.32.0-1.fc14.x86_64
> nautilus-python-0.7.0-2.fc14.x86_64
> nautilus-sendto-2.31.7-1.fc14.x86_64
> rabbitvcs-nautilus-0.13.3-2.fc14.x86_64
> brasero-nautilus-2.32.0-1.fc14.x86_64
> nautilus-extensions-2.32.0-1.fc14.x86_64
> totem-nautilus-2.32.0-1.fc14.x86_64
> evince-nautilus-2.32.0-1.fc14.x86_64
> 
> but I can't say if they are involved in the process of gvfs. I did the tests
> again with 1,5k, 15Mb and 350Mb in both directions (copy to windows share and
> then copy it again to my machine).

Didn't have some of those packages but even after installing it made no difference. Copying large files to the Windows sever fails still, I did some testing with a text file & the largest file I can copy over is 16384 bytes long ie.

[jkissane@fedora14 Desktop]$ ls -l
total 16
-rw-rw-r--. 1 jkissane jkissane 16384 Nov  5 14:26 jk.txt

--- Additional comment from oded@geek.co.il on 2010-11-08 02:52:10 EST ---

I have the exact same problem in both Fedora 14 and Ubuntu 10.10: copying using Nautilus gvfs mounts or Dolphin KIO mounts fails with the error "Invalid Argument" after about 48K.

Copying with the gvfs-copy command also fails with the same problem, but copying with the smbclient command works well.

The server is Windows 2003 SBS.

The relevant bug report in GNOME's bugzilla is this: https://bugzilla.gnome.org/show_bug.cgi?id=588391 - this is the original bug report coordinated with Debian and Ubuntu which was eventually fixed by Jeremy Allison in Samba's tree. On the face of it this looks to be the same problem, which means a regression in Fedora's samba 3.5.6.

--- Additional comment from libregeek@gmail.com on 2010-11-10 02:36:35 EST ---

Confirmed this bug in Fedora 14

nautilus-2.32.0-1.fc14.x86_64
libsmbclient-3.5.6-69.fc14.x86_64
gvfs-smb-1.6.4-3.fc14.x86_64

--- Additional comment from oded@geek.co.il on 2010-11-11 06:14:13 EST ---

Adding Guenther Deschner (Samba packager in Fedora) to CC list. Guenther - if you're not the right person to handle this, I apologize in advance.

Apparently this bug is fixed by Jeremy Allison's patch in GNOME's Bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=633937 . 

I've tested the patch and it seems to work well in KDE using Dolphin (I haven't tested GVFS as I'm having some GNOME configuration issues). 

According to Jeremy Allison this patch is scheduled for inclusion in the Samba 3.5.7 upstream release, but until that is released, packaged and distributed for Fedora - it might be a good idea to add the patch to the current Samba build.

Comment 2 Tomáš Bžatek 2010-11-18 13:18:05 UTC
Reassigning to samba to get the patch packaged.

Comment 3 Jack Neely 2010-11-19 19:06:43 UTC
The libsmbclient 3.5.6-70.fc14 in Fedora 14 does fix this issue.

Comment 9 Guenther Deschner 2011-02-04 10:56:55 UTC
*** Bug 617614 has been marked as a duplicate of this bug. ***

Comment 13 Martin Cermak 2011-03-08 08:19:58 UTC
Comments #10, #12 => Verified.

Comment 14 errata-xmlrpc 2011-05-19 13:14:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0582.html


Note You need to log in before you can comment on or make changes to this bug.