This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 654606 - smartmontools does not support LSI MegaRAID
smartmontools does not support LSI MegaRAID
Status: CLOSED DUPLICATE of bug 519261
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: smartmontools (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Michal Hlavinka
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-18 06:41 EST by Gerrit Slomma
Modified: 2010-11-18 09:17 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-18 07:49:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerrit Slomma 2010-11-18 06:41:13 EST
Description of problem:

smartmontools does not support LSI MegaRAID, smart-status of disks behind LSI MegaRAID could not be queried. Maybe the version is to old - 2008-08-07 according to the changelog.

Version-Release number of selected component (if applicable):

1:5.38-2.el5

How reproducible:

invoke smartmontools with --help, no option for megaraid available under -d TYPE

Steps to Reproduce:
1. smartmontools --help
2. look up the section with -d TYPE
3.
  
Actual results:

no option for megaraid

Expected results:

option for megaraid to query

Additional info:

I have some Fujitsu RX300 S6 with RAID 5/6-controller - based on LSI SAS2108 according to the Fujitus-datasheet at
https://globalsp.ts.fujitsu.com/dmsp/docs/ds-py-rx300-s6.pdf
Kernel does get the controller:

megasas: FW now in Ready state
scsi0 : LSI SAS based MegaRAID driver
  Vendor: SEAGATE   Model: ST9146852SS       Rev: 5203
  Type:   Direct-Access                      ANSI SCSI revision: 05
  Vendor: SEAGATE   Model: ST9146852SS       Rev: 5203
  Type:   Direct-Access                      ANSI SCSI revision: 05
  Vendor: SEAGATE   Model: ST9146852SS       Rev: 5203
  Type:   Direct-Access                      ANSI SCSI revision: 05
  Vendor: SEAGATE   Model: ST9146852SS       Rev: 5203
  Type:   Direct-Access                      ANSI SCSI revision: 05
  Vendor: LSI       Model: RAID 5/6 SAS 6G   Rev: 2.40
  Type:   Direct-Access                      ANSI SCSI revision: 05

smartmontools-5.39.1-2.el6.x86_64 of RHEL6-server does have the option.
Comment 1 Michal Hlavinka 2010-11-18 07:49:35 EST
this feature request is already filled as bug #519261

*** This bug has been marked as a duplicate of bug 519261 ***
Comment 2 Gerrit Slomma 2010-11-18 09:07:14 EST
"You are not authorized to access bug #519261"

So this is why i could not find it via search?
Comment 3 Michal Hlavinka 2010-11-18 09:17:05 EST
(In reply to comment #2)
> "You are not authorized to access bug #519261"
> 
> So this is why i could not find it via search?

yes, this bug is private, so even search function can't see it

Note You need to log in before you can comment on or make changes to this bug.