Bug 65471 - single quotes in provider name are not escaped correctly
Summary: single quotes in provider name are not escaped correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
: 67273 (view as bug list)
Depends On:
Blocks: rcn-7.3
TreeView+ depends on / blocked
 
Reported: 2002-05-24 23:11 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-06-26 16:10:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2002:257 high SHIPPED_LIVE Updated redhat-config-network package available 2003-05-06 04:00:00 UTC
Red Hat Product Errata RHBA-2002:267 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-02-07 15:19:58 UTC

Description Need Real Name 2002-05-24 23:11:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
For example, a provider name of:
Dad's provider
produces many error messages when rp3 is run, and ultimately a segfault.

The configuration file produced looks something like this:

<cut>
# for the documentation of these parameters.
USERCTL=yes
BOOTPROTO=dialup
NAME='Dad's provider'
DEVICE=ppp0
TYPE=Modem
ONBOOT='no'
</cut>

As you can see, the ' character isn't handled properly.

This is probably true of all types of connection, but I have only tested it for
modem dialup connections

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add a new network connection using the Internet Configuration Wizard
2. Set its provider name to to some text containing a single quote
3. Run rp3, preferably from the command line, as you get to see error messages
that way.
	

Actual Results:  Printed a bunch of debug info, complaining about unexpected
EOF's and not being able to close a single quote

Expected Results:  Should have dialed out

Additional info:

Workaround: delete the connection and recreate it with a single-quote-less name.

Comment 1 Harald Hoyer 2002-06-26 14:23:42 UTC
*** Bug 67273 has been marked as a duplicate of this bug. ***

Comment 2 Harald Hoyer 2002-06-26 16:10:34 UTC
fixed in CVS

Comment 3 Harald Hoyer 2002-10-23 09:56:46 UTC
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

Comment 4 John Flanagan 2003-02-14 21:04:16 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-267.html



Note You need to log in before you can comment on or make changes to this bug.