Bug 67273 - config failed: ProviderName character restrictions
config failed: ProviderName character restrictions
Status: CLOSED DUPLICATE of bug 65471
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 15:17 EDT by John Reiser
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-26 06:48:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2002-06-21 15:17:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.16-KRUD-perfctr2.3.6
i586)

Description of problem:
Programs > System > Internet Configuration Wizard failed
with the following Exception Report:
Traceback (innermost last):
  File "/usr/sbin/internet-druid", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/internet-druid", line 458, in on_okButton_clicked
    if self.save() != 0:
  File "/usr/sbin/internet-druid", line 288, in save
    self.saveDevices()
  File "/usr/sbin/internet-druid", line 297, in saveDevices
    devicelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 108, in save
    dev.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDevice.py", line
350, in save
    conf.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDevice.py", line
66, in write
    Conf.ConfShellVar.write(self)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 277,
in write
    self.file = open(self.filename, 'w', -1)
IOError: [Errno 2] No such file or directory:
'/etc/sysconfig/networking/devices/ifcfg-Aracnet/SpiritOne'

Local variables in innermost frame:
self: <netconfpkg.NCDevice.ConfDevice instance at 865fbf0>


The ProviderName was "Aracnet/SpiritOne".


Version-Release number of selected component (if applicable):
$ rpm -qf /usr/bin/neat
redhat-config-network-1.0.0-1
$ 

How reproducible:
Always

Steps to Reproduce:
1.Run the wizard as non-root, give the root password,
   use a ProviderName that contains a '/'.
2.
3.
	

Actual Results:  ExcpetionReport, with a request to file a bug report against
redhat-config-network component.

Expected Results:  successful configuration

Additional info:
Comment 1 Harald Hoyer 2002-06-26 10:23:46 EDT

*** This bug has been marked as a duplicate of 65471 ***

Note You need to log in before you can comment on or make changes to this bug.