Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 655187 - JON241: Can't async uninventory a platform with bundle deployments
Summary: JON241: Can't async uninventory a platform with bundle deployments
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Provisioning
Version: 3.0.0
Hardware: All
OS: All
high
medium
Target Milestone: ---
: ---
Assignee: Jay Shaughnessy
QA Contact: Sunil Kondkar
URL:
Whiteboard:
Depends On:
Blocks: jon241-bugs 661140
TreeView+ depends on / blocked
 
Reported: 2010-11-19 20:06 UTC by Jay Shaughnessy
Modified: 2018-12-02 17:30 UTC (History)
4 users (show)

Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 661140 (view as bug list)
Environment:
Any
Last Closed: 2013-08-31 13:07:29 UTC


Attachments (Terms of Use)

Description Jay Shaughnessy 2010-11-19 20:06:10 UTC
If a bundle has been deployed to a platform, that platform can't be fully uninventoried.  It fails in the Async (backround) removal due to db integrity constraints.

How reproducible:

Always

Steps to Reproduce:
1. Deploy a bundle
2. Univentory the platform
3. Watch the server log for Async delete errors


Additional info:

I think a weak workaround would be to delete the bundle which would delete everything related to the bundle. But this may not be desirable to the user.

Comment 1 Jay Shaughnessy 2010-11-19 20:18:44 UTC
Fixed in master 9aeb5a00158b7d24dbb706522d8f8bb35e03bb07

Comment 2 Ian Springer 2010-11-22 15:29:29 UTC
Fix cherry picked to release-3.0.0 branch (commit 834e207).

Comment 3 Sudhir D 2010-11-25 09:31:03 UTC
Verified this against jon-server-2.4.1-SNAPSHOT build# ae99b5b.

I do not see error while async deletion. Below is the log snippet.

2010-11-25 14:58:19,182 INFO  [org.rhq.enterprise.server.scheduler.jobs.AsyncResourceDeleteJob] Async resource deletion - 306 successful, 0 failed, took [9097] ms

Marking this bug verified.

Comment 4 Heiko W. Rupp 2013-08-31 13:07:29 UTC
This has been long implemented and verified - closing.


Note You need to log in before you can comment on or make changes to this bug.