Bug 661140 - Can't async uninventory a platform with bundle deployments
Can't async uninventory a platform with bundle deployments
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Provisioning (Show other bugs)
3.0.0
All All
high Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On: 655187
Blocks: jon30-bugs
  Show dependency treegraph
 
Reported: 2010-12-07 16:38 EST by Charles Crouch
Modified: 2015-02-01 18:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 655187
Environment:
Any
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2010-12-07 16:38:31 EST
Just needs re-verifying in master branch

+++ This bug was initially created as a clone of Bug #655187 +++

If a bundle has been deployed to a platform, that platform can't be fully uninventoried.  It fails in the Async (backround) removal due to db integrity constraints.

How reproducible:

Always

Steps to Reproduce:
1. Deploy a bundle
2. Univentory the platform
3. Watch the server log for Async delete errors


Additional info:

I think a weak workaround would be to delete the bundle which would delete everything related to the bundle. But this may not be desirable to the user.

--- Additional comment from jshaughn@redhat.com on 2010-11-19 15:18:44 EST ---

Fixed in master 9aeb5a00158b7d24dbb706522d8f8bb35e03bb07

--- Additional comment from ian.springer@redhat.com on 2010-11-22 10:29:29 EST ---

Fix cherry picked to release-3.0.0 branch (commit 834e207).

--- Additional comment from sdharane@redhat.com on 2010-11-25 04:31:03 EST ---

Verified this against jon-server-2.4.1-SNAPSHOT build# ae99b5b.

I do not see error while async deletion. Below is the log snippet.

2010-11-25 14:58:19,182 INFO  [org.rhq.enterprise.server.scheduler.jobs.AsyncResourceDeleteJob] Async resource deletion - 306 successful, 0 failed, took [9097] ms

Marking this bug verified.
Comment 1 Sunil Kondkar 2011-02-15 08:51:08 EST
Verified on build#1010 (Version: 4.0.0-SNAPSHOT  Build Number: ec5b64e)

Uploaded and deployed a bundle on platform. Uninventoried the platform successfully. No error is observed in server log. Below is the log:

2011-02-15 19:15:40,714 INFO  [org.rhq.enterprise.server.scheduler.jobs.AsyncResourceDeleteJob] Async resource deletion - 556 successful, 0 failed, took [31588] ms

Marking this bug as verified.
Comment 2 Corey Welton 2011-05-23 21:15:22 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 3 Corey Welton 2011-05-23 21:15:26 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:15:30 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:15:37 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.