Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 655270 - Blank screen after kdm login, [ABRT] kdm killed by singal 11
Summary: Blank screen after kdm login, [ABRT] kdm killed by singal 11
Keywords:
Status: CLOSED DUPLICATE of bug 605156
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: 14
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-20 01:47 UTC by Reartes Guillermo
Modified: 2010-11-29 14:59 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-29 14:59:36 UTC
Type: ---


Attachments (Terms of Use)
Messages (153.99 KB, text/plain)
2010-11-20 01:48 UTC, Reartes Guillermo
no flags Details

Description Reartes Guillermo 2010-11-20 01:47:20 UTC
Description of problem:
After "logging in"/"failed to log in" from KDM, I'm left with a black screen and a blinking cursor in the upper left corner. 

Version-Release number of selected component (if applicable):
kdebase-workspace  4.4.5-1.fc13

How reproducible:
Allways

------------------
EXAMPLE:

User: root
Password: root01

------------------


Fedora 14 (i686):
user: root
password: root00
user: root
password: root01
Result: <BANG!>

user: root
password: root00
user: root
password: root00
Result: <BANG!>

user: root
password: root00
user: root
password: <null>, just press enter.
Result: <BANG!>

abrt: 
componet: kde-workspace
reason: Process /usr/bin/kdm was killed by signal 11 (SIGSEGV)
package: kde-workspace-4.5.2-3.fc14


Affected Packages:
kdm			4.5.2-3.fc14
kdebase-workspace	4.5.2-3.fc14
kernel			2.6.35.6-48.fc14
xorg-x11-drv-intel	2.12.0-6.fc14

Performed a yum update (Several packages updated, including KDE)


Fedora 14 (i686):
user: root
password: root00
user: root
password: root01
Result: <BANG!>

user: root
password: root00
user: root
password: root00
Result: <BANG!>

user: root
password: root00
user: root
password: <null>, just press enter.
Result: <BANG!>

user: root
password: root00
user: root
password: root01 
Result: <BANG!> YES! IT IS THE CORRECT PASSWORD !!!!

Affected Packages:
kdm			4.5.3-3.fc14
kdebase-workspace	4.5.3-3.fc14
kernel			2.6.35.6-48.fc14
xorg-x11-drv-intel	2.12.0-6.fc14.1


componet: kde-workspace
reason: Process /usr/bin/kdm was killed by signal 4 (SIGILL)
package: kdm-4.5.3-3.fc14

Actual results:
blank screen.
ALT+F1, login and reboot the system. (or change runlevels 5->3->5)

Expected results:
load kde after login.

I opened bug 648311 (Fedora 13 i686), that is my work netbook. EEE 1005HA

I also have a MSI Wind U100, so i installed F14 to test if it is afected by the same issue. F14 is affected so i opened this bugreport.

Comment 1 Reartes Guillermo 2010-11-20 01:48:04 UTC
Created attachment 461689 [details]
Messages

Comment 2 Reartes Guillermo 2010-11-29 14:17:09 UTC
Tried to use Xorg with a different video driver: VESA

* I added the option "nomodeset" to the grub config file.
* I rebooted, theg booted in runlevel 3 (TEXT MODE).
* I run: # xorg -configure
* I edited the the generated xorg.conf file (replaced Driver "intel" by
Driver "vesa")
* Then i moved the generated xorg.conf into is proper place (/etc/X11)
* init 5

Xorg now uses the VESA driver.

The problem still persist, even with VESA driver, so it does not seem a video driver issue... 

After ther problem ocurrs, it is enough to open a new VT and issue:
# pkill kdm

After that, xorg restarts properly. (but do not type yout password wrong again... :-) )

I can reproduce it 100%, after power on, just press enter, wait, enter again.

Monitoring kdm.log from another workstation:
# tail -f /var/log/kdm.log

kdmgreet: Fatal IO error: client killed
error setting MTRR (base = 0xc0000000, size = 0x007b0000, type = 1) Invalid argument (22)

or if i try again:
# pkill kdm

I see just (/var/log/kdm.log):

error setting MTRR (base = 0xc0000000, size = 0x007b0000, type = 1) Invalid argument (22)


[root@apache ~]# cat /proc/mtrr 
reg00: base=0x000000000 (    0MB), size= 2048MB, count=1: write-back
reg01: base=0x07f700000 ( 2039MB), size=    1MB, count=1: uncachable
reg02: base=0x07f800000 ( 2040MB), size=    8MB, count=1: uncachable
reg03: base=0x0c0000000 ( 3072MB), size=  256MB, count=1: write-combining


Strange, if i remove xorg.conf and nomodeset in grub (to use the intel driver again, kdm.log
does not show anything when the problem occurs :-| )

NOW All test are performed with INTEL driver AGAIN.

Monitoring Xorg.0.log when the problem occurs:
# tail -f /var/log/Xorg.0.log

[   339.742] (II) Power Button: Close
[   339.743] (II) UnloadModule: "evdev"
[   339.747] (II) Video Bus: Close
[   339.747] (II) UnloadModule: "evdev"
[   339.751] (II) Power Button: Close
[   339.751] (II) UnloadModule: "evdev"
[   339.758] (II) Sleep Button: Close
[   339.758] (II) UnloadModule: "evdev"
[   339.783] (II) AT Translated Set 2 keyboard: Close
[   339.783] (II) UnloadModule: "evdev"
[   339.799] (II) FSPPS/2 Sentelic FingerSensingPad: Close
[   339.799] (II) UnloadModule: "evdev"

Monitoring messages when the problem occurs:
# tail -f /var/log/messages

Nov 24 20:28:20 apache kernel: [ 1067.944217] kdm[1676]: segfault at 6a4dd0 ip 006a4dd0 sp bfbb3eac error 4 in pam_unix.so[6b2000+c000]
Nov 24 20:28:21 apache abrt[1691]: saved core dump of pid 1676 (/usr/bin/kdm) to /var/spool/abrt/ccpp-1290641300-1676.new/coredump (860160 bytes)
Nov 24 20:28:21 apache abrtd: Directory 'ccpp-1290641300-1676' creation detected
Nov 24 20:28:21 apache kdm_greet[1679]: Cannot read from core
Nov 24 20:28:21 apache kdm[1667]: Unknown session exit code 0 (sig 11) from manager process
Nov 24 20:28:21 apache abrtd: Crash is in database already (dup of /var/spool/abrt/ccpp-1290211320-1472)
Nov 24 20:28:21 apache abrtd: Deleting crash ccpp-1290641300-1676 (dup of ccpp-1290211320-1472), sending dbus signal

When i issue (/var/log/messages):
# pkill kdm

Nov 24 20:30:42 apache init: prefdm main process ended, respawning
Nov 24 20:30:42 apache kernel: [ 1209.812987] composite sync not supported
Nov 24 20:30:42 apache kernel: [ 1209.919945] composite sync not supported
Nov 24 20:30:42 apache kernel: [ 1210.053212] composite sync not supported
Nov 24 20:30:43 apache kernel: [ 1210.136081] atkbd serio0: Unknown key pressed (translated set 2, code 0xf7 on isa0060/serio0).
Nov 24 20:30:43 apache kernel: [ 1210.136098] atkbd serio0: Use 'setkeycodes e077 <keycode>' to make it known.
Nov 24 20:30:43 apache kernel: [ 1210.140295] atkbd serio0: Unknown key released (translated set 2, code 0xf7 on isa0060/serio0).
Nov 24 20:30:43 apache kernel: [ 1210.140311] atkbd serio0: Use 'setkeycodes e077 <keycode>' to make it known.
Nov 24 20:30:43 apache kernel: [ 1210.145782] atkbd serio0: Unknown key pressed (translated set 2, code 0xf7 on isa0060/serio0).
Nov 24 20:30:43 apache kernel: [ 1210.145804] atkbd serio0: Use 'setkeycodes e077 <keycode>' to make it known.
Nov 24 20:30:43 apache kernel: [ 1210.149483] atkbd serio0: Unknown key released (translated set 2, code 0xf7 on isa0060/serio0).
Nov 24 20:30:43 apache kernel: [ 1210.149506] atkbd serio0: Use 'setkeycodes e077 <keycode>' to make it known.


[root@apache ~]# ldd /usr/bin/kdm
        linux-gate.so.1 =>  (0x00402000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00634000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00110000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00e04000)
        libpam.so.0 => /lib/libpam.so.0 (0x009c6000)
        libdl.so.2 => /lib/libdl.so.2 (0x0097d000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x00c85000)
        libck-connector.so.0 => /usr/lib/libck-connector.so.0 (0x00113000)
        libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x00116000)
        libutil.so.1 => /lib/libutil.so.1 (0x00210000)
        libc.so.6 => /lib/libc.so.6 (0x00214000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00161000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x001a5000)
        libaudit.so.1 => /lib/libaudit.so.1 (0x00b87000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x005d5000)
        /lib/ld-linux.so.2 (0x00183000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x004b1000)
        librt.so.1 => /lib/librt.so.1 (0x007f0000)
        libfreebl3.so => /lib/libfreebl3.so (0x004d3000)

[root@apache ~]# ldd /lib/security/pam_unix.so
        linux-gate.so.1 =>  (0x00951000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x0078f000)
        libpam.so.0 => /lib/libpam.so.0 (0x00964000)
        libaudit.so.1 => /lib/libaudit.so.1 (0x0073c000)
        libdl.so.2 => /lib/libdl.so.2 (0x00f86000)
        libselinux.so.1 => /lib/libselinux.so.1 (0x002f7000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00da9000)
        libc.so.6 => /lib/libc.so.6 (0x00316000)
        /lib/ld-linux.so.2 (0x0022a000)
        libfreebl3.so => /lib/libfreebl3.so (0x002a3000)

# pkill kdm

Monitoring from another workstation:
# tail -f /var/log/secure/

This is the first try (hit enter):
Nov 24 21:09:30 apache kdm: :0[1839]: PAM unable to dlopen(/lib/security/pam_gnome_keyring.so): /lib/security/pam_gnome_keyring.so: cannot open shared object file: No such file or directory
Nov 24 21:09:30 apache kdm: :0[1839]: PAM adding faulty module: /lib/security/pam_gnome_keyring.so
Nov 24 21:09:30 apache kdm: :0[1839]: pam_unix(kdm:auth): authentication failure; logname= uid=0 euid=0 tty=:0 ruser= rhost=  user=root

This is the second try (hit enter):
Nov 24 21:09:39 apache kdm: :0[1839]: PAM unable to dlopen(/lib/security/pam_gnome_keyring.so): /lib/security/pam_gnome_keyring.so: cannot open shared object file: No such file or directory
Nov 24 21:09:39 apache kdm: :0[1839]: PAM adding faulty module: /lib/security/pam_gnome_keyring.so

The line  pam_unix(kdm:auth): bla bla bla is missing the second time.... (and of course a pkill kdm is needed...)

Does the file exists?
[root@apache log]# ldd /lib/security/pam_gnome_keyring.so
ldd: /lib/security/pam_gnome_keyring.so: No such file or directory

I do use KDE, no GNOME.

I comented the following in PAM:
[root@apache ~]# cat /etc/pam.d/kdm
#auth       optional    pam_gnome_keyring.so
#session    optional    pam_gnome_keyring.so auto_start


[root@apache ~]# ldconfig
[root@apache ~]# init 6

Now i cannot reproduce it 100%, BUT IT STILL DOES HAPPEN.... just try & try & try...
A bit of improvement at least (i dunno for what reason those entries where
there nor what is/was gnome_keyring)

WOW! I forgot about SELinux. It is enforcing on this laptop.... 

Monitoring from another workstation:
# tail -f /var/log/audit/audit.log

type=USER_AUTH msg=audit(1290645429.355:83): user pid=1699 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 msg='op=PAM:authentication acct="root" exe="/usr/bin/kdm" hostname=? addr=? terminal=:0 res=failed'
type=ANOM_ABEND msg=audit(1290645434.270:84): auid=4294967295 uid=0 gid=0 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 pid=1699 comm="kdm" sig=11

Setting it to permissive does NOT prevent it from happening.
Commented the following:

/etc/pam.d/login
#-session   optional     pam_ck_connector.so

/etc/pam.d/passwd
#-password   optional   pam_gnome_keyring.so use_authtok

# ldconfig

The issue still exists, after "unknown pkill & try cycles", sometimes it happens.

These tests were done a couple of days ago. I will update the system and re-test.

Comment 3 Jaroslav Reznik 2010-11-29 14:59:36 UTC

*** This bug has been marked as a duplicate of bug 605156 ***


Note You need to log in before you can comment on or make changes to this bug.