Bug 605156 - (kdm-pam-fprintd) [abrt] crash in kdm-4.4.4-1.fc13: pam-fprintd related
[abrt] crash in kdm-4.4.4-1.fc13: pam-fprintd related
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fprintd (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
abrt_hash:e18ff73f7a83e143332faa534b6...
:
: 506171 544701 548347 585799 612176 635059 655270 (view as bug list)
Depends On:
Blocks: F14Target-kde
  Show dependency treegraph
 
Reported: 2010-06-17 06:34 EDT by Michal Žejdl
Modified: 2010-11-29 09:59 EST (History)
18 users (show)

See Also:
Fixed In Version: fprintd-0.2.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-23 16:50:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (9.58 KB, text/plain)
2010-06-17 06:34 EDT, Michal Žejdl
no flags Details
new backtrace (10.65 KB, text/plain)
2010-06-22 01:33 EDT, Michal Žejdl
no flags Details
backtrace (9.65 KB, text/plain)
2010-08-20 05:33 EDT, Michal Žejdl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 220404 None None None Never
KDE Software Compilation 240796 None None None Never

  None (edit)
Description Michal Žejdl 2010-06-17 06:34:34 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: -:0 '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' ''
comment: login via kdm with wrong password makes kdm crash when password is entered again
component: kdebase-workspace
executable: /usr/bin/kdm
global_uuid: e18ff73f7a83e143332faa534b61db0b744bac8a
kernel: 2.6.33.5-124.fc13.i686
package: kdm-4.4.4-1.fc13
rating: 3
reason: Process /usr/bin/kdm was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. enter wrong password into kdm login window (empty is enough)
2. enter anything into pasword field again
Comment 1 Michal Žejdl 2010-06-17 06:34:36 EDT
Created attachment 424754 [details]
File: backtrace
Comment 2 Michal Žejdl 2010-06-17 08:26:03 EDT
after commenting out this line

auth        sufficient    pam_fprintd.so

from /etc/pam.d/system-auth

everything is ok
Comment 3 Steven M. Parrish 2010-06-21 20:17:18 EDT
KDE Version 4.4.4 is now available.  Please update to the this latest release and retest the application.  Please advise if you are still having the same issue as documented.  Any reports not updated within 30 days will be closed.

Thanks from the Fedora KDE Team
Comment 4 Michal Žejdl 2010-06-22 01:33:40 EDT
Created attachment 425831 [details]
new backtrace

the bug is still here, backtrace is slightly different now

it looks like the issue is out of the kdm, but I am not an expert

commenting out pam_fprintd.so from /etc/pam.d/system-auth still works
Comment 5 Rex Dieter 2010-07-07 10:18:52 EDT
*** Bug 612176 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2010-07-07 10:21:22 EDT
*** Bug 544701 has been marked as a duplicate of this bug. ***
Comment 7 Rex Dieter 2010-07-07 10:22:34 EDT
*** Bug 548347 has been marked as a duplicate of this bug. ***
Comment 8 Rex Dieter 2010-07-07 10:26:33 EDT
Quote from the upstream bugreport:
https://bugs.kde.org/show_bug.cgi?id=220404
==========================
well, i'll just generously bounce back the ball. :P
this looks like a pam_fprintd issue - judging by the backtrace it may be
assuming the presence of a glib main loop, which is of course absent in kdm.
this wouldn't be too surprising if it was tested only with gdm.
==========================

Re-assigning for feedback/comment from fprintd maintainer(s).
Comment 9 Sergio Monteiro Basto 2010-07-07 11:03:23 EDT
My tests after 

yum remove fprintd ,

couldn't reproduce the bug again, but just a few tests.
Comment 10 Bastien Nocera 2010-08-17 10:24:53 EDT
(In reply to comment #8)
> Quote from the upstream bugreport:
> https://bugs.kde.org/show_bug.cgi?id=220404
> ==========================
> well, i'll just generously bounce back the ball. :P
> this looks like a pam_fprintd issue - judging by the backtrace it may be
> assuming the presence of a glib main loop, which is of course absent in kdm.

Whao. Somebody isn't looking at code... It uses its own main loop, which happens to be a GLib one.

> this wouldn't be too surprising if it was tested only with gdm.

It was also tested with a number of non-glib apps, such as "login"...

> ==========================
> 
> Re-assigning for feedback/comment from fprintd maintainer(s).

I'll look at this.
Comment 11 Bastien Nocera 2010-08-19 13:04:46 EDT
Could you please test with the newer libfprint and fprintd 0.2 releases?

If you want the F13 packages, I'm afraid you'll have to wait a little, as the buildroot is broken, but the packages are available from http://koji.fedoraproject.org

Updates have been filed for F-12 and F-14
Comment 12 Michal Žejdl 2010-08-20 05:33:38 EDT
Created attachment 439896 [details]
backtrace

unfortunately still the same behaviour with

fprintd-debuginfo-0.2.0-1.fc13.i686
fprintd-pam-0.2.0-1.fc13.i686
fprintd-0.2.0-1.fc13.i686
libfprint-debuginfo-0.2.0-1.fc13.i686
libfprint-0.2.0-1.fc13.i686
Comment 13 Rex Dieter 2010-09-17 14:20:22 EDT
OK, let's get this triaged properly -> pam_printd
Comment 14 Rex Dieter 2010-09-17 14:20:39 EDT
*** Bug 635059 has been marked as a duplicate of this bug. ***
Comment 15 Kevin Kofler 2010-09-17 16:34:21 EDT
pam_fprint is obsolete, the new pam-fprintd module is in the fprintd-pam subpackage of fprintd.
Comment 16 Rex Dieter 2010-09-29 09:36:23 EDT
*** Bug 506171 has been marked as a duplicate of this bug. ***
Comment 17 Rex Dieter 2010-10-15 14:54:24 EDT
users reporting seeing this on f14 too. :(

I guess we could consider omitting it from the kde spin considering it's known to cause problems.
Comment 18 Rex Dieter 2010-10-24 23:02:50 EDT
ommited per
http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=commitdiff;h=c5d32129f7789be52b7ff330cd5e8c75e3f5ffe8;hp=0fa07e73697cb5887dade22147b6ed8c0fb74ff1

until this is resolved.

(And kde upstream noticing the backtraces involve crashes inside of pam, closed->downsream now too).
Comment 19 Kevin Kofler 2010-11-03 11:22:55 EDT
*** Bug 585799 has been marked as a duplicate of this bug. ***
Comment 20 Fedora Update System 2010-11-09 14:18:47 EST
fprintd-0.2.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fprintd-0.2.0-2.fc14
Comment 21 Ray Strode [halfline] 2010-11-09 15:47:46 EST
Hey guys, someone came up to me during a conference and showed me a bug where the gnome-screensaver unlock dialog crashed. (there's no filed report about that as far as i can tell from searching). The bug ended up being an issue in pam_fprintd.  On the surface, it looks like it may be same problem affecting this bug report.

I'd appreciate if anyone affected could try the update and report back whether it solves this problem as well.
Comment 22 Fedora Update System 2010-11-09 20:13:59 EST
fprintd-0.2.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fprintd'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/fprintd-0.2.0-2.fc14
Comment 23 Michal Žejdl 2010-11-10 04:38:04 EST
With fprintd-0.2.0-1.fc14 kdm still crashes. But I can not reproduce reported crash in kdm with fprintd-0.2.0-2.fc14. It looks like the bug is gone. Thank you.
Comment 24 Bastien Nocera 2010-11-10 09:45:22 EST
(In reply to comment #23)
> With fprintd-0.2.0-1.fc14 kdm still crashes. But I can not reproduce reported
> crash in kdm with fprintd-0.2.0-2.fc14. It looks like the bug is gone. Thank
> you.

Awesome. Thanks to Ray for fixing this up.

Rex, any chance you can revert your patch and add the new fprintd to the spin (at least for F15).
Comment 25 Rex Dieter 2010-11-10 11:04:59 EST
Yes, thanks!
Comment 26 Fedora Update System 2010-11-23 16:50:07 EST
fprintd-0.2.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Jaroslav Reznik 2010-11-29 09:59:36 EST
*** Bug 655270 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.