Bug 65536 - Problems with es1371 card on Dell P4 Desktop machine.
Problems with es1371 card on Dell P4 Desktop machine.
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-05-27 02:12 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-06-01 20:51:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
This is the output of lspci on the P4 Dell Desktop. (the one for which recording does not work) (4.86 KB, text/plain)
2002-05-27 02:35 EDT, Need Real Name
no flags Details
The output of lscpi on the P3 Desktop with the same card. (the one for which recording works just fine) (4.81 KB, text/plain)
2002-05-27 02:38 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-05-27 02:12:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
In one sentence, the recording functionality does not work with a Sound Blaster
16 PCI card on the Dell P4 Desktop machine, even though the same exact card and
the same exact kernel modules work perfectly on my own Dell P3 Desktop machine.
ALSA0.9rc1 shows exactly the same behaviour. OSS/Commercial driver trial seems
to work fine on the P4 Desktop with the es1371, and it works in XP as well. 

It seems bizaare that the same card should work fine on one machine but not work
completely on another machine. I suspect that this is a symptom of a more subtle

Background:  In my ongoing saga (see bug 60646) to get working full duplex audio
for my cousin's desktop, I went out and bought a Sound Blaster 16 PCI. I
disabled the builtin audio (i8x0+ac97) in the BIOS,  and let kudzu set up the
configuration. Playback worked perfectly in everything I tried, and the
microphone mixer control was also working in "gmix." If I unmuted the mic, the
speakers would amplify whatever I would say into them as expected. But recording
does not work. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install a Soundblaster 16 PCI card
2. Set up sound. 
3. Make sure that the mixer has the microphone set up as the capture device
4. Run "record"
5. Try to "play" the resulting .wav files.

Actual Results:  The record program does not show any indication that it is
picking up any signal over the microphone. Increasing the mixer does not alter
this. The wav files that are recorded are completely empty. 

Expected Results:  The record program should have showed a moving bar whenever I
tap the microphone or speak into it. The wav files should have contained a
recording of what I spoke.  This is what happens when I use this exact same
physical card on my own Dell P3 desktop. 

Additional info:

I tried a number of variations in an attempt to isolate what was triggering the
bug. I removed all PCI cards. I tried both enabling and disabling the onboard
audio device. Same behaviour either way. Playback works, mixer works, recording
does not. I tried telling the BIOS "PNP Aware BIOS" both yes and no. Same
behavior either way. I tried ASLA 0.90rc1 and it showed exactly the same
behavior as the kernel OSS drivers. The demo version of OSS/Commercial worked fine.
Comment 1 Need Real Name 2002-05-27 02:35:57 EDT
Created attachment 58624 [details]
This is the output of lspci on the P4 Dell Desktop. (the one for which recording does not work)
Comment 2 Need Real Name 2002-05-27 02:38:41 EDT
Created attachment 58625 [details]
The output of lscpi on the P3 Desktop with the same card. (the one for which recording works just fine)
Comment 3 Arjan van de Ven 2002-05-28 09:47:59 EDT
Interrupt: pin A routed to IRQ 3
Interesting. While IRQ sharing SHOULD work....... 
Does /proc/interrupts show any activity on irq 3 while trying to record ?
Comment 4 Need Real Name 2002-06-01 20:51:30 EDT
I went back to my cousin's place to look at /proc/interrupts. Upon installing
the card again, I found that recording is indeed working correctly now. I did
have to turn up the "Igain" mixer which seemed to default back down to 0. (is
there a way to make it default to something nonzero?)  But I'm pretty sure that
I had done that the last time as well. 

As I can not reproduce this bug myself, I suggest this bug be closed.

Note You need to log in before you can comment on or make changes to this bug.