This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 655571 - sunrpc, hugetlbfs & mqueue mounted multiple times on boot
sunrpc, hugetlbfs & mqueue mounted multiple times on boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
: 668718 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-21 14:21 EST by Tom London
Modified: 2011-02-23 05:19 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-23 05:19:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom London 2010-11-21 14:21:00 EST
Description of problem:
I'm seeing this:

[root@tlondon ~]# mount
/dev/mapper/vg_tlondon-lv_root on / type ext4 (rw,commit=0)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/tmp on /tmp type none (rw,bind,commit=0)
/home on /home type none (rw,bind,commit=0)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
hugetlbfs on /dev/hugepages type hugetlbfs (rw)
mqueue on /dev/mqueue type mqueue (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
hugetlbfs on /dev/hugepages type hugetlbfs (rw)
mqueue on /dev/mqueue type mqueue (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
hugetlbfs on /dev/hugepages type hugetlbfs (rw)
mqueue on /dev/mqueue type mqueue (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
hugetlbfs on /dev/hugepages type hugetlbfs (rw)
mqueue on /dev/mqueue type mqueue (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
hugetlbfs on /dev/hugepages type hugetlbfs (rw)
mqueue on /dev/mqueue type mqueue (rw)
/dev/sda1 on /boot type ext4 (rw,commit=0)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
gvfs-fuse-daemon on /home/tbl/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=tbl)
/dev/mapper/udisks-luks-uuid-94a9d7d7-f819-4c2c-b735-81bb28db0426-uid500 on /media/Backup1TB type ext4 (rw,nosuid,nodev,uhelper=udisks)
[root@tlondon ~]# 

and

[root@tlondon ~]# dmesg | grep 'sunrpc\|hugetlbfs\|mqueue'
[    9.687394] SELinux: initialized (dev hugetlbfs, type hugetlbfs), uses transition SIDs
[    9.687400] SELinux: initialized (dev mqueue, type mqueue), uses transition SIDs
[   17.770206] SELinux: initialized (dev hugetlbfs, type hugetlbfs), uses transition SIDs
[   37.676771] SELinux: initialized (dev mqueue, type mqueue), uses transition SIDs
[   37.705055] SELinux: initialized (dev mqueue, type mqueue), uses transition SIDs
[root@tlondon ~]# 

Not sure its hurting anything, but .....

Version-Release number of selected component (if applicable):
systemd-13-1.fc15.x86_64

How reproducible:
Every boot

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lennart Poettering 2010-11-21 16:24:26 EST
Nah, systemd doesn't mount things twice. Most likely this happens simply because /etc/mtab is not being linked to /proc/mounts. We don't really support that anymore. You basically see an incorrect mtab intermixing the info from the current boot with some remains of the previous boot.

Could you verify that this problem goes away if you link /etc/mtab to /proc/mounts? If so then I'll reassign this to u-l-ng so that Karel makes sure that /etc/mtab is replaced by a symlink to /proc/mounts on package upgrades.
Comment 2 Tom London 2010-11-21 18:53:39 EST
OK.

I did:


[root@tlondon etc]# ln -s /proc/mounts /etc/mtab
[root@tlondon etc]# ls -l /etc/mtab
lrwxrwxrwx. 1 root root 12 Nov 21 15:51 /etc/mtab -> /proc/mounts
[root@tlondon etc]# mount
rootfs on / type rootfs (rw)
/proc on /proc type proc (rw,relatime)
/sys on /sys type sysfs (rw,seclabel,relatime)
udev on /dev type devtmpfs (rw,seclabel,nosuid,relatime,size=1964796k,nr_inodes=491199,mode=755)
devpts on /dev/pts type devpts (rw,seclabel,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /dev/shm type tmpfs (rw,seclabel,relatime)
/dev/mapper/vg_tlondon-lv_root on / type ext4 (rw,seclabel,relatime,barrier=1,data=ordered)
none on /selinux type selinuxfs (rw,relatime)
udev on /dev type devtmpfs (rw,seclabel,nosuid,relatime,size=1964796k,nr_inodes=491199,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (rw,seclabel,nosuid,nodev,noexec,relatime,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/ns type cgroup (rw,nosuid,nodev,noexec,relatime,ns)
cgroup on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
cgroup on /sys/fs/cgroup/cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
systemd-1 on /dev/mqueue type autofs (rw,relatime,fd=26,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /sys/kernel/debug type autofs (rw,relatime,fd=27,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /dev/hugepages type autofs (rw,relatime,fd=28,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /sys/kernel/security type autofs (rw,relatime,fd=29,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=31,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,seclabel,relatime)
mqueue on /dev/mqueue type mqueue (rw,seclabel,relatime)
/dev/sda1 on /boot type ext4 (rw,seclabel,relatime,barrier=1,data=ordered)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfs-fuse-daemon on /home/tbl/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=500,group_id=500)
/dev/mapper/udisks-luks-uuid-94a9d7d7-f819-4c2c-b735-81bb28db0426-uid500 on /media/Backup1TB type ext4 (rw,seclabel,nosuid,nodev,relatime,barrier=1,data=ordered)
[root@tlondon etc]# 

Is that what you expected?

I'll reboot and see if this is 'stable'.
Comment 3 Tom London 2010-11-21 19:02:35 EST
Yeah, appears stable after reboot:

[root@tlondon ~]# ls -l /etc/mtab
lrwxrwxrwx. 1 root root 12 Nov 21 15:51 /etc/mtab -> /proc/mounts
[root@tlondon ~]# 
[root@tlondon ~]# mount
rootfs on / type rootfs (rw)
/proc on /proc type proc (rw,relatime)
/sys on /sys type sysfs (rw,seclabel,relatime)
udev on /dev type devtmpfs (rw,seclabel,nosuid,relatime,size=1964796k,nr_inodes=491199,mode=755)
devpts on /dev/pts type devpts (rw,seclabel,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /dev/shm type tmpfs (rw,seclabel,relatime)
/dev/mapper/vg_tlondon-lv_root on / type ext4 (rw,seclabel,relatime,barrier=1,data=ordered)
none on /selinux type selinuxfs (rw,relatime)
udev on /dev type devtmpfs (rw,seclabel,nosuid,relatime,size=1964796k,nr_inodes=491199,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (rw,seclabel,nosuid,nodev,noexec,relatime,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/ns type cgroup (rw,nosuid,nodev,noexec,relatime,ns)
cgroup on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
cgroup on /sys/fs/cgroup/cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
systemd-1 on /dev/mqueue type autofs (rw,relatime,fd=26,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /sys/kernel/debug type autofs (rw,relatime,fd=27,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /dev/hugepages type autofs (rw,relatime,fd=28,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /sys/kernel/security type autofs (rw,relatime,fd=29,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=31,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,seclabel,relatime)
mqueue on /dev/mqueue type mqueue (rw,seclabel,relatime)
/dev/sda1 on /boot type ext4 (rw,seclabel,relatime,barrier=1,data=ordered)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfs-fuse-daemon on /home/tbl/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=500,group_id=500)
[root@tlondon ~]#
Comment 4 Lennart Poettering 2010-11-21 19:33:12 EST
Yupp. looks good.

Ok, will reassign this to u-l-ng now.

Karel, please please please, make u-l-ng install a symlink in place of /etc/mtab by default! (and of course, make sure that the meta information stored in mtab beyond /proc/mounts isn't lost...)
Comment 5 Karel Zak 2010-11-22 03:42:49 EST
(In reply to comment #4)
> Yupp. looks good.

Lennart, I don't understand why /etc/mtab contains the duplicate lines. 

(The symlink to /proc/mounts is bugfix/workaround, but it does not explain the problem.;-)

> Karel, please please please, make u-l-ng install a symlink in place of
> /etc/mtab by default! (and of course, make sure that the meta information
> stored in mtab beyond /proc/mounts isn't lost...)

Is it required for F-15?
Comment 6 Lennart Poettering 2010-11-24 20:34:07 EST
In systemd we are not clearing /etc/mtab on boot. We are also not playing catchup with the status quo after /etc became writable. That means that /etc/mtab will collect old out-dated information from previous boots, and not contain information about the stuff we mount before /etc is rw.

Instead we actually added some code to systemd which warns in kmsg if /etc/mtab is still a real file. Basically, we are gently putting some pressure on you to get rid of mtab... ;-)

Yes, please fix this for F-15. I don't want to have to add this horrible code to systemd which resets and syncs mtab on boot.

Please please please with cream on top!
Comment 7 Till Maas 2010-12-03 19:04:10 EST
Just symlinking mtab to /proc/mounts will break (u)mount.crypt from pam_mount, because there is afaik no way to specify the entry for the filesystem column if a filesystem in /proc/mounts. E.g. if an ext4 filesystem on a luks encrypted volume is mounted with mount.crypt, /proc/mounts will say that it is ext3 instead of crypt, which is what is written to /etc/mtab. Therefore with the symlink umount won't call umount.crypt and therefore not close the luks volume.
Comment 8 Karel Zak 2011-01-11 10:11:54 EST
*** Bug 668718 has been marked as a duplicate of this bug. ***
Comment 9 Karel Zak 2011-02-23 05:19:58 EST
The problem with duplicate entries in mtab should be already resolved (by the symlink). The problem with mount.crypt and mount.nfs will be resolved by upstream(s). So, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.