Bug 668718 - Strange output from df
Strange output from df
Status: CLOSED DUPLICATE of bug 655571
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-11 06:37 EST by Kjartan Maraas
Modified: 2011-01-11 10:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-11 10:11:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2011-01-11 06:37:37 EST
Description of problem:

[kmaraas@e4300 gnome]$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda3             50395844  15964396  31871448  34% /
/dev/sda2               198337     66642    121455  36% /boot
/dev/sda6             42599952  39046060   1389928  97% /home
gvfs-fuse-daemon      42599952  39046060   1389928  97% /home/kmaraas/.gvfs
/dev/sda6             42599952  39046060   1389928  97% /home
/dev/sda6             42599952  39046060   1389928  97% /home
/dev/sda2               198337     66642    121455  36% /boot
/dev/sda6             42599952  39046060   1389928  97% /home
/dev/fuse             42599952  39046060   1389928  97% /home/kmaraas/.gvfs
/dev/sda6             42599952  39046060   1389928  97% /home
/dev/sda6             42599952  39046060   1389928  97% /home
/dev/sda2               198337     66642    121455  36% /boot
/dev/sda2               198337     66642    121455  36% /boot
/dev/sda6             42599952  39046060   1389928  97% /home
/dev/sda6             42599952  39046060   1389928  97% /home
/dev/sda2               198337     66642    121455  36% /boot
/dev/sda2               198337     66642    121455  36% /boot
/dev/sda6             42599952  39046060   1389928  97% /home
/dev/sda6             42599952  39046060   1389928  97% /home
/dev/sda6             42599952  39046060   1389928  97% /home
/dev/sda2               198337     66642    121455  36% /boot

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ondrej Vasik 2011-01-11 07:01:44 EST
Thanks for report, this is possibly disrupted by systemd changes. Coreutils (gnulib mountlist.c) uses getnmntent() glibc function for getting mountpoint stats. That mountpoint gathering is now probably somehow broken as I see multiple duplicate records in the table. Reassigning to glibc, but you will be probably required to provide more information to further analyze the issue.
Comment 2 Ondrej Vasik 2011-01-11 07:02:24 EST
( getmntent() , of course, sorry for typo)
Comment 3 Kjartan Maraas 2011-01-11 07:17:49 EST
This is the latest rawhide updated yesterday. I'll provide more info when I'm told which info is relevant :-)
Comment 4 Andreas Schwab 2011-01-11 08:02:25 EST
getmntent just reads the file passed to setmntent.
Comment 5 Ondrej Vasik 2011-01-11 08:22:03 EST
And file (/etc/mtab) defined by _PATH_MOUNTED (from glibc) was passed to setmntent() from glibc. Nothing was changed in coreutils in this area for quite a long time ... so I don't think the issue is in coreutils (and df).

There is something rotten in different place and I suspect some systemd changes. Adding Karel Zak to CC, as he may have more info about the changes with mounting.
Comment 6 Kamil Dudka 2011-01-11 08:32:40 EST
Kjartan, please attach the content of your /etc/mtab and /proc/mounts.
Comment 7 Karel Zak 2011-01-11 10:11:54 EST

*** This bug has been marked as a duplicate of bug 655571 ***

Note You need to log in before you can comment on or make changes to this bug.