Bug 656438 - There is no references for some variables in documentation sysconfig.txt
There is no references for some variables in documentation sysconfig.txt
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
5.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Ivana Varekova
: ManPageChange, Patch
Depends On:
Blocks: 699662
  Show dependency treegraph
 
Reported: 2010-11-23 13:20 EST by Fabrício José Vieira Ceolin
Modified: 2011-07-21 03:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The ypserv(8), rpc.yppasswdd(8) and rpc.ypxfrd(8) manual pages now contain information about the possibility of setting internal options.
Story Points: ---
Clone Of:
: 699662 (view as bug list)
Environment:
Last Closed: 2011-07-21 03:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch of man pages (2.39 KB, patch)
2011-04-21 10:45 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description Fabrício José Vieira Ceolin 2010-11-23 13:20:30 EST
Description of problem:

There is no references for YPSERV_ARGS and YPXFRD in /usr/share/doc/initscripts-8.45.30/sysconfig.txt used in /etc/sysconfig/network

Version-Release number of selected component (if applicable):

rpm -qi initscripts
Name        : initscripts                  Relocations: (not relocatable)
Version     : 8.45.30                           Vendor: Red Hat, Inc.
Release     : 2.el5                         Build Date: Mon 13 Jul 2009 10:22:47 AM BRT
Install Date: Mon 22 Nov 2010 09:10:22 AM BRST      Build Host: ls20-bc2-14.build.redhat.com
Group       : System Environment/Base       Source RPM: initscripts-8.45.30-2.el5.src.rpm
Size        : 5471135                          License: GPLv2 and GPLv2+
Signature   : DSA/SHA1, Thu 30 Jul 2009 09:41:08 AM BRT, Key ID 5326810137017186
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://git.fedorahosted.org/git/initscripts.git
Summary     : The inittab file and the /etc/init.d scripts.
Description :
The initscripts package contains the basic system scripts used to boot
your Red Hat system, change runlevels, and shut the system down
cleanly.  Initscripts also contains the scripts that activate and
deactivate most network interfaces.


How reproducible:

Using commands.


Steps to Reproduce:

cat /usr/share/doc/initscripts-8.45.30/sysconfig.txt | grep YPSERV_ARGS
cat /usr/share/doc/initscripts-8.45.30/sysconfig.txt | grep YPXFRD

  
Actual results:

Nothins happends

Expected results:

We expected that returs this possible variables.

Additional info:

An working command returns:
cat /usr/share/doc/initscripts-8.45.30/sysconfig.txt | grep NISDOMAIN
NISDOMAIN=<nis domain name>
Comment 1 Bill Nottingham 2010-11-23 20:53:50 EST
Those are not used by the initscripts package; NISDOMAIN is. While some service-specific parameters may be documented in sysconfig.txt due to legacy reasons, it is impossible for sysconfig.txt to realistically list all possible configuration values for all possible services that ship init scripts; service-specific configuration parameters need documented in the service itself.
Comment 2 Fabrício José Vieira Ceolin 2010-11-24 08:14:32 EST
There is no documentation for YPSERV_ARGS and YPXFRD in package ypserv too.

How reproducible:

Using commands.


Steps to Reproduce:
cd /usr/share/doc/ypserv-2.19
grep -r YPSERV_ARGS .
grep -r YPXFRD .

Actual results:

Nothins happends

Expected results:

We expected that returs this possible variables.

Additional info:
Comment 3 Fabrício José Vieira Ceolin 2010-11-24 08:24:06 EST
Complemeting:

How reproducible:

Using commands.

Steps to Reproduce:
man -K YPSERV_ARGS
man -K YPXFRD

Actual results:

Nothins happends

Expected results:

We expected that returs this possible variables.
Comment 4 Ondrej Vasik 2011-01-11 10:16:58 EST
YPSERV_ARGS is just envvar where you could provide arguments for ypserv (see man 8 ypserv).

YPXFRD is just envvar where you could provide arguments for rpc.ypxfrd (see man 8 rpc.ypxfrd).

Anyway, it would be better to document this either in the initscripts or in ypserv manpages. 

However, bugzilla is not a support tool, it is bug tracking tool. If you want to increase the priority of the ypserv update (and more info in these initscripts/manpages), please contact Red Hat product support - http://www.redhat.com/support/ .
Comment 5 Ivana Varekova 2011-04-21 09:28:09 EDT
Hello, please Jan what do you plan with this issue (man-pages fix/ documentation fix/ other option)?
Comment 6 Honza Horak 2011-04-21 10:45:53 EDT
Created attachment 493878 [details]
patch of man pages

According to Bill's comment #1 I'd rather add these options to man pages. The attached patch extends man pages of ypserv, ypxfrd and yppasswdd.
Comment 9 Miroslav Svoboda 2011-07-15 12:23:35 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The ypserv(8), rpc.yppasswdd(8) and rpc.ypxfrd(8) manual pages now contains information about possibilities of setting internal options.
Comment 10 Miroslav Svoboda 2011-07-15 12:24:23 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-The ypserv(8), rpc.yppasswdd(8) and rpc.ypxfrd(8) manual pages now contains information about possibilities of setting internal options.+The ypserv(8), rpc.yppasswdd(8) and rpc.ypxfrd(8) manual pages now contains information about the possibility of setting internal options.
Comment 11 Miroslav Svoboda 2011-07-18 12:17:27 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-The ypserv(8), rpc.yppasswdd(8) and rpc.ypxfrd(8) manual pages now contains information about the possibility of setting internal options.+The ypserv(8), rpc.yppasswdd(8) and rpc.ypxfrd(8) manual pages now contain information about the possibility of setting internal options.
Comment 12 errata-xmlrpc 2011-07-21 03:37:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-1009.html

Note You need to log in before you can comment on or make changes to this bug.