Bug 699662 - There is no references for some variables in documentation sysconfig.txt
There is no references for some variables in documentation sysconfig.txt
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ypserv (Show other bugs)
5.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Honza Horak
qe-baseos-daemons
: ManPageChange, Patch
Depends On: 656438
Blocks: 749319
  Show dependency treegraph
 
Reported: 2011-04-26 05:59 EDT by Ivana Varekova
Modified: 2012-02-21 00:53 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 656438
Environment:
Last Closed: 2012-02-21 00:53:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivana Varekova 2011-04-26 05:59:44 EDT
+++ This bug was initially created as a clone of Bug #656438 +++

Description of problem:

There is no references for YPSERV_ARGS and YPXFRD in /usr/share/doc/initscripts-8.45.30/sysconfig.txt used in /etc/sysconfig/network

Version-Release number of selected component (if applicable):

rpm -qi initscripts
Name        : initscripts                  Relocations: (not relocatable)
Version     : 8.45.30                           Vendor: Red Hat, Inc.
Release     : 2.el5                         Build Date: Mon 13 Jul 2009 10:22:47 AM BRT
Install Date: Mon 22 Nov 2010 09:10:22 AM BRST      Build Host: ls20-bc2-14.build.redhat.com
Group       : System Environment/Base       Source RPM: initscripts-8.45.30-2.el5.src.rpm
Size        : 5471135                          License: GPLv2 and GPLv2+
Signature   : DSA/SHA1, Thu 30 Jul 2009 09:41:08 AM BRT, Key ID 5326810137017186
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://git.fedorahosted.org/git/initscripts.git
Summary     : The inittab file and the /etc/init.d scripts.
Description :
The initscripts package contains the basic system scripts used to boot
your Red Hat system, change runlevels, and shut the system down
cleanly.  Initscripts also contains the scripts that activate and
deactivate most network interfaces.


How reproducible:

Using commands.


Steps to Reproduce:

cat /usr/share/doc/initscripts-8.45.30/sysconfig.txt | grep YPSERV_ARGS
cat /usr/share/doc/initscripts-8.45.30/sysconfig.txt | grep YPXFRD

  
Actual results:

Nothins happends

Expected results:

We expected that returs this possible variables.

Additional info:

An working command returns:
cat /usr/share/doc/initscripts-8.45.30/sysconfig.txt | grep NISDOMAIN
NISDOMAIN=<nis domain name>

--- Additional comment from notting@redhat.com on 2010-11-23 20:53:50 EST ---

Those are not used by the initscripts package; NISDOMAIN is. While some service-specific parameters may be documented in sysconfig.txt due to legacy reasons, it is impossible for sysconfig.txt to realistically list all possible configuration values for all possible services that ship init scripts; service-specific configuration parameters need documented in the service itself.

--- Additional comment from ceolin@ulevel.com on 2010-11-24 08:14:32 EST ---

There is no documentation for YPSERV_ARGS and YPXFRD in package ypserv too.

How reproducible:

Using commands.


Steps to Reproduce:
cd /usr/share/doc/ypserv-2.19
grep -r YPSERV_ARGS .
grep -r YPXFRD .

Actual results:

Nothins happends

Expected results:

We expected that returs this possible variables.

Additional info:

--- Additional comment from ceolin@ulevel.com on 2010-11-24 08:24:06 EST ---

Complemeting:

How reproducible:

Using commands.

Steps to Reproduce:
man -K YPSERV_ARGS
man -K YPXFRD

Actual results:

Nothins happends

Expected results:

We expected that returs this possible variables.

--- Additional comment from ovasik@redhat.com on 2011-01-11 10:16:58 EST ---

YPSERV_ARGS is just envvar where you could provide arguments for ypserv (see man 8 ypserv).

YPXFRD is just envvar where you could provide arguments for rpc.ypxfrd (see man 8 rpc.ypxfrd).

Anyway, it would be better to document this either in the initscripts or in ypserv manpages. 

However, bugzilla is not a support tool, it is bug tracking tool. If you want to increase the priority of the ypserv update (and more info in these initscripts/manpages), please contact Red Hat product support - http://www.redhat.com/support/ .

--- Additional comment from varekova@redhat.com on 2011-04-21 09:28:09 EDT ---

Hello, please Jan what do you plan with this issue (man-pages fix/ documentation fix/ other option)?

--- Additional comment from hhorak@redhat.com on 2011-04-21 10:45:53 EDT ---

Created attachment 493878 [details]
patch of man pages

According to Bill's comment #1 I'd rather add these options to man pages. The attached patch extends man pages of ypserv, ypxfrd and yppasswdd.
Comment 6 errata-xmlrpc 2012-02-21 00:53:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0205.html

Note You need to log in before you can comment on or make changes to this bug.