Bug 656449 - JON241: [apache] Unable to match the main server vhost during directory and ifmodule discovery
JON241: [apache] Unable to match the main server vhost during directory and i...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity medium (vote)
: ---
: ---
Assigned To: Lukas Krejci
Corey Welton
:
Depends On:
Blocks: jon241-bugs 656495
  Show dependency treegraph
 
Reported: 2010-11-23 13:52 EST by Lukas Krejci
Modified: 2011-05-23 21:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 656495 (view as bug list)
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Krejci 2010-11-23 13:52:11 EST
Description of problem:
$SUBJECT is causing no Directory and IfModule resources to be discovered under the Main vhost.

Version-Release number of selected component (if applicable):
3.0.0

How reproducible:
always

Steps to Reproduce:
1. Have a apache configuration with some <Directory> and <IfModule> sections in the main server configuration (e.g. the default config after installing httpd on fedora for example)
2. have RHQ discover it and inventory it
3. Enable Augeas support in the connection properties of the apache server resource
4. run "discovery -f" on the agent command line
  
Actual results:
Failed discovery entries in the agent.log, no Directory or IfModule resources discovered under the Main vhost.

Expected results:
No exceptions in the agent.log, Directory and IfModule resource appear under the Main vhost.


Additional info:
This is specific to RHQ 3 (i.e. release-3.0.0 branch). RHQ 4 (master) shouldn't exhibit this issue.
Comment 1 Lukas Krejci 2010-11-23 16:15:58 EST
commit ae99b5bc0bf42909308a9d1efc09cee77d06ffc1
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Tue Nov 23 22:09:27 2010 +0100

    a couple of robustness enhancements to the apache plugin:
    BZ 656449 - use the matching algorithm between SNMP values and augeas nodes also
      when matching the vhost node by resource key, because resource key
      in RHQ 3 is based on the SNMP value.
    BZ 652247 - Log the SNMP errors only on DEBUG level during discovery because SNMP isn't
      required for it to work.
    BZ 656476 - Do not fail the discovery if a non-existent directory is used in an Include directive
    BZ 652247, BZ 656491 - Do not choke on invalid/unresolvable hostnames in VirtualHost or ServerName directives
Comment 2 Sunil Kondkar 2010-11-25 04:03:55 EST
Verified on Jon241 build#28

Directory and IfModule resources appear under the Main vhost. No exceptions are found in agent log. Please refer the screenshot.
Comment 3 Corey Welton 2011-05-23 21:16:45 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:16:45 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:16:45 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:16:54 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.