Bug 656495 - [apache] Unable to match the main server vhost during directory and ifmodule discovery
[apache] Unable to match the main server vhost during directory and ifmodule ...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On: 656449
Blocks: jon30-bugs
  Show dependency treegraph
 
Reported: 2010-11-23 16:02 EST by Lukas Krejci
Modified: 2011-05-23 21:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 656449
Environment:
Last Closed: 2011-05-23 21:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (104.70 KB, image/png)
2010-12-09 07:44 EST, Sunil Kondkar
no flags Details

  None (edit)
Description Lukas Krejci 2010-11-23 16:02:25 EST
+++ This bug was initially created as a clone of Bug #656449 +++

Description of problem:
$SUBJECT is causing no Directory and IfModule resources to be discovered under the Main vhost.

Version-Release number of selected component (if applicable):
3.0.0

How reproducible:
always

Steps to Reproduce:
1. Have a apache configuration with some <Directory> and <IfModule> sections in the main server configuration (e.g. the default config after installing httpd on fedora for example)
2. have RHQ discover it and inventory it
3. Enable Augeas support in the connection properties of the apache server resource
4. run "discovery -f" on the agent command line
  
Actual results:
Failed discovery entries in the agent.log, no Directory or IfModule resources discovered under the Main vhost.

Expected results:
No exceptions in the agent.log, Directory and IfModule resource appear under the Main vhost.


Additional info:
This is specific to RHQ 3 (i.e. release-3.0.0 branch). RHQ 4 (master) shouldn't exhibit this issue.
Comment 1 Lukas Krejci 2010-11-26 08:52:40 EST
commit 3e03058e6b276b66affd1529d684882db3cc3a13
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Fri Nov 26 14:48:32 2010 +0100

    A cherry-pick and adaptation of the original fix ae99b5bc0bf42909308a9d1efc09cee77d06ffc1 in release-3.0.0 branch:
    
    a couple of robustness enhancements to the apache plugin:
    BZ 656449 - use the matching algorithm between SNMP values and augeas nodes also
      when matching the vhost node by resource key, because resource key
      in RHQ 3 is based on the SNMP value.
    BZ 652247 - Log the SNMP errors only on DEBUG level during discovery because SNMP isn't
      required for it to work.
    BZ 656476 - Do not fail the discovery if a non-existent directory is used in an Include directive
    BZ 652247, BZ 656491 - Do not choke on invalid/unresolvable hostnames in VirtualHost or ServerName directives
Comment 2 Sunil Kondkar 2010-12-09 07:43:15 EST
Verified on rhq-server-4.0.0-SNAPSHOT build#816.

Directory and IfModule resources appear under the Main vhost. No exceptions are
found in agent log. Please refer the screenshot.
Comment 3 Sunil Kondkar 2010-12-09 07:44:10 EST
Created attachment 467737 [details]
Screenshot
Comment 4 Corey Welton 2011-05-23 21:13:37 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:13:37 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:13:37 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.