This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 656551 - Please Update Spec File to use %ghost on files in /var/run and /var/lock
Please Update Spec File to use %ghost on files in /var/run and /var/lock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bip (Show other bugs)
16
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
http://lists.fedoraproject.org/piperm...
: Reopened
: 676409 (view as bug list)
Depends On:
Blocks: 827166 707294
  Show dependency treegraph
 
Reported: 2010-11-23 18:24 EST by Lennart Poettering
Modified: 2012-05-31 15:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: bip-0.8.8-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 707294 (view as bug list)
Environment:
Last Closed: 2011-12-03 21:40:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2010-11-23 18:24:59 EST
Your package bip appears to include a file in /var/run or /var/lock. With an upcoming change in Rawhide these directories will now be mounted as tmpfs. For details about this change please consult http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html For your package this means that you need add %ghost to all files that are placed in either of these two directories. Please make sure to make this change in time for the F15 cycle. For details about %ghost see http://www.rpm.org/max-rpm-snapshot/s1-rpm-inside-files-list-directives.html#S3-RPM-INSIDE-FLIST-GHOST-DIRECTIVE , for more information on the F15 feature see the feature page https://fedoraproject.org/wiki/Features/var-run-tmpfs . If your package already uses %ghost on these files, feel free to close this bug report right-away. Sorry for this mass bug filing, and if you have any further questions, don't hesitate to ask on fedora-devel or ask me personally. Thank you, Lennart
Comment 1 Brian Lane 2011-02-12 20:44:47 EST
*** Bug 676409 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2011-02-12 20:46:34 EST
bip-0.8.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bip-0.8.7-1.fc15
Comment 3 Fedora Update System 2011-02-12 22:24:34 EST
bip-0.8.7-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bip'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bip-0.8.7-1.fc15
Comment 4 Fedora Update System 2011-03-02 21:45:12 EST
bip-0.8.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Tom Hughes 2011-05-24 07:44:02 EDT
I'm afraid that update doesn't fix it. You need to add a file in /etc/tmpfiles.d to tell systemd to create /var/run/bip at boot time. Suggested contents are:

d /var/run/bip 0755 bip bip -
Comment 6 Derrick Ornelas 2011-11-09 12:24:13 EST
I've encountered this issue in bip-0.8.7-1.fc16

/var/log/messages:
---
Nov  9 12:11:18 dbox bip[2714]: Starting bip: 09-11-2011 12:11:18 FATAL: Cannot write to PID file (/var/run/bip/bip.pid.dbox.2717) No such file or directory
Nov  9 12:11:18 dbox bip[2714]: [FAILED]
Nov  9 12:11:18 dbox systemd[1]: bip.service: control process exited, code=exited status=1
Nov  9 12:11:18 dbox systemd[1]: Unit bip.service entered failed state.
---

The workaround in comment#5 fixes the issue.
Comment 7 Darryl L. Pierce 2011-11-17 14:06:44 EST
(In reply to comment #6)
> I've encountered this issue in bip-0.8.7-1.fc16
> 
> /var/log/messages:
> ---
> Nov  9 12:11:18 dbox bip[2714]: Starting bip: 09-11-2011 12:11:18 FATAL: Cannot
> write to PID file (/var/run/bip/bip.pid.dbox.2717) No such file or directory
> Nov  9 12:11:18 dbox bip[2714]: [FAILED]
> Nov  9 12:11:18 dbox systemd[1]: bip.service: control process exited,
> code=exited status=1
> Nov  9 12:11:18 dbox systemd[1]: Unit bip.service entered failed state.
> ---
> 
> The workaround in comment#5 fixes the issue.

Can you post for me the pid_file line from your bip.conf file? It should read:

pid_file="/var/run/bip/bip.pid"

Also, does /etc/tmpfiles.d/bip.conf exist? And, if so, what is the content of that file.
Comment 8 Brian Lane 2011-11-17 14:31:16 EST
Darryl, the problem was that unless you reboot the pid directory isn't created. I added a call to systemd-tmpfsfiles --create /etc/tmpfsfiles.d/bip.conf
Comment 9 Fedora Update System 2011-11-17 14:33:47 EST
bip-0.8.8-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/bip-0.8.8-1.fc16
Comment 10 Fedora Update System 2011-11-19 00:59:01 EST
Package bip-0.8.8-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bip-0.8.8-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16091/bip-0.8.8-1.fc16
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-12-03 21:40:52 EST
bip-0.8.8-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.