Bug 707294 - Please Update Spec File to use %ghost on files in /var/run and /var/lock
Please Update Spec File to use %ghost on files in /var/run and /var/lock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bip (Show other bugs)
15
All Linux
medium Severity medium
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
http://lists.fedoraproject.org/piperm...
:
Depends On: 656551
Blocks: 827166
  Show dependency treegraph
 
Reported: 2011-05-24 12:02 EDT by Brian Lane
Modified: 2015-06-21 20:07 EDT (History)
7 users (show)

See Also:
Fixed In Version: bip-0.8.7-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 656551
Environment:
Last Closed: 2011-06-07 00:24:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2011-05-24 12:02:28 EDT
+++ This bug was initially created as a clone of Bug #656551 +++

Your package bip appears to include a file in /var/run or /var/lock. With an upcoming change in Rawhide these directories will now be mounted as tmpfs. For details about this change please consult http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html For your package this means that you need add %ghost to all files that are placed in either of these two directories. Please make sure to make this change in time for the F15 cycle. For details about %ghost see http://www.rpm.org/max-rpm-snapshot/s1-rpm-inside-files-list-directives.html#S3-RPM-INSIDE-FLIST-GHOST-DIRECTIVE , for more information on the F15 feature see the feature page https://fedoraproject.org/wiki/Features/var-run-tmpfs . If your package already uses %ghost on these files, feel free to close this bug report right-away. Sorry for this mass bug filing, and if you have any further questions, don't hesitate to ask on fedora-devel or ask me personally. Thank you, Lennart

--- Additional comment from bcl@redhat.com on 2011-02-12 20:44:47 EST ---

*** Bug 676409 has been marked as a duplicate of this bug. ***

--- Additional comment from updates@fedoraproject.org on 2011-02-12 20:46:34 EST ---

bip-0.8.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bip-0.8.7-1.fc15

--- Additional comment from updates@fedoraproject.org on 2011-02-12 22:24:34 EST ---

bip-0.8.7-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bip'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bip-0.8.7-1.fc15

--- Additional comment from updates@fedoraproject.org on 2011-03-02 21:45:12 EST ---

bip-0.8.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from tom@compton.nu on 2011-05-24 07:44:02 EDT ---

I'm afraid that update doesn't fix it. You need to add a file in /etc/tmpfiles.d to tell systemd to create /var/run/bip at boot time. Suggested contents are:

d /var/run/bip 0755 bip bip -
Comment 1 Fedora Update System 2011-06-02 08:58:12 EDT
bip-0.8.7-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bip-0.8.7-2.fc15
Comment 2 Fedora Update System 2011-06-03 01:28:54 EDT
Package bip-0.8.7-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bip-0.8.7-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/bip-0.8.7-2.fc15
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2011-06-07 00:24:06 EDT
bip-0.8.7-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.