Bug 656719 - Please Update Spec File according to https://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Summary: Please Update Spec File according to https://fedoraproject.org/wiki/Packaging...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vpnc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christian Krause
QA Contact: Fedora Extras Quality Assurance
URL: http://lists.fedoraproject.org/piperm...
Whiteboard:
: 734260 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-23 23:45 UTC by Lennart Poettering
Modified: 2011-11-18 15:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-18 15:17:10 UTC
Type: ---


Attachments (Terms of Use)

Description Lennart Poettering 2010-11-23 23:45:52 UTC
Your package vpnc appears to include a file in /var/run or /var/lock. With an upcoming change in Rawhide these directories will now be mounted as tmpfs. For details about this change please consult http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html For your package this means that you need add %ghost to all files that are placed in either of these two directories. Please make sure to make this change in time for the F15 cycle. For details about %ghost see http://www.rpm.org/max-rpm-snapshot/s1-rpm-inside-files-list-directives.html#S3-RPM-INSIDE-FLIST-GHOST-DIRECTIVE , for more information on the F15 feature see the feature page https://fedoraproject.org/wiki/Features/var-run-tmpfs . If your package already uses %ghost on these files, feel free to close this bug report right-away. Sorry for this mass bug filing, and if you have any further questions, don't hesitate to ask on fedora-devel or ask me personally. Thank you, Lennart

Comment 1 Fedora Admin XMLRPC Client 2011-08-31 00:42:49 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Christian Krause 2011-09-04 10:04:34 UTC
According to https://fedoraproject.org/wiki/Packaging:Tmpfiles.d using %ghost is already deprecated, tmpfiles.d service should be used instead.

Comment 3 Christian Krause 2011-09-04 10:06:24 UTC
*** Bug 734260 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2011-09-11 16:32:56 UTC
vpnc-0.5.3-13.svn457.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/vpnc-0.5.3-13.svn457.fc16

Comment 5 Fedora Update System 2011-09-11 16:35:19 UTC
vpnc-0.5.3-13.svn457.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/vpnc-0.5.3-13.svn457.fc15

Comment 6 Fedora Update System 2011-09-25 23:18:34 UTC
vpnc-0.5.3-13.svn457.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-09-30 19:07:12 UTC
vpnc-0.5.3-13.svn457.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.