Bug 657124 - [abrt] vinagre-2.31.4-1.fc14: vnc_framebuffer_get_width: Process /usr/bin/vinagre was killed by signal 11 (SIGSEGV)
Summary: [abrt] vinagre-2.31.4-1.fc14: vnc_framebuffer_get_width: Process /usr/bin/vin...
Keywords:
Status: CLOSED DUPLICATE of bug 650104
Alias: None
Product: Fedora
Classification: Fedora
Component: vinagre
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:dcb8be6b12d7be57163b2c4473e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-25 00:31 UTC by Rob Whalley
Modified: 2010-11-29 14:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-29 14:24:29 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (15.12 KB, text/plain)
2010-11-25 00:31 UTC, Rob Whalley
no flags Details

Description Rob Whalley 2010-11-25 00:31:01 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: vinagre
component: vinagre
crash_function: vnc_framebuffer_get_width
executable: /usr/bin/vinagre
kernel: 2.6.35.6-48.fc14.x86_64
package: vinagre-2.31.4-1.fc14
rating: 4
reason: Process /usr/bin/vinagre was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1290635457
uid: 500

How to reproduce
-----
1. Using SSH to map a local port to the remote port, also using a different port from standard (i.e. not 22)
2. Then make VNC connection to server
3. Occasionally crashes when attempting connection - but not always (intermittant)

Comment 1 Rob Whalley 2010-11-25 00:31:04 UTC
Created attachment 462787 [details]
File: backtrace

Comment 2 zayco 2010-11-25 13:45:26 UTC
Package: vinagre-2.31.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. logg in
2.
3.

Comment 3 Brian Bielinski 2010-11-26 08:26:25 UTC
Package: vinagre-2.31.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Open vinagre (remote desktop viewer)
2. Connect to another linux box (Centos)
3. Connect to a third (Windows XP box - UltraVNC)

Step 3 crashes vinagre pretty regularly.  Also, when I only connect to Centos box, the interface works fine, but then slowly degrades in performance until I have to restart vinagre.  This also did not happen before the latest update.

Comment
-----
This used to work before the latest update...

Comment 4 Gilboa Davara 2010-11-29 12:06:00 UTC
Package: vinagre-2.31.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start vinagre
2. Open and close bookmarks in quick succession
3. Boom

Comment 5 Daniel Berrangé 2010-11-29 14:24:29 UTC
The first two reported crashes are bug 650104 which is in gtk-vnc.   Comment 4 is reporting a completely different problem, likely bug 654350

*** This bug has been marked as a duplicate of bug 650104 ***


Note You need to log in before you can comment on or make changes to this bug.