Bug 650104 - Crash in mouse motion event handler if VNC connection has not fully initialized
Summary: Crash in mouse motion event handler if VNC connection has not fully initialized
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk-vnc
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a2233e1c4b713e3e00bfe7f58b0...
: 650402 651038 657124 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-05 08:33 UTC by Douglas Furlong
Modified: 2010-12-02 19:08 UTC (History)
9 users (show)

Fixed In Version: gtk-vnc-0.4.2-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-02 19:08:36 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (26.83 KB, text/plain)
2010-11-05 08:33 UTC, Douglas Furlong
no flags Details

Description Douglas Furlong 2010-11-05 08:33:26 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: python /usr/share/virt-manager/virt-manager.py
component: virt-manager
crash_function: vnc_framebuffer_get_width
executable: /usr/bin/python
kernel: 2.6.35.6-48.fc14.x86_64
package: virt-manager-0.8.5-1.fc14
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1288943072
uid: 500

comment
-----
Upgraded from Fedora 13, when attempting to open a password protected display I am greeted with this error.

I did notice while trying to shut down the guest (took for ever) I was able to connect to the display (yet see nothing) with out any issues.

How to reproduce
-----
1. Attempting to open the view/display of a windows 7 guest.

Comment 1 Douglas Furlong 2010-11-05 08:33:30 UTC
Created attachment 458022 [details]
File: backtrace

Comment 2 Daniel Berrangé 2010-11-05 13:14:19 UTC
If you can reproduce this problem reliably, then can you try this update which has a small chance of helping fix the problem:

https://admin.fedoraproject.org/updates/gtk-vnc-0.4.2-1.fc14

Comment 3 Daniel Berrangé 2010-11-08 10:13:51 UTC
*** Bug 650402 has been marked as a duplicate of this bug. ***

Comment 4 Douglas Furlong 2010-11-08 10:20:39 UTC
Though I seemed to be able to duplicate the bug at the time (re-start virt manager and try and connect), I am no longer able to duplicate this behaviour.

Comment 5 Cole Robinson 2010-11-17 23:05:03 UTC
Reassigning to gtk-vnc.

Comment 6 Daniel Berrangé 2010-11-22 21:42:21 UTC
*** Bug 651038 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2010-11-29 14:15:16 UTC
gtk-vnc-0.4.2-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gtk-vnc-0.4.2-2.fc14

Comment 8 Daniel Berrangé 2010-11-29 14:24:29 UTC
*** Bug 657124 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2010-11-29 21:27:48 UTC
gtk-vnc-0.4.2-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-vnc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gtk-vnc-0.4.2-3.fc14

Comment 10 Fedora Update System 2010-12-02 19:08:14 UTC
gtk-vnc-0.4.2-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.