Bug 657370 - New package request: omping - Utility to test IP multicast functionality
Summary: New package request: omping - Utility to test IP multicast functionality
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: omping
Version: 6.0
Hardware: All
OS: All
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact:
Maxim Svistunov
URL:
Whiteboard:
: 543938 (view as bug list)
Depends On: 663053
Blocks: 543938
TreeView+ depends on / blocked
 
Reported: 2010-11-25 16:04 UTC by Jan Friesse
Modified: 2018-11-14 20:11 UTC (History)
13 users (show)

Fixed In Version: omping-0.0.1-4.el6
Doc Type: Release Note
Doc Text:
Omping is now fully supported Open Multicast Ping (Omping) is a tool to test the IP multicast functionality, primarily in the local network. This utility allows users to test IP multicast functionality and assists in the diagnosing whether a problem is in the network configuration or there is a bug. In Red Hat Enterprise Linux 6, Omping was previously provided as a Technology Preview and it is now fully supported.
Clone Of:
Environment:
Last Closed: 2011-05-19 12:28:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0528 normal SHIPPED_LIVE new package: omping 2011-05-18 17:44:54 UTC

Description Jan Friesse 2010-11-25 16:04:38 UTC
Description of problem:
RHEL 6.0 currently doesn't contain any tool for testing IP multicast functionality. This is problem for (specially) Corosync users (so whole RHCS). There is currently bug https://bugzilla.redhat.com/show_bug.cgi?id=543938 for creation of such tool.

Tool is now in Fedora Rawhide and Fedora 14 named as omping, maintained by me (FAS honzaf). Original Fedora spec review bug is https://bugzilla.redhat.com/show_bug.cgi?id=656855

SPEC and SRPM for review:
SPEC: http://honzaf.fedorapeople.org/omping/omping.spec
SRPM: http://honzaf.fedorapeople.org/omping/omping-0.0.1-2.fc14.src.rpm

Version-Release number of selected component (if applicable):
RHEL 6.0

Comment 7 Jan Friesse 2010-11-30 10:34:00 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:
RHEL 6 repos doesn't contain any tool for checking multicast communications.

Consequence:
This may lead to problems if customer want to use Corosync (RHCS) and their network equipment/OS Firewall is badly configured. Corosync (RHCS) doesn't work and customer has no idea why.

Fix:
Implementation of tool to test IP multicast communication.

Result:
Customer/GSS can test multicast and should be able to find out enough informations to decide, if problem is hidden in network configuration or it's different problem (like bug)

Comment 9 Steven Dake 2010-12-01 18:44:37 UTC
*** Bug 543938 has been marked as a duplicate of this bug. ***

Comment 12 Ryan Lerch 2011-02-28 00:14:10 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,11 +1 @@
-Cause:
+Open Multicast Ping (Omping) is a tool to test the IP multicast functionality primarily in the local network. This utility allows users to test multicast and assists in the diagnosing if an issues is in the network configuration or elsewhere (i.e. a bug). In Red Hat Enterprise Linux 6 omping is provided as a Technology Preview.-RHEL 6 repos doesn't contain any tool for checking multicast communications.
-
-Consequence:
-This may lead to problems if customer want to use Corosync (RHCS) and their network equipment/OS Firewall is badly configured. Corosync (RHCS) doesn't work and customer has no idea why.
-
-Fix:
-Implementation of tool to test IP multicast communication.
-
-Result:
-Customer/GSS can test multicast and should be able to find out enough informations to decide, if problem is hidden in network configuration or it's different problem (like bug)

Comment 14 Jan Friesse 2011-03-15 14:17:00 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1,3 @@
-Open Multicast Ping (Omping) is a tool to test the IP multicast functionality primarily in the local network. This utility allows users to test multicast and assists in the diagnosing if an issues is in the network configuration or elsewhere (i.e. a bug). In Red Hat Enterprise Linux 6 omping is provided as a Technology Preview.+Open Multicast Ping (Omping) is a tool to test the IP multicast functionality primarily in the local network. This utility allows users to test multicast and assists in the diagnosing if an issues is in the network configuration or elsewhere (i.e. a bug). In Red Hat Enterprise Linux 6 omping is provided as a Technology Preview.
+
+This is test

Comment 15 Jan Friesse 2011-03-15 14:17:50 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,3 +1 @@
-Open Multicast Ping (Omping) is a tool to test the IP multicast functionality primarily in the local network. This utility allows users to test multicast and assists in the diagnosing if an issues is in the network configuration or elsewhere (i.e. a bug). In Red Hat Enterprise Linux 6 omping is provided as a Technology Preview.
+Open Multicast Ping (Omping) is a tool to test the IP multicast functionality primarily in the local network. This utility allows users to test multicast and assists in the diagnosing if an issues is in the network configuration or elsewhere (i.e. a bug). In Red Hat Enterprise Linux 6 omping is provided as a Technology Preview.-
-This is test

Comment 16 errata-xmlrpc 2011-05-19 12:28:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0528.html


Note You need to log in before you can comment on or make changes to this bug.