Bug 657441 - Windows could not create a partition on disk 0 for installation
Windows could not create a partition on disk 0 for installation
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virtio-win (Show other bugs)
5.6
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier2 710871
  Show dependency treegraph
 
Reported: 2010-11-25 22:15 EST by Suqin Huang
Modified: 2011-07-11 06:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 710871 (view as bug list)
Environment:
Last Closed: 2011-07-11 06:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vrozenfe: needinfo-


Attachments (Terms of Use)
installation_error (119.08 KB, image/png)
2010-11-25 22:15 EST, Suqin Huang
no flags Details

  None (edit)
Description Suqin Huang 2010-11-25 22:15:05 EST
Created attachment 462988 [details]
installation_error

Description of problem:


Version-Release number of selected component (if applicable):
kvm-83-215.el5

How reproducible:
100%

Steps to Reproduce:
1. install guest with the following cmd:
/usr/libexec/qemu-kvm -drive file=/usr/images/win2008-32-virtio.qcow2,index=0,if=virtio,media=disk,cache=none,format=qcow2,boot=on -net nic,vlan=0,model=virtio,macaddr=9a:2d:20:42:2a:60 -net tap,vlan=0,script=/usr/scripts/qemu-ifup-switch,downscript=no -m 2048 -smp 2,cores=1,threads=1,sockets=2 -drive file=/usr/isos/ISO/Win2008/32/en_windows_server_2008_datacenter_enterprise_standard_x86_dvd_X14-26710.iso,media=cdrom,index=1 -fda /usr/share/virtio-win/virtio-drivers-1.0.0-45801.vfd -cpu qemu64,+sse2 -redir tcp:5000::10023 -vnc :0  -rtc-td-hack -M rhel5.6.0 -usbdevice tablet -boot d -monitor stdio

2.
3.
  
Actual results:
Windows could not create a partition on disk 0 (image is attached)

Expected results:


Additional info:
1. host info 
kernel: 2.6.18-232.el5
cpu:

processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping	: 4
cpu MHz		: 1600.000
cache size	: 8192 KB

flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx rdtscp lm constant_tsc ida nonstop_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 sse4_2 popcnt lahf_lm

2. virtio-win:
https://brewweb.devel.redhat.com/buildinfo?buildID=144654

3. guest can be installed with ide 
4. guest can be installed with virtio if the image already be formatted.
5. guest Win2008-32
Comment 1 Suqin Huang 2010-11-26 00:15:24 EST
The same issue when I install with raw file
Comment 2 Suqin Huang 2010-11-26 00:18:13 EST
I can install Win2008R2 successfully.
Comment 3 Suqin Huang 2010-11-26 03:25:04 EST
pls ignore this message:
"4. guest can be installed with virtio if the image already be formatted."

Sometimes can install successfully with the formatted image, sometime can not.

The following error display:
Windows cannot be installed to this hard disk space, Windows must be installed to a partition formmatted as NTFS.

format methods:
1. attach to a guest and format with cmd:
format I: /FS:NTFS /V:local /y

2. use a pre-installed image.
Comment 5 RHEL Product and Program Management 2011-01-11 16:15:29 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2011-01-11 17:56:54 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 12 Vadim Rozenfeld 2011-07-04 05:41:34 EDT
I cannot reproduce this problem on my system.
What is the win2008-32-virtio.qcow2 size?
Thank you,
Vadim.
Comment 13 Suqin Huang 2011-07-07 21:54:32 EDT
repeat 20times can not reproduce with 
virtio-win https://brewweb.devel.redhat.com/buildinfo?buildID=157007
guest: win2008-32 (20G)

kvm: kvm-83-238.el5  
kernel: 2.6.18-269.el5
Comment 14 Vadim Rozenfeld 2011-07-08 01:49:45 EDT
(In reply to comment #13)
> repeat 20times can not reproduce with 
> virtio-win https://brewweb.devel.redhat.com/buildinfo?buildID=157007
> guest: win2008-32 (20G)
> 
> kvm: kvm-83-238.el5  
> kernel: 2.6.18-269.el5

Thank you.
Could you close it a s NOTABUG?
Best regards,
Vadim.
Comment 15 Vadim Rozenfeld 2011-07-11 06:12:35 EDT
Closing this bug, based on comment #13
https://bugzilla.redhat.com/show_bug.cgi?id=657441#c13

Note You need to log in before you can comment on or make changes to this bug.