Bug 710871 - Windows could not create a partition on disk 0 for installation
Windows could not create a partition on disk 0 for installation
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.1
Unspecified Unspecified
medium Severity medium
: rc
: 6.3
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Triaged
Depends On: 657441
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-06-05 08:12 EDT by Ronen Hod
Modified: 2014-12-14 19:53 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 657441
Environment:
Last Closed: 2011-07-11 06:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ronen Hod 2011-06-05 08:12:07 EDT
+++ This bug was initially created as a clone of Bug #657441 +++

Created attachment 462988 [details]
installation_error

Description of problem:


Version-Release number of selected component (if applicable):
kvm-83-215.el5

How reproducible:
100%

Steps to Reproduce:
1. install guest with the following cmd:
/usr/libexec/qemu-kvm -drive file=/usr/images/win2008-32-virtio.qcow2,index=0,if=virtio,media=disk,cache=none,format=qcow2,boot=on -net nic,vlan=0,model=virtio,macaddr=9a:2d:20:42:2a:60 -net tap,vlan=0,script=/usr/scripts/qemu-ifup-switch,downscript=no -m 2048 -smp 2,cores=1,threads=1,sockets=2 -drive file=/usr/isos/ISO/Win2008/32/en_windows_server_2008_datacenter_enterprise_standard_x86_dvd_X14-26710.iso,media=cdrom,index=1 -fda /usr/share/virtio-win/virtio-drivers-1.0.0-45801.vfd -cpu qemu64,+sse2 -redir tcp:5000::10023 -vnc :0  -rtc-td-hack -M rhel5.6.0 -usbdevice tablet -boot d -monitor stdio

2.
3.
  
Actual results:
Windows could not create a partition on disk 0 (image is attached)

Expected results:


Additional info:
1. host info 
kernel: 2.6.18-232.el5
cpu:

processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping	: 4
cpu MHz		: 1600.000
cache size	: 8192 KB

flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx rdtscp lm constant_tsc ida nonstop_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 sse4_2 popcnt lahf_lm

2. virtio-win:
https://brewweb.devel.redhat.com/buildinfo?buildID=144654

3. guest can be installed with ide 
4. guest can be installed with virtio if the image already be formatted.
5. guest Win2008-32

--- Additional comment from shuang@redhat.com on 2010-11-26 00:15:24 EST ---

The same issue when I install with raw file

--- Additional comment from shuang@redhat.com on 2010-11-26 00:18:13 EST ---

I can install Win2008R2 successfully.

--- Additional comment from shuang@redhat.com on 2010-11-26 03:25:04 EST ---

pls ignore this message:
"4. guest can be installed with virtio if the image already be formatted."

Sometimes can install successfully with the formatted image, sometime can not.

The following error display:
Windows cannot be installed to this hard disk space, Windows must be installed to a partition formmatted as NTFS.

format methods:
1. attach to a guest and format with cmd:
format I: /FS:NTFS /V:local /y

2. use a pre-installed image.

--- Additional comment from pm-rhel@redhat.com on 2011-01-11 16:15:29 EST ---

This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

--- Additional comment from pm-rhel@redhat.com on 2011-01-11 17:56:54 EST ---

This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 1 Ronen Hod 2011-06-05 08:13:23 EDT
Cloned a RHEL5.6 bug since it is probably relevant to RHEL6 as well.
Comment 3 Vadim Rozenfeld 2011-07-11 06:17:30 EDT
This bug was cloned from 5.6 where it could not be reproduced any more.
Closing this bug, based on comment
https://bugzilla.redhat.com/show_bug.cgi?id=657441#c13

Note You need to log in before you can comment on or make changes to this bug.