Bug 657647 - kdm is not started by systemd-15
kdm is not started by systemd-15
Status: CLOSED DUPLICATE of bug 657785
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-26 19:36 EST by Charlie Moschel
Modified: 2010-11-27 22:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-27 22:54:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie Moschel 2010-11-26 19:36:02 EST
Description of problem:

Since last rawhide update my boot hangs: kdm is not started and there are no working virtual consoles started for text mode recovery.  This is an i686 VM

Version-Release number of selected component (if applicable):

Systemd-15, rawhide update on 25-Nov-10
 
Actual results:

Boot hangs, but GPM is started and systemd responds to ctl-alt-delete.  No text consoles are available.

Expected results:

Normal KDM login screen.

Additional info:

Reverting to systemd-14 fails the same way
Reverting to systemd-13 boots normally, kdm starts up OK.

Looking through diffs of serial console logs this is logged in systemd-15 but not systemd-13:

[  OK  ]
[    8.196951] systemd[1]: prefdm.service: main process exited, code=exited, status=1
[    8.202106] systemd[1]: prefdm.service holdoff time over, scheduling restart.
[    8.205441] systemd[1]: Unit prefdm.service entered failed state.
[    8.209428] systemd[1]: systemd-ask-password-plymouth.path/stop would stop a running service.
[    8.221342] systemd[1]: Deleting systemd-ask-password-plymouth.path/stop to minimize impact.
Starting Display Manager...
[  OK  ]
[    8.260953] systemd[1]: prefdm.service: main process exited, code=exited, status=1
Starting sm-client: [    8.270261] systemd[1]: prefdm.service holdoff time over, scheduling restart.
[    8.279203] systemd[1]: Unit prefdm.service entered failed state.
[    8.280941] systemd[1]: systemd-ask-password-plymouth.path/stop would stop a running service.
[    8.288385] systemd[1]: Deleting systemd-ask-password-plymouth.path/stop to minimize impact.
Starting Display Manager...
[    8.324815] systemd[1]: prefdm.service: main process exited, code=exited, status=1
[    8.340739] systemd[1]: prefdm.service holdoff time over, scheduling restart.
[    8.342778] systemd[1]: Unit prefdm.service entered failed state.
[    8.350350] systemd[1]: systemd-ask-password-plymouth.path/stop would stop a running service.
[    8.352750] systemd[1]: Deleting systemd-ask-password-plymouth.path/stop to minimize impact.
Starting Display Manager...
[  OK  ]
[    8.379113] systemd[1]: prefdm.service: main process exited, code=exited, status=1
[    8.386263] systemd[1]: prefdm.service holdoff time over, scheduling restart.
[    8.389889] systemd[1]: Unit prefdm.service entered failed state.
[    8.393003] systemd[1]: systemd-ask-password-plymouth.path/stop would stop a running service.
[    8.400210] systemd[1]: Deleting systemd-ask-password-plymouth.path/stop to minimize impact.
Starting Display Manager...
[    8.433383] systemd[1]: prefdm.service: main process exited, code=exited, status=1
[    8.439953] systemd[1]: prefdm.service holdoff time over, scheduling restart.
[    8.454222] systemd[1]: Unit prefdm.service entered failed state.
[    8.460190] systemd[1]: systemd-ask-password-plymouth.path/stop would stop a running service.
[    8.465586] systemd[1]: Deleting systemd-ask-password-plymouth.path/stop to minimize impact.
Starting Display Manager...
[    8.503005] systemd[1]: prefdm.service: main process exited, code=exited, status=1
[    8.512842] systemd[1]: prefdm.service holdoff time over, scheduling restart.
[    8.520322] systemd[1]: Unit prefdm.service entered failed state.
[    8.524279] systemd[1]: systemd-ask-password-plymouth.path/stop would stop a running service.
[    8.528496] systemd[1]: Deleting systemd-ask-password-plymouth.path/stop to minimize impact.
Starting Display Manager...
[    8.534267] systemd[1]: prefdm.service start request repeated too quickly, refusing to start.
Starting Display Manager ESC[1;31mfailedESC[0m.

Fedora release 15 (Rawhide)
Kernel 2.6.36.1-7.rc1.fc15.i686 on an i686 (ttyS0)

localhost login: Starting automount: [  OK  ]
[    9.175488] avahi-daemon[733]: Registering new address record for fe80::20c:29ff:fe50:b5d2 on eth0.*.
Starting Network Time Service...
[   13.870068] systemd[1]: Startup finished in 3s 786ms 316us (kernel) + 1s 10ms 907us (initrd) + 9s 72ms 833us (userspace) = 13s 870ms 56us.
Comment 1 Charlie Moschel 2010-11-26 19:48:02 EST
xdm works OK (set DISPLAYMANAGER=KDM in /etc/sysconfig/desktop, rather than KDE).  Don't have gdm installed to try.

Should component be changed to KDM?
Comment 2 Charlie Moschel 2010-11-26 20:25:15 EST
(In reply to comment #1)
> xdm works OK (set DISPLAYMANAGER=KDM in /etc/sysconfig/desktop, rather than
> KDE).  Don't have gdm installed to try.
> 
> Should component be changed to KDM?

s/=KDM/=XDM
Comment 3 Charlie Moschel 2010-11-27 22:54:57 EST
Workaround: create /etc/tmpfiles.d/kdm.conf with the line:
d /var/run/kdm/ 01777 root root -

(from bug 657785

*** This bug has been marked as a duplicate of bug 657785 ***

Note You need to log in before you can comment on or make changes to this bug.