Bug 657785 - /var/run/kdm/ fails to be created on boot
/var/run/kdm/ fails to be created on boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: EasyFix
: 657603 657647 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-27 16:36 EST by goffrie
Modified: 2010-12-08 14:12 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-29 13:57:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum-log for today (6.14 KB, text/plain)
2010-12-08 02:47 EST, dominique
no flags Details

  None (edit)
Description goffrie 2010-11-27 16:36:31 EST
Description of problem:
Since /var/run/ is now tmpfs, /var/run/kdm/ is deleted on reboot. Nothing recreates it, causing KDM to fail to start.

Version-Release number of selected component (if applicable):
kde-settings-kdm-4.5-11.fc15.noarch (is this the right thing?)

How reproducible:
Always?

Steps to Reproduce:
1. Have /var/run on tmpfs
2. Use KDM
3.
  
Actual results:
KDM falls over when /var/run/kdm/ doesn't exist.

Expected results:
/var/run/kdm/ is created before KDM starts.

Additional info:
This should be easily fixable by adding a file to /etc/tmpfiles.d/ which creates /var/run/kdm/ with mode 01777.
Comment 1 Kevin Kofler 2010-11-27 17:39:50 EST
*** Bug 657603 has been marked as a duplicate of this bug. ***
Comment 2 Charlie Moschel 2010-11-27 22:54:57 EST
*** Bug 657647 has been marked as a duplicate of this bug. ***
Comment 3 Charlie Moschel 2010-11-27 23:01:40 EST
(In reply to comment #0)
> Additional info:
> This should be easily fixable by adding a file to /etc/tmpfiles.d/ which
> creates /var/run/kdm/ with mode 01777.

I can confirm the suggested workaround above works, and kdm starts normally:

$ cat /etc/tmpfiles.d/kdm.conf
d /var/run/kdm/ 01777 root root -
Comment 4 Rex Dieter 2010-11-29 13:57:42 EST
%changelog
* Mon Nov 29 2010 Rex Dieter <rdieter@fedoraproject.org> 4.6-1
- init 4.6
- /var/run/kdm/ fails to be created on boot (#657785)
Comment 5 dominique 2010-12-08 02:45:47 EST
Today there are update, after reboot kdm don't work again...
For test I remove /etc/tmpfiles.d/kdm.conf" with content "d /var/run/kdm/ 01777 root root - for same result; kdm don't work...
Any Idea? 

List of update in attach file
Comment 6 dominique 2010-12-08 02:47:30 EST
Created attachment 467403 [details]
yum-log for today
Comment 7 goffrie 2010-12-08 07:31:02 EST
that is a different bug; check /var/log/kdm.log (I had a problem with an unrecognized argument -nr, so I removed it from /etc/kde/kdm/kdmrc and it worked)
Comment 8 Charlie Moschel 2010-12-08 08:06:27 EST
I saw the same a few days ago, and found my test system did not have a default boot target for some reason.  Not sure why it worked before, but KDM started OK once I did:

# ln -sf /lib/systemd/systemd/graphical.target /etc/systemd/system/default.target

I didn't open a bug because I thought it was a problem on my end, but maybe it is your case too.
Comment 9 dominique 2010-12-08 12:00:12 EST
In the kdm.log, I also have "unrecognized argument -nr", I remove it from /etc/kde/kdm/kdmrc and kdm launch...

But there is another problem, my keyboard don't work, and I am unable to loggin.
In the kdm.log I have this:

(==) Using system config directory "/usr/share/X11/xorg.conf.d"
resize called 1440 900
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Internal error:   Could not resolve keysym XF86TouchpadOn
> Internal error:   Could not resolve keysym XF86TouchpadOff
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            No Symbols named "latin9" in the include file "us"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server.

When I use gdm, my keyboard work fine.
Comment 10 Rex Dieter 2010-12-08 12:05:32 EST
Please file separate bugs for other issues, thanks.
Comment 11 dominique 2010-12-08 13:10:30 EST
(In reply to comment #10)
> Please file separate bugs for other issues, thanks.

OK
New bug is here: Bug 661395
Comment 12 Kevin Kofler 2010-12-08 13:53:29 EST
> In the kdm.log, I also have "unrecognized argument -nr", I remove it from
> /etc/kde/kdm/kdmrc and kdm launch...

Well, can we sed this in %post (like we do for configurations referring to old KDE 3 KDM themes)?
Comment 13 Rex Dieter 2010-12-08 14:10:57 EST
Sure.

One thing I wish *could* be done sanely:

Package as distributed with Fedora GA mark it
%config

and any subsequent updates,
%config(noreplace)

(instead of always (noreplace))
Comment 14 Rex Dieter 2010-12-08 14:12:02 EST
(though I guess that wouldn't help here, nvm)

Note You need to log in before you can comment on or make changes to this bug.