Bug 65770 - ctree.insert_node segfault
ctree.insert_node segfault
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: pygtk2 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
: 66831 66836 67239 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-05-31 12:04 EDT by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-27 10:58:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the fix. (573 bytes, patch)
2002-06-10 08:41 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2002-05-31 12:04:34 EDT
Description of Problem: 
I get a segfault with some pygtk code 
 
Version-Release number of selected component (if applicable): 
pygtk-0.6.9-3 
 
How Reproducible: 
100% 
 
Steps to Reproduce: 
$ python 
>>> import gtk 
>>> tree = gtk.CTree() 
>>> node = tree.insert_node (None, None, ['make']) 
>>> tree.insert_node (node, None, ['model'])
Comment 1 Tim Waugh 2002-06-10 08:41:27 EDT
Created attachment 60270 [details]
Here is the fix.
Comment 2 Tim Waugh 2002-06-17 10:02:32 EDT
(This prevents printconf-gui from being functional.)
Comment 3 Tim Waugh 2002-06-17 11:47:16 EDT
*** Bug 66831 has been marked as a duplicate of this bug. ***
Comment 4 Tim Waugh 2002-06-17 14:23:55 EDT
*** Bug 66836 has been marked as a duplicate of this bug. ***
Comment 5 Tim Waugh 2002-06-21 10:32:43 EDT
*** Bug 67239 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2002-06-27 10:58:36 EDT
1.99.10-5.1.
Comment 7 Matt Wilson 2002-07-22 15:42:18 EDT
fixed in 1.99.11.

Note You need to log in before you can comment on or make changes to this bug.